Jump to content


Photo

HOW TO: Run Emby behind Torguard VPN


  • Please log in to reply
59 replies to this topic

#41 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted 11 January 2019 - 10:39 PM

@notla49285 , @jmatsukawa and anyone else, I've updated the OP. Is it more clear/helpful? 


Edited by Doofus, 11 January 2019 - 10:40 PM.


#42 jmatsukawa OFFLINE  

jmatsukawa

    Newbie

  • Members
  • 4 posts
  • Local time: 11:57 PM

Posted 11 January 2019 - 11:01 PM

Looks good to me, I'm pretty sure that would have kept me on track.


  • Doofus likes this

#43 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted 11 January 2019 - 11:02 PM

Looks good to me, I'm pretty sure that would have kept me on track.

 

That's good. Thanks for the input :)



#44 notla49285 OFFLINE  

notla49285

    Advanced Member

  • Members
  • 244 posts
  • Local time: 06:57 AM

Posted 12 January 2019 - 08:57 AM

I'm in and out at the moment, I haven't touched TorGuard since my last post on this thread so have been using AirVPN and my domain as detailed. When I get back I'll read through the updated OP properly and have another go, may be tomorrow.

#45 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted 12 January 2019 - 01:41 PM

I'm not putting this in the guide, but there's another way to choose an IP. You can also use the IP shown in the app when you run it, normally. This is actually what I did. I experimented with using different servers in the app, to see which one gave me the best bandwidth, then I used that IP for port forwarding.

#46 HaraldBluetooth OFFLINE  

HaraldBluetooth

    Advanced Member

  • Members
  • 67 posts
  • Local time: 07:57 AM

Posted 15 January 2019 - 06:30 AM

Thanks Doofus for starting this topic :)

 

Mullvad VPN is also an option if you are looking for a no-logging VPN provider. 

 

They support forwarded ports, and you can manage your forwarded ports on their web site. You can install the VPN service on all the devices you want, but only 5 simultaneous connections. 

 

If you are using multiple devices that share the same account and connect to the same server, then only the most recently connected device will have the ports forwarded to it. In that case you have to connect each device to a different Mullvad server, then you have all your forwarded ports available on your devices.


Edited by HaraldBluetooth, 15 January 2019 - 06:34 AM.

  • Doofus likes this

#47 bifflowman OFFLINE  

bifflowman

    Newbie

  • Members
  • 6 posts
  • Local time: 12:57 AM

Posted Yesterday, 07:50 PM

Thanks of this tutorial. I noticed you said you are using this with pfsense. Is pfsense necessary to get this to work because I'm not having an luck? If it is, got any recommendations on decent hardware for running pfsense for emby? I was thinking this one  with 8gb ram Core i7

 

If anyone can checkout my setup and let me know of any problems, I'd really appreciate it. 

 

My dedicated SOCKS5 IP with Torgaurd

 

5c3fbf7006205_torguardportdedicatedip.pn

 

My Torguard app settings

5c3fbfbc700dc_torguardapp.png

 

My Router port forwarding with the torguard IP set as the external iP

5c3fbfd731c43_router.png

 

My Emby settings.

5c3fc05531739_emby.png



#48 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Yesterday, 08:08 PM

I can't take a good look, right now, but I'll have a look, later. And you don't need pfsense. That guide should be all you need to do. But a quick look at your TG interface, you don't appear to have configured it.

Make sure you complete step six, fully.

Edited by Doofus, Yesterday, 08:09 PM.

  • bifflowman likes this

#49 bifflowman OFFLINE  

bifflowman

    Newbie

  • Members
  • 6 posts
  • Local time: 12:57 AM

Posted Yesterday, 08:25 PM

I can't take a good look, right now, but I'll have a look, later. And you don't need pfsense. That guide should be all you need to do. But a quick look at your TG interface, you don't appear to have configured it.

Make sure you complete step six, fully.

 

 

Thanks. I think I did that correctly, but I could be wrong. I added the SOCKS5 IP in the App settings under the server tab, selected the correct country and gave it a name. Then entered the following according to the torguard email they sent.

 

Protocol: udp
Port/Auth: 1912
HMAC: SHA256
 
I'm not sure what to use for cypher so I left it default. I just tried various cyphers without luck. Tunnel type I left as OpenVPN.
 
5c3fcb2c87a08_backend.png
5c3fcb3ad8180_front.png


#50 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Yesterday, 08:39 PM

I'll take a closer look, a little later

#51 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Yesterday, 10:44 PM

Go into port management and change your config to something like this. Just forward the TCP port, and allow all source IPs.

 

5c3fec03f0580_Snapshot_132.jpg



#52 bifflowman OFFLINE  

bifflowman

    Newbie

  • Members
  • 6 posts
  • Local time: 12:57 AM

Posted Yesterday, 11:22 PM

Go into port management and change your config to something like this. Just forward the TCP port, and allow all source IPs.

 

 

 

 

Thanks. I just double checked. I have that. Still not connecting.

5c3ff4b89dc5e_port.png



#53 bifflowman OFFLINE  

bifflowman

    Newbie

  • Members
  • 6 posts
  • Local time: 12:57 AM

Posted Yesterday, 11:32 PM

Could the problem be the local IP that torguard is using? I can't add this as the local IP in my routers port forward because it doesn't start with 192.

5c3ff722c1642_Capture.png



#54 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Yesterday, 11:32 PM

Did you restart the server?



#55 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Yesterday, 11:36 PM

Wait! Why are you forwarding port 8093? The server is on (according to your screenshot) 8096

 

5c3ff82093669_5c3fc05531739_emby.png


  • bifflowman likes this

#56 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Yesterday, 11:39 PM

Your router is forwarding 8093, too. You need to change those.



#57 bifflowman OFFLINE  

bifflowman

    Newbie

  • Members
  • 6 posts
  • Local time: 12:57 AM

Posted Today, 12:07 AM

Good lord. I'm an idiot. I thought the public and local ports had to be different. It's working. Thanks so much for waking me up to that.


  • Doofus likes this

#58 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Today, 12:10 AM

Good lord. I'm an idiot. I thought the public and local ports had to be different. It's working. Thanks so much for waking me up to that.

 

Happy to help. Enjoy your VPN :)


  • bifflowman likes this

#59 bifflowman OFFLINE  

bifflowman

    Newbie

  • Members
  • 6 posts
  • Local time: 12:57 AM

Posted Today, 02:00 AM

Sorry for going off topic but do you need SSL if you are using a VPN?
 
Thanks again for all of the help you provided!


#60 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 10094 posts
  • Local time: 10:57 PM

Posted Today, 02:48 AM

 

Sorry for going off topic but do you need SSL if you are using a VPN?
 
Thanks again for all of the help you provided!

 

 

No. The TG app will encrypt all internet activity on that machine, between you and the proxy. And they use stealth proxies, which means that by the time the data hits the internet, not only is all the identifying info removed but the traffic looks like generic traffic. The intention being that your ISP doesn't even know it's a VPN. They claim they have no DNS leakage. You can still use SSL, if you wish. I chose to use a VPN instead of a domain with SSL, because it's just easier. They have layers of their own security. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users