Jump to content

Transcoding abschalten


Pfalznase
 Share

Recommended Posts

Pfalznase

Hallo Leute, ich habe ein Problem mit dem Software Transcoding,

ich möchte gerne das Transcodieren komplett abschalten damit Emby die Filme unverändert Streamt,

denn seit der Version 3.2.50  habe ich das Problem von Block Bildung, Bild rucklern, Ton Spüngen und Abrüchen in verschidenen Serien und Filmen, reproduzierbar.

 

Ich hatte gehofft das sich das mit der Version 3.2.60 bessert , leider habe ich auch mit der neuen Version noch Probleme.

 

Ich habe die Synology DS418j (die wie bekannt keine Transcodierungsunterstüzung hat) in Betrieb mit der Nvidia Shield TV , davor hatte ich einen Raspberry PI 2 mit Librelec,

bevor Fragen auftauchen ja das Problem hatte ich auch auf dem PI und ich kann es auch mit Emby Theater auf meinem Windows PC reproduzieren (es scheint also ein Server Problem zu sein).

 

Wenn ich die selben Filme, Serien mit einem Mediaplayer auf dem PC direkt von der DS-418j im Ordner starte habe ich keine Probleme,

also kann ich das Netzerk ausschliessen (Netzwerk upload ca 40MB/s Download ca 100MB/s.

 

Hat noch jemand ein ähnliches Problem? Ist das Problem Bekannt?

 

Logs könnte ich wenn benötigt am Wochenende liefern.

 

Danke im Voraus

 

 

Link to comment
Share on other sites

pünktchen

Hast du bei deinen Bibliotheken auch einen optionalen Netzwerkpfad, also eine Freigabe eingetragen?

Sind bei deinen Videos auf der Detailseite, unterhalb der Darsteller die Videocodec Informationen aufgelistet?

Link to comment
Share on other sites

Pfalznase

Hast du bei deinen Bibliotheken auch einen optionalen Netzwerkpfad, also eine Freigabe eingetragen?

Sind bei deinen Videos auf der Detailseite, unterhalb der Darsteller die Videocodec Informationen aufgelisteot?

optionalen Netzwerkpfad habe ich bisher noch nicht eingetragen -> werde ich nachholen

Videocodecs werden über all gelistet

Link to comment
Share on other sites

Pfalznase

Hallo

ich habe mir am Wochenende nochmal Zeit genommen

und habe die ganzen Serien und Filme ,mit denen ich Probleme habe,

vom Backup auf die Diskstation kopiert ....

damit haben sich zumindest bei einigen Serien die Probleme erledigt,

anscheinend waren beim ersten kopieren die Cointainer beschädigt worden,

warum auch immer.

 

Ich werde das weiter beobachten ...

Danke

Link to comment
Share on other sites

  • 2 weeks later...
Pfalznase

Hier die Logs

 

Habe einen kurzen Ausschnitt von Travelers S02E02 angesehen und massive Probleme gesehen und gehört.

 

Tonversatz und Blockbildung das Serverlog und FFmpeg Log hab ich angehängt.

 

Hatte plötzlich vor 5 Tagen wieder dieses Problem, konnte dieses mal jedoch einen beschädigten Container ausschliessen.

Ich habe dann in den Einstellungen testweise die Untertitel "komplett" deaktiviert und siehe da:

 

!!! Problem verschwunden !!!

 

Ich kann also abschliessend feststellen das Emby (oder ffmpeg) ein Problem mit den Untertiteln hat.

Ich werde jetzt Emby "Ohne Untertitel" benutzen.

Link to comment
Share on other sites

The_Registar

Ich hatte das gleiche Problem. Ich teste noch aber momentan schein es wieder zu funktionieren. Warum weiss ich selbst auch noch nicht. Habe in der Emby App etwas umgestellt.

Edited by The_Registar
Link to comment
Share on other sites

Hier sind einige Logs. Bei dem Film " Das fünfte Element" habe ich den Untertitel entfernt und trotzdem Transcoding. 

Offenbar haben Sie die In-App-Qualitätseinstellung geändert. Versuchen Sie, es auf automatisch zurückzusetzen.

Link to comment
Share on other sites

The_Registar

Ich habe nun in der APP die Bandbreite auf 100Mbit eingestellt und Bildwiederholungsrate auf Anpassen. Damit funktioniert es bei vielen Filmen. Leider nicht bei allen. Ich teste noch etwas

Link to comment
Share on other sites

Ich habe nun in der APP die Bandbreite auf 100Mbit eingestellt und Bildwiederholungsrate auf Anpassen. Damit funktioniert es bei vielen Filmen. Leider nicht bei allen. Ich teste noch etwas

Danke für die Rückmeldung. Wenn Sie ein Problem haben, schauen wir uns ein Beispiel an. Vielen Dank !

Link to comment
Share on other sites

The_Registar

Bei FIlm Men in Black II funktioniert die Einstellungen nicht. AUch nicht auf automatisch. Wenn ich das Log richtig lese, gibt es ein Problem mit den Untertiteln. Habe diese deaktiviert beim Playback aber ich vermute da ist es schon zu spät. Versuche diese mal raus zu muxxen. ALso MKV ohne Untertitel. 

ffmpeg-transcode-fdd717d8-3044-4561-98f9-2c37b7122aba.txt

Link to comment
Share on other sites

Bei FIlm Men in Black II funktioniert die Einstellungen nicht. AUch nicht auf automatisch. Wenn ich das Log richtig lese, gibt es ein Problem mit den Untertiteln. Habe diese deaktiviert beim Playback aber ich vermute da ist es schon zu spät. Versuche diese mal raus zu muxxen. ALso MKV ohne Untertitel. 

 
 
Das funktioniert ganz gut, aber Ihr Server ist dafür nicht schnell genug.
 
Die Untertitel müssen während des Transcodierens eingebrannt werden, und dieser Vorgang erfordert eine beträchtliche CPU. Berücksichtigen Sie stattdessen die externen SRT-Untertitel, um die Transcodierungsleistung zu verbessern.
 
Hilft das?
Link to comment
Share on other sites

Hier dann das LOG ohne Untertitel. Es funktioniert sofort mit direct play ohne Trancoding.

Ja, das ist richtig. Kein Untertitel brennen bedeutet, dass Sie direkt spielen.

Link to comment
Share on other sites

The_Registar

Ok, ich werde es mal ohne Untertitel generell versuchen.

Habe auch schon ein Upgrade der HW in Betracht gezogen.

 

CPU: Intel i3 8100

https://ark.intel.com/de/products/126688/Intel-Core-i3-8100-Processor-6M-Cache-3_60-GHz

 

 

Wäre diese CPU stark genug oder eher eine Grafikkarte ins jetzige System? Dann wäre eine passiv gekühlte ja mehr als ausreichend.

Edited by The_Registar
Link to comment
Share on other sites

pünktchen

Falls du kein Live TV über Emby nutzen möchtest, kannst du auch einen Pentium nehmen. Haupsache die CPU unterstützt Intel Quick Sync.

Bei ner Grafikkarte müsste es eine Nvidia sein, da die Hardwarebeschleunigung mit ATI noch nicht funktioniert.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...