Jump to content

Multiple Emby Server in Activity Monitor


rsava
 Share

Recommended Posts

Hi there,

I am running Emby (Emby Server for Mac x64, ver 3.2,60) on a Mac Mini (mid 2011) with macOS High Sierra (10.13).

I am noticing that as I run Emby, more instances pop up in Activity Monitor.

Last night I had trouble connecting to Emby with both a browser and the iOS app (very sluggish to show anything, just the spinner). I shut down Emby and restarted ... well, I tried to restart. It would not run so I opened Activity Monitor and found 5 more instances of Emby Server running. I force quit all of them and Emby started right up. Everything ran fine, loaded at a decent speed. Only one instance of Emby Server was running.

This morning, I opened Activity Monitor again and I now have a other instance of Emby Server running. 

 

I have not noticed any slow down yet but I am wondering why another instance is running and if I will continue to get more instances until I have to restart Emby again because of slow downs.

Is this something that is a known issue, never seen before or somewhere in between?

 

I was thinking of scripting an automatic Emby restart or rebooting in the middle of the night but this machine does other things for me in the middle of the night so I would prefer to not go that route if possible.

 

Any assistance would be appreciated.

 

rsava

Link to comment
Share on other sites

It definitely looks like it is overnight. I went to bed @ 22:30 (EST) and there were two instances of Emby Server in Activity Monitor. It is now 07:00 and there are three. 

 

I shut down the Server and Electron shut down but the three Emby Servers did not. I had to Force Quit them. Emby Server would not start back up until I did that. 

 

As soon as I did, Emby Server started up normally. Only Electron and Emby Server are currently running.

Link to comment
Share on other sites

Ok, it's restarting automatically because you installed the server restart plugin. try removing that.

Link to comment
Share on other sites

  • 4 weeks later...

Sorry, but I have no plugin and still I have two instances on Mac OS X. How can I cure that?

 

 

Hi,

 

Open a terminal window and run the following command (assuming you have copied EmbyServer.app into your Applications folder) :

/Applications/EmbyServer.app/Contents/MacOS/EmbyServer 

 

 

Leave the terminal window open. To quit Emby go to the open terminal window and hit ctrl-c. Don't be tempted to quit Emby from the menu bar icon as this does not work correctly at the moment.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...