Jump to content

Emby sporadically hanging with System.IO.IOException: Too many open files in the logs


jmassot
 Share

Recommended Posts

Hello,

 

I am running Emby 3.2.60.0 on a MacOS High Sierra, and I am having Emby sporadically hanging, requiring me to manually stop Emby process from Activity Monitor (Force Quit), then manually restarting it.

 

In the logs, I could capture lots of error entries with: System.IO.IOException: Too many open files.

 

See attached log file with a sample of such errors.

 

Thanks in advance for your help!

 

Cheers,

   JC.

excerpt_log.txt

Link to comment
Share on other sites

Hi there, can you please attach the complete emby server log? I would like to understand the full picture. Thanks !

Link to comment
Share on other sites

For starters I would remove the email plugin as there is a defect in the .net core runtime under MacOS that may cause Emby Server to crash when attempting to send emails. I believe i saw it is resolved in the upcoming .net core 2.1.

 

Second, if you remove the statistics plugin that will reduce server activity which might possibly be enough to alleviate the too many open files error. if that doesn't work out there is a procedure you can follow here to increase the limit:

 

https://docs.microsoft.com/en-us/dotnet/core/macos-prerequisites?tabs=netcore2x

 

Thanks.

Link to comment
Share on other sites

Noted. I have accordingly removed both the Email and Statistics plugins, and followed the procedure within the link you provided to increase the limit.

I will monitor the situation and keep you posted.

 

Thanks!

Link to comment
Share on other sites

I encountered this problem too; any solution in sight except increasing the files limit?

 

I would just increase the file limit. The default is low. But you can also see post #2 and we can advise of any plugins that might be contributing to your hitting the limit.

Link to comment
Share on other sites

I would just increase the file limit. The default is low. But you can also see post #2 and we can advise of any plugins that might be contributing to your hitting the limit.

 

 

here is the server log

Thanks a lot for your support

Log-6.txt

Link to comment
Share on other sites

OK, if you have the realtime monitor enabled for any of your libraries, you could try turning that off. You could also try reducing the number of enabled internet metadata providers. But I would just increase the limit. Thanks.

Link to comment
Share on other sites

OK, if you have the realtime monitor enabled for any of your libraries, you could try turning that off. You could also try reducing the number of enabled internet metadata providers. But I would just increase the limit. Thanks.

 

 

Interestingly enough, I have Emby Server (same default settings) installed on a MacBook Pro 2012, i.e. the same HW as Mac Mini but running macOS High Sierra and this error does not appear!

 

EDIT: reducing the metadata provider to one per kind eliminated the error of "Too Many Open Files"

Edited by Everbrave
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...