Jump to content

Small bug in setup wizard


Go to solution Solved by Luke,

Recommended Posts


I'm just going through the setup of a new Emby server on my Synology DS918+.
The package installed just fine but while going through the setup wizard I noticed the dropdown for adding a folder to my media library didn't work.
After selecting one of the folders on my NAS it just closes the dropdown without selecting the chosen folder.

Not a big problem as I could just enter the path manually but I thought I'd let you know :)

Link to comment
Share on other sites

Please attach the emby server log, thanks.

When proceeding I noted Emby did not find anything in the shared folder due to missing permissions. I tried again to add a folder after giving read/write permissions and now it works without any errors.

The log also shows an access denied error so I guess we can blame this on me not setting the correct permissions before trying to add the folder:

2017-12-28 15:10:38.622 Error HttpServer: Error processing request
	*** Error Report ***
	Command line: /var/packages/EmbyServer/target/server/MediaBrowser.Server.Mono.exe -package synology -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe -restartpath /var/packages/EmbyServer/scripts/restart
	Operating system: Unix
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: False
	Mono: (tarball Mon Sep 25 18:34:32 CST 2017)
	Processor count: 4
	Program data path: /var/packages/EmbyServer/target/var
	Application directory: /volume1/@appstore/EmbyServer/releases/v3.2.50.0
	System.UnauthorizedAccessException: Access to the path '/volume1/Series' is denied.

Maybe it would be an option in this case to show a message pointing to the wiki (https://github.com/MediaBrowser/Wiki/wiki/Synology-:-Setting-Up-Your-Media-Library-Share) which helped me solve this?

It might help people who are new to Emby/Synology.

Link to comment
Share on other sites

  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...