Jump to content

How to get m3u to work in emby


Koml
 Share

Recommended Posts

Hello Luke

 

Thanks so much for your continued interest.

 

Since the last log I have tried fiddling around a bit more.  I have compiled a much shorter M3U list (with only about 20 channels as opposed to the 2000+ before) with the aim of also shortening the length of the attached log file.

 

Grateful for any insight.

 

Thanks.

New Emby Log.txt

Link to comment
Share on other sites

I still have same issue even after update to latest version today. @@Koml can u please reply with details about streams format ?

Is it format=ts or some other (from the m3u link), have 3 different providers in all formats, and still have same issue with spinning circle and emby theater unresponsive

when i play a stream.

Link to comment
Share on other sites

I still have same issue even after update to latest version today. @@Koml can u please reply with details about streams format ?

Is it format=ts or some other (from the m3u link), have 3 different providers in all formats, and still have same issue with spinning circle and emby theater unresponsive

when i play a stream.

 

@@kikinjo, please see how to report a media playback issue. thanks !

Link to comment
Share on other sites

  • 9 months later...

I believe I may be having the same issue (though the stream never starts). From the ffmpeg output it seems the URL to the playlist is passed instead of the selected stream. Downloading the M3U file and giving that filepath instead of the URL doesn't make a difference, but if I paste the command from the logs and replace the playlist URL with the playlist entry URL it seems to work.

 

ffmpeg log (sensitive info replaced with fake capital variable names):

/usr/bin/ffmpeg -i "http://${PLAYLIST_URL}&type=m3u_plus&output=ts" -map_metadata -1 -map_chapters -1 -threads 0 -sn -codec:v:0 libx264 -pix_fmt yuv420p -preset veryfast -crf 23 -maxrate 139808000 -bufsize 279616000 -profile:v high -level 4.1 -x264opts:0 subme=0:me_range=4:rc_lookahead=10:me=dia:no_chroma_me:8x8dct=0:partitions=none -force_key_frames "expr:gte(t,n_forced*3)" -flags -global_header -vsync -1 -codec:a:0 aac -strict experimental -ac 2 -ab 192000  -f segment -max_delay 5000000 -avoid_negative_ts disabled -start_at_zero -segment_time 3  -individual_header_trailer 0 -segment_format mpegts -segment_list_entry_prefix "hls/14295dadb4be3c30f1eeba97d821bf30/" -segment_list_type m3u8 -segment_start_number 0 -segment_list "/var/lib/emby/transcoding-temp/14295dadb4be3c30f1eeba97d821bf30.m3u8" -y "/var/lib/emby/transcoding-temp/14295dadb4be3c30f1eeba97d821bf30%d.ts"

ffmpeg version n4.1 Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 8.2.1 (GCC) 20180831
  configuration: --prefix=/usr --disable-debug --disable-static --disable-stripping --enable-fontconfig --enable-gmp --enable-gnutls --enable-gpl --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libdrm --enable-libfreetype --enable-libfribidi --enable-libgsm --enable-libiec61883 --enable-libjack --enable-libmodplug --enable-libmp3lame --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libv4l2 --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxcb --enable-libxml2 --enable-libxvid --enable-nvdec --enable-nvenc --enable-omx --enable-shared --enable-version3
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
  libpostproc    55.  3.100 / 55.  3.100

http://${PLAYLIST_URL}&type=m3u_plus&output=ts: Invalid data found when processing input

I'm on Arch Linux, if that helps. Also, I don't see any m3u formats when I run

ffmpeg -formats

EDIT: Switching to the ffmpeg-full-nvenc AUR package fixes everything.

Edited by Cybolic
Link to comment
Share on other sites

 

EDIT: Switching to the ffmpeg-full-nvenc AUR package fixes everything.

How did you accomplish this unless it's way to technical to share......I searched for that package and I do not understand any of the info it gives me.

 

EDIT: Awesome, figured it out....Now Emby Theater Works on Ubuntu!!!!!!!.......Spoke too soon, worked once now back to black screen unless I use external player.....

Edited by EODCrafter
Link to comment
Share on other sites

How did you accomplish this unless it's way to technical to share......I searched for that package and I do not understand any of the info it gives me.

 

On Arch Linux, the ffmpeg-full-nvenc package is a user-contributed package in the AUR (the Arch User Repository), it can be installed through the following commands:

 

Using yay (my preferred helper):

yay ffmpeg-full-nvenc

If you don't have a helper installed, the manual process is:

git clone https://aur.archlinux.org/ffmpeg-full-nvenc.git
cd ffmpeg-full-nvenc
makepkg -si

You probably want to grab a cup of your favourite beverage first as compiling ffmpeg and its dependencies takes a while.

  • Like 1
Link to comment
Share on other sites

EDIT: Awesome, figured it out....Now Emby Theater Works on Ubuntu!!!!!!!.......Spoke too soon, worked once now back to black screen unless I use external player.....

 

Have you tried the nvenc-enabled packages here? They might require you to have an NVIDIA card, but I don't think it's a hard requirement.

Link to comment
Share on other sites

Have you tried the nvenc-enabled packages here? They might require you to have an NVIDIA card, but I don't think it's a hard requirement.

Err:35 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release      
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done                      
E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
E: The repository 'http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Link to comment
Share on other sites


steve@steve:~$ ffmpeg
ffmpeg version N-47226-gdb4771af81-static https://johnvansickle.com/ffmpeg/ Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 6.3.0 (Debian 6.3.0-18+deb9u1) 20170516
configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc-6 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg
libavutil 56. 19.101 / 56. 19.101
libavcodec 58. 33.101 / 58. 33.101
libavformat 58. 19.100 / 58. 19.100
libavdevice 58. 4.105 / 58. 4.105
libavfilter 7. 33.101 / 7. 33.101
libswscale 5. 2.100 / 5. 2.100
libswresample 3. 2.100 / 3. 2.100
libpostproc 55. 2.100 / 55. 2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Link to comment
Share on other sites

steve@steve:~$ ffmpeg
ffmpeg version N-47226-gdb4771af81-static https://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2018 the FFmpeg developers
  built with gcc 6.3.0 (Debian 6.3.0-18+deb9u1) 20170516
  configuration: --enable-gpl --enable-version3 --enable-static --disable-debug --disable-ffplay --disable-indev=sndio --disable-outdev=sndio --cc=gcc-6 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-gray --enable-libaom --enable-libfribidi --enable-libass --enable-libvmaf --enable-libfreetype --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librubberband --enable-libsoxr --enable-libspeex --enable-libvorbis --enable-libopus --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvpx --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg
  libavutil      56. 19.101 / 56. 19.101
  libavcodec     58. 33.101 / 58. 33.101
  libavformat    58. 19.100 / 58. 19.100
  libavdevice    58.  4.105 / 58.  4.105
  libavfilter     7. 33.101 /  7. 33.101
  libswscale      5.  2.100 /  5.  2.100
  libswresample   3.  2.100 /  3.  2.100
  libpostproc    55.  2.100 / 55.  2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

 

At first glance those configuration options look fine. Is it working for you?

Link to comment
Share on other sites

No, I think this has been reported as some obscure GTK Issue....I'll keep using external Player with ET...5bed7894da237_Screenshotfrom201811150744

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...