Jump to content


Photo

Emby Server for Android


  • Please log in to reply
1177 replies to this topic

#1 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 02:47 PM

Release Download

https://emby.media/download

 

Beta Download

https://github.com/M...ver_4.2.0.7.apk

Requires Android 6.0+.

 

How to Use

 

Just run the app like any other android app.

 

Supported Devices

 

While you can technically run this on any android device (yes even a smartphone), we haven't yet decided what devices we want to support and troubleshoot. This feedback and testing thread is what will help us make that decision.

 

Feature Status

 

Feature complete. Feedback is appreciated. Thanks.

 

@CBers


  • bifftaz, EODCrafter, FiercePierce and 6 others like this

#2 Jdiesel OFFLINE  

Jdiesel

    Advanced Member

  • Members
  • 2621 posts
  • Local time: 01:18 AM
  • LocationRegina, SK

Posted 19 December 2017 - 02:56 PM

This should make a few people happy. I can likely test on my Shield TV and Odroid C2. Just need to find some time over the holiday break...



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 03:03 PM

Thanks, and like I said this is mostly just for fun right now and is far from production ready. So the purpose of this thread is to hopefully accelerate the process of getting to that point. Thanks.



#4 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2640 posts
  • Local time: 03:18 AM
  • LocationLong Island, NY

Posted 19 December 2017 - 03:14 PM

very cool.



#5 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15111 posts
  • Local time: 08:18 AM
  • LocationKent, England.

Posted 19 December 2017 - 04:04 PM

Feedback is appreciated. Thanks.

@CBers


Thanks, but no thanks.

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 04:09 PM

Thanks, but no thanks.

 

You prefer to separate the functions?



#7 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15111 posts
  • Local time: 08:18 AM
  • LocationKent, England.

Posted 19 December 2017 - 05:11 PM

You prefer to separate the functions?


Yes.

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 05:13 PM

Thanks for the feedback.



#9 clarkss12 OFFLINE  

clarkss12

    Advanced Member

  • Members
  • 975 posts
  • Local time: 03:18 AM
  • LocationMichigan, USA

Posted 19 December 2017 - 05:34 PM

Since I love to tinker, I installed this server onto my Mecool M8S Pro L (Amlogic S912), and setting it up now.  Install was a piece of cake.  Right now, I have the server running under a Windows 10, Linux Ubuntu 16.04, and LibreELEC.  All my media is stored onto one of my two NAS's, so I will have to figure out how to "mount" those locations onto my Android box.

 

My box is running a modded Android TV OS version 7.1.2.

 

Edit 1:  After install the apk, I did NOT reboot, but the web setup worked right off the bat.  After added my Live TV to it, I rebooted the box.  But after I rebooted, the Server was not running, had to go back to my Android box and click on the grey Emby app, that started the server.

 

Anyway, it appears that this server manually has to be restarted after a reboot.

 

Played a HD TV stream on my Windows 10 desktop computer, using the Emby Theater app and it played flawlessly.


Edited by clarkss12, 19 December 2017 - 05:46 PM.

  • ebr likes this

#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 05:38 PM

Excellent, thanks ! And again for now without ffmpeg you are most likely limited to just browsing around the library unless you can force a direct play. Thanks.



#11 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44185 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 05:42 PM

Since I love to tinker, I installed this server onto my Mecool M8S Pro L (Amlogic S912), and setting it up now.  Install was a piece of cake.  Right now, I have the server running under a Windows 10, Linux Ubuntu 16.04, and LibreELEC.  All my media is stored onto one of my two NAS's, so I will have to figure out how to "mount" those locations onto my Android box.

 

My box is running a modded Android TV OS version 7.1.2.

 

I figure you are probably the perfect person to test this so thanks for taking it on!



#12 clarkss12 OFFLINE  

clarkss12

    Advanced Member

  • Members
  • 975 posts
  • Local time: 03:18 AM
  • LocationMichigan, USA

Posted 19 December 2017 - 06:05 PM

Excellent, thanks ! And again for now without ffmpeg you are most likely limited to just browsing around the library unless you can force a direct play. Thanks.

Since I am only able to get the OTA TV working, I can't test my media from my NAS's right now.   What is strange, my TV streams play perfectly on my Windows 10 computer but trying to play on the same box as the one that the server is running on I get the "Too many errors: Giving up".



#13 clarkss12 OFFLINE  

clarkss12

    Advanced Member

  • Members
  • 975 posts
  • Local time: 03:18 AM
  • LocationMichigan, USA

Posted 19 December 2017 - 06:44 PM

Just tested it on my Zidoo X9S (Realtek RTD1295 ARM Cortex-A53 Quad-Core) and again, it installed perfectly from my USB memory stick.  I loaded the TV app with Schedules Direct for my guide data, and started the Windows 10 Emby Theater to test.  Same situation, played perfectly.

 

Opened my Emby app on my Zidoo X9S that the Emby server is running on, and set the Live TV stream to the same channel as my Windows computer.  As normal, it only used ONE tuner for both devices (excellent), and played perfectly.  I tested a 720P, and 1080i channels and both played perfectly.....

 

Zidoo X9S is running Android version 6.0.1 (standard "touch" screen version of Android).  

 

 

Attached File  Zidoo X9S Emby Server.jpg   62.58KB   53 downloads

 

Edit:  I never use this device, but it stays connected always, so it makes a good device to load the Emby Server.


Edited by clarkss12, 19 December 2017 - 06:52 PM.


#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 07:18 PM

Isn't that neat. That's fantastic. Thanks for testing.



#15 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2640 posts
  • Local time: 03:18 AM
  • LocationLong Island, NY

Posted 19 December 2017 - 07:22 PM

I plan on installing on a CuBox i4-Pro in the next week ro so just for shits and giggles and will report back.  


  • Luke likes this

#16 clarkss12 OFFLINE  

clarkss12

    Advanced Member

  • Members
  • 975 posts
  • Local time: 03:18 AM
  • LocationMichigan, USA

Posted 19 December 2017 - 07:31 PM

Having this server run on Android is just fantastic.  The only problem I see, is the ability to mount networked storage devices.  Perhaps someone on here can give me instructions on how to do it.  I did a cursory look, but will spend more time researching it tomorrow.

 

With my cheat sheets, I can mount all my media stored on my NAS's from Windows, Linux and LibreELEC, but never tried to mount from Android.  On any of my boxes, running Linux, Widows, or LibreELEC, it only takes a couple of hours to have a fully functioning media player, including a PVR.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 127006 posts
  • Local time: 03:18 AM

Posted 19 December 2017 - 07:35 PM

you should be able to use smb://



#18 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2640 posts
  • Local time: 03:18 AM
  • LocationLong Island, NY

Posted 19 December 2017 - 07:43 PM

Having this server run on Android is just fantastic. The only problem I see, is the ability to mount networked storage devices. Perhaps someone on here can give me instructions on how to do it. I did a cursory look, but will spend more time researching it tomorrow.

With my cheat sheets, I can mount all my media stored on my NAS's from Windows, Linux and LibreELEC, but never tried to mount from Android. On any of my boxes, running Linux, Widows, or LibreELEC, it only takes a couple of hours to have a fully functioning media player, including a PVR.

NFS. Did it for years using Kodi via a dedicated Linux NAS. No issues ever other than the bs Kodi version db sync

Sent from my SM-G950U using Tapatalk

#19 clarkss12 OFFLINE  

clarkss12

    Advanced Member

  • Members
  • 975 posts
  • Local time: 03:18 AM
  • LocationMichigan, USA

Posted 19 December 2017 - 07:45 PM

you should be able to use smb://

Glad you we are not video chatting, my face is beet red!!!!!!!!!   Haha, that was so simple,

 

Thank you.......... 

 

Attached File  Zidoo X9S mounted drive.jpg   36.41KB   37 downloads


Edited by clarkss12, 19 December 2017 - 07:48 PM.


#20 clarkss12 OFFLINE  

clarkss12

    Advanced Member

  • Members
  • 975 posts
  • Local time: 03:18 AM
  • LocationMichigan, USA

Posted 19 December 2017 - 08:07 PM

Ran a test using a BlueRay rip, Windows played perfectly.  Would not play in Zidoo, too many errors........  Guess it does need the ffmpeg.

 

Attached File  MIB codecs.txt   8.23KB   12 downloads

 

Attached File  Men In Black BlueRay rip.jpg   66.73KB   41 downloads

 

Attached File  Men In Black BlueRay Rip 2.jpg   65.08KB   40 downloads

 

Edit:  Played same MIB on my Vorke V2 (Windows 10 micro PC), which is connected to my Denon AVR, and it played perfectly WITH Dolby HD..........

 

Can't get no better than that.


Edited by clarkss12, 19 December 2017 - 08:12 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users