Jump to content

Error No connection could be made ...


HDJedi
 Share

Recommended Posts

HDJedi

Hi I'm getting the error

Status unavailable (No connection could be made because the target machine actively refused it [::1]:9080)

after installing ServerWMC (See attached jpg)

Is this a firewall error or do I need to port forward port 9080 or something?

Any help appreciated as I'd like to get this working. Thanks.

 

Running on Windows 7 Media Centre HTPC

 

post-2407-0-42411400-1394027580_thumb.jpg

  • Like 1
Link to comment
Share on other sites

Spaceboy

I get this on first boot when mb3 tries to query swmc before it has fully started, perhaps a delay could be implemented? Or maybe this isn't entirely your issue but would still be good feedback to the devs

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

krustyreturns

Yeah, you can get this error if serverwmc is not running, or if its being blocked by a firewall, or if you have not set the ip address in mediabrowser to the machine running serverwmc.  The first time you run serverwmc, windows should ask you whether you want to open port 9080 in the windows firewall (assuming you are using the windows firewall).  

  • Like 1
Link to comment
Share on other sites

HDJedi

Thanks for replies. Tried opening port 9080 TCP & UDP on Windows firewall but no change. Reinstalled SWMC but still same error. Never did get the windows firewall message re allowing the program.

 

Could it be my router firewall that needs setting?

 

Quote "I get this on first boot when mb3 tries to query swmc before it has fully started, perhaps a delay could be implemented?"

Delay what and how?

 

Thanks

Link to comment
Share on other sites

shadetree

Hi I'm getting the error

Status unavailable (No connection could be made because the target machine actively refused it [::1]:9080)

after installing ServerWMC (See attached jpg)

Is this a firewall error or do I need to port forward port 9080 or something?

Any help appreciated as I'd like to get this working. Thanks.

 

Running on Windows 7 Media Centre HTPC

 

I too have the same error output with new LTV install.

 

I'll double check the service and firewall later when I get home on my LAN, my web access is a bit unstable bouncing satellites.

 

shade

Link to comment
Share on other sites

krustyreturns

Are you guys running swmc on the same machine as MBS?  Maybe provide some more info on your setup.  You can also try using telnet to swmc to test the connection, or I just use google chrome, from the mbs machine open chrome and type in the ip address and port of the swmc machine.  It its the same machine just use:

127.0.0.1:9080  

or just the machine name:  

machineName:9080

 

then watch the bottom of the status tab in swmc and see if you get a connection.

  • Like 1
Link to comment
Share on other sites

shadetree

Thanks krustyreturns,  I'm running SWMC and MBS on the same server...so I thought....

 

After some long reading (some was yours), I realized that I hadn't actually installed the SWMC MSI thru MB3, just the MB3 app.  I downloaded version ServerWMC-1129 and remote in from office.  Installed the MSI, configured access and startup behavior.  Had the wife restart the server and log in.  LTV is working brilliantly from here now!

 

Only problem now is explaining to the wife why I wasn't working while at work...lol.

 

shade    

Link to comment
Share on other sites

egold

I did the same thing. I installed serverwmc through MBS and could not get it to connect. I installed the serverwmc.msi and I was able to connect using localhost. I previously opened port 9080 in windows firewall when I was trying to get it to work before realizing I needed the msi so I did not get the open ports 9080 when i installed the app in MB3.. Ok, now that I have it installed and working. What can I do with it? can I access my recorded TV shows through android? I have the app installed in MBT on my laptops but when I click it on it just launches WMC on the laptop. My HTPC is connected to my TV and we use WMC on that to record tv shows. To view live Tv I just switch over to the antenna. We are OTA.

  • Like 1
Link to comment
Share on other sites

egold

Thanks for the reply Krusty. It's working well on my iphone over wifi. I can view my recorded shows np/ My wifes android phone is a different story. It hangs for a bit with movies and trying to play a recoded tv show from serverwmc I just get a blank screen. I also noticed on my iphone there is a place to enter in lan ip and my isp ip on the android I only see the lan ip to enter. seems the iphone app is more advanced than the droid app. So far I'm very happy with MB3 good great job.  I'll check out the android thread. 

Link to comment
Share on other sites

HDJedi

Well got it working. Didn't install the Server WMC msi file. Oops ;)

Working now.

 

PS Is it still the case that live TV only works in Web client or can it work in Android/IOS client now?

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...