Jump to content

emby for osx 10.11.6? (Update)


izoser
 Share

Recommended Posts

So i was all set to try Emby again downloaded and to my surprise only works on OS X 10.12
i am maxed out at OS X 10.11.6. The wiki still says snow leopard 10.6.3 will work.

now what? and do not say get a newer computer. :)
any options worth trying?
thanks

Edited by izoser
Link to comment
Share on other sites

no i can not.

however i have discovered a patch for old macs to use 10.12.6

i am exploring this option now

 

thank you for the reply

Link to comment
Share on other sites

UPDATE:
So I took the plunge on to the razors edge and survived.
The patch worked. http://dosdude1.com/highsierra/

I am now running MacOS 10.13.1 on a mac mini 3,1 (late 2009)
Internet is work well (no wifi as advertised) no problem
Installed the PIA app no issues working good.
I have SMB working no issues.
I have backed up my iphone and updated it to 11.0.3

The emby server is installed, setup and scanning at this time.
So far so good.

Overall it is working amazingly well, all things considered.
No, it is not super fast but very usable I think.

I did have concerns with the security issue but ran across no bad reports, so what the hell.

A few tips:
1. My first flash drive had issues.
2. Disconect all external drives other than the install drive.
3. My mouse would stop working had to move to a different USB port

other than that all appears to be swimming along very well.

Hope this helps someone else.

thanks

Link to comment
Share on other sites

  • 1 month later...
yamahito

Looks like this will be my best option, too.

 

Ideally, though, I'd rather run a headless version, perhaps using something like homebrew.  Might this be a possible option in future for mac users to bypass both logging in and this sort of obsolescence issue?

Link to comment
Share on other sites

  • 5 months later...
nanni

it is a pity that there is not a version that works on the system before 10.12. Many 'old' Mac can not install newer systems than 10.11.6 El Capitan.

All other Media Centers (Kodi, Serviio, Plex, UMS) work with 10.11.

Link to comment
Share on other sites

I have nothing against supporting the old version it's just that the runtime we are using requires 10.12+. If they are able to loosen up the restriction than so will we.

Link to comment
Share on other sites

We are using the Microsoft .NET Core runtime. here's one ticket i found on github where someone mentioned a desire for 10.11:

 

https://github.com/dotnet/core/issues/732

 

Apparently Apple changed the cryptography stack in 10.12, and Microsoft has done all of their HTTPS/SSL development based on this. For them to support 10.11 they will have to develop separately for it to support the older cryptography stack, and I'm guessing they don't want to do that.

Link to comment
Share on other sites

However, .NET Core 2.1 has introduced a number of changes that make the runtime better, with fewer native dependencies. Maybe that would make supporting the older MacOS easier for them. You could try opening a ticket about it and see what they say, maybe they will re-evaluate.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...