Jump to content
keithterrill

ANSWERED Intranet Setup Broadcasting?

Recommended Posts

keithterrill

I apologize if this is not in the correct forum. I also apologize if this is already answered.

I have two Linux Mint computers connected via Ethernet cable. A Cisco Linksys E1500 is the router between them.

On Linux Mint 17.3 I installed, setup, and am running embyserver. The IP is x.x.x.1 (not the real address.)

On the router, I set a Single Port Forwarding named emby as External Port 8096, Internal Port 8096, Protocol Both, IP Address x.x.x.1 (where that is the IP address of the server computer).

On Linux Mint 18.3 I installed kodi (from the ppa:team-xbmc/ppa repository) following directions from http://kodi.wiki/view/HOW-TO:Install_Kodi_for_Linux   This computer is IP x.x.x.2 (again, not the real address)

In the kodi client I installed the EmbyCon add on. In the EmbyCon settings I set the Server Address to x.x.x.1 and the Server Port to 8096. Use HTTPS is off and Verify Certificate is OFF.

When I click Detect Server it reports No Servers Detected.

 

User name is set to "john" and the password is left blank. Device name is set to EmbyCon.

On the server I added a user named "john" and left the password empty.

(Actually I tried with and without passwords etc.)

So... help, how do I broadcast from the server so that I can see the files (movies in this case) on the client?

thank you

Share this post


Link to post
Share on other sites
Luke

Hi @@keithterrill, if EmbyCon is not automatically detecting your Emby Server, you should still be able to manually enter the server address to connect to. Try doing that instead of having it search for your Emby Server. Please let us know if this helps. Thanks.

 

@

Share this post


Link to post
Share on other sites
keithterrill

I did enter it.
 

 

 

In the kodi client I installed the EmbyCon add on. In the EmbyCon settings I set the Server Address to x.x.x.1 and the Server Port to 8096. Use HTTPS is off and Verify Certificate is OFF.

59f14e7b9441b_EmbyCon20171025225039.png


It did not find it that way, nor did it find it when I clicked on Detect Server.

I know I can touch the server because I can ping it from a terminal on the client computer.
 

client ~ $ ping x.x.x.1
PING x.x.x.1 (x.x.x.1) 56(84) bytes of data.
64 bytes from x.x.x.1: icmp_seq=1 ttl=64 time=0.390 ms
64 bytes from x.x.x.1: icmp_seq=2 ttl=64 time=0.513 ms
64 bytes from x.x.x.1: icmp_seq=3 ttl=64 time=0.334 ms
64 bytes from x.x.x.1: icmp_seq=4 ttl=64 time=0.562 ms

So, something else is not correct.

Share this post


Link to post
Share on other sites
Luke

Is the Emby Server software running when you try to connect from EmbyCon?

Share this post


Link to post
Share on other sites
BAlGaInTl

I would probably start with using the web app just to test.

 

Open a browser on each computer and go to http://x.x.x.1:8096 to see if the server loads.

 

Once you know that is working, then you can troubleshoot Kodi some more.

Share this post


Link to post
Share on other sites
keithterrill

Is the Emby Server software running when you try to connect from EmbyCon?

 

I believe it is running.

 

server ~ $ service emby-server status
emby-server start/running, process 1820

59f1c90b6bd24_Screenshotfrom201710260730

 

 

Share this post


Link to post
Share on other sites
keithterrill

If this is all on the local network why do you need to set up port forwarding?

I would not think I need it. I included the fact for completeness.

 

The port forwarding is for the future hope of connecting over the internet, but for now I want to get the intranet working first.

Share this post


Link to post
Share on other sites
keithterrill

I would probably start with using the web app just to test.

 

Open a browser on each computer and go to http://x.x.x.1:8096 to see if the server loads.

 

Once you know that is working, then you can troubleshoot Kodi some more.

Executing this in a browser on x.x.x.1 works.

 

Executing this in a browser on x.x.x.2 times out.

 

59f1ce6f5dc92_Screenshotfrom201710260753

Share this post


Link to post
Share on other sites
BAlGaInTl

Executing this in a browser on x.x.x.1 works.

 

Executing this in a browser on x.x.x.2 times out.

 

 

So the server is running, but you can't reach it from the second computer.

 

Do you have a firewall enabled on that computer?  You may have to add a rule to allow the traffic.

 

It could also be something on the server computer blocking that incoming port.

 

Try temporarily disabling firewalls on both systems to see if it works.

Edited by BAlGaInTl
  • Like 1

Share this post


Link to post
Share on other sites
keithterrill

So the server is running, but you can't reach it from the second computer.

 

Do you have a firewall enabled on that computer?  You may have to add a rule to allow the traffic.

 

It could also be something on the server computer blocking that incoming port.

 

Try temporarily disabling firewalls on both systems to see if it works.

 

 

I feel like the person who called the T.V. repair man to fix the set that won't turn on, and he reaches behind and plugs it into the wall socket.

 

Yes, that worked. I plum forgot that I had put a fire wall up because of unwanted attacks after I installed Apache on a Virtual Server.

 

So, what I did was to open port 8096 on x.x.x.1

Started the browser on x.x.x.2 and putin http://x.x.x.1:8096

And, I had it running.

 

Then I launched kodi and tried that. It found the server.

I have a different problem with the kodi but will readdress that later.

 

thank you.

Share this post


Link to post
Share on other sites
BAlGaInTl

I feel like the person who called the T.V. repair man to fix the set that won't turn on, and he reaches behind and plugs it into the wall socket.

 

Yes, that worked. I plum forgot that I had put a fire wall up because of unwanted attacks after I installed Apache on a Virtual Server.

 

So, what I did was to open port 8096 on x.x.x.1

Started the browser on x.x.x.2 and putin http://x.x.x.1:8096

And, I had it running.

 

Then I launched kodi and tried that. It found the server.

I have a different problem with the kodi but will readdress that later.

 

thank you.

 

Thanks for the feedback.  It's no big deal.  We've all been there.  It helps to get a different perspective sometimes.

 

Glad that worked for you.

Edited by BAlGaInTl
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...