Jump to content


Photo

Judder on Frame Rate Switching


  • Please log in to reply
82 replies to this topic

#1 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 22 October 2017 - 09:24 AM

I'm having issues with stuttered / juddery playback using frame rate switching with mpv. Here's some screen grabs of my settings and the logs consistent with the time this occurred although it is occurring often. Last night I had to shut off frame rate switching in order to watch the movie without getting nauseous. 

 

59ec9b46214bc_DroppedFrames.jpg

 

 

 

 

59ec9b5841d4e_VideoSettings1.jpg59ec9b6782f97_VideoSettings2.jpg

59ec9b77aa326_VideoSettings3.jpg59ec9b86a58e7_VideoSettings4.jpg

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 07:56 AM

Posted 22 October 2017 - 01:04 PM

Try setting the app back to default settings.



#3 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 22 October 2017 - 05:52 PM

Try setting the app back to default settings.

Works great. No Judder at all.

Sent from my SM-G930P using Tapatalk
  • Luke likes this

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136081 posts
  • Local time: 07:56 AM

Posted 22 October 2017 - 05:54 PM

Do you remember which ones you changed? We are probably at the point where we have too many settings in the UI now and need to consider removing some. @Doofus



#5 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 22 October 2017 - 06:00 PM

Do you remember which ones you changed? We are probably at the point where we have too many settings in the UI now and need to consider removing some. @Doofus

Just turning off frame rate switching but leaving the rest as posted in the OP fixed it. I have had frame rate switching work just fine but last night was unwatchable. Look at all the dropped frames in the "Stats for Nerds" in just a minute or two of playback.

Sent from my SM-G930P using Tapatalk

#6 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 22 October 2017 - 09:43 PM

A couple of things. First, what GPU are you using? Second, you have HWA set to auto and it's using dxva2-copy. That should be d3d, assuming you're using windows. Third, the whole bottom section of settings requires extra processing. I leave all those, alone. Without knowing your GPU, I'm shooting in the dark. Do you also know how to get an mpv log? That would be helpful. But I think we need to manage GPU usage, more efficiently. I was recently getting frame dropping, like that. I reconfigured a great deal, to get it to stop. Hardware and software, but I think my issue was with something I was using.


Edited by Doofus, 22 October 2017 - 11:13 PM.


#7 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 22 October 2017 - 10:43 PM

You should also disable display sync. That will cause a lot of dropped frames



#8 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 07:40 AM

A couple of things. First, what GPU are you using? Second, you have HWA set to auto and it's using dxva2-copy. That should be d3d, assuming you're using windows. Third, the whole bottom section of settings requires extra processing. I leave all those, alone. Without knowing your GPU, I'm shooting in the dark. Do you also know how to get an mpv log? That would be helpful. But I think we need to manage GPU usage, more efficiently. I was recently getting frame dropping, like that. I reconfigured a great deal, to get it to stop. Hardware and software, but I think my issue was with something I was using.

You should also disable display sync. That will cause a lot of dropped frames

I have come to the conclusion that Intel iGPU HD4600 does not handle 23.976 fps well and have turned it off and set HWA to none and now have zero dropped frames.

Sent from my SM-G930P using Tapatalk

#9 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 07:43 AM

Recommendations on a good GPU around the $100 price point would be nice. My Radeon HD7850 gave up the ghost recently so I'm using on board video right now.

Sent from my SM-G930P using Tapatalk

Edited by Sammy, 23 October 2017 - 07:44 AM.


#10 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 08:29 AM

Works great. No Judder at all.

Sent from my SM-G930P using Tapatalk

 

If this is to be the best answer then does frame rate switching actaully work in mpv? Seems to be a "maybe" answer because it depends on the GPU? Shouldn't this work with iGPU? I had it working long ago, back in 2011, on an i3 iGPU with madVR (no advanced settings though). Why can't I expect that on a 4th generation i5 iGPU in mpx?



#11 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 10:12 AM

Try setting it to d3d without copyback, turn off display sync and everything else at default.

#12 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 10:44 AM

Try setting it to d3d without copyback, turn off display sync and everything else at default.

Is that setting good with Win7x64Pro?

Sent from my SM-G930P using Tapatalk

#13 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 11:45 AM

Ah that was why it chose DXVA2 copyback. No, you need win 8 and up. So with copyback, it's writing to your RAM. That could possibly be why you have dropped frames. Unfortunately DXVA2 is not well supported, now. But there is a way for you to try it. Do you have an mpv.conf?

Edited by Doofus, 23 October 2017 - 12:15 PM.


#14 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 11:52 AM

You can set your HWA to auto and put this in your mpv.conf

hwdec=dxva2
opengl-backend=dxinterop

And disable display sync

Edited by Doofus, 23 October 2017 - 12:12 PM.


#15 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 12:32 PM

Ah that was why it chose DXVA2 copyback. No, you need win 8 and up. So with copyback, it's writing to your RAM. That could possibly be why you have dropped frames. Unfortunately DXVA2 is not well supported, now. But there is a way for you to try it. Do you have an mpv.conf?

I do have 12Gbs DDR3 1600 RAM and about 6Gbs free most of the time. I do not have a mpv config file. I have not been following the mpv thread for some time now.

Sent from my SM-G930P using Tapatalk

#16 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 12:33 PM

You can set your HWA to auto and put this in your mpv.conf

hwdec=dxva2
opengl-backend=dxinterop

And disable display sync

How / where to setup mpv.conf?

Thanks.

Sent from my SM-G930P using Tapatalk

#17 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 12:37 PM

Recommendations on a good GPU around the $100 price point?

I also have this thread going at avsforums.

Sent from my SM-G930P using Tapatalk

Edited by Sammy, 23 October 2017 - 12:37 PM.


#18 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 12:40 PM

%AppData%\Roaming\mpv

#19 Doofus ONLINE  

Doofus

    Advanced Member

  • Members
  • 12084 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 03:28 PM

I do have 12Gbs DDR3 1600 RAM and about 6Gbs free most of the time. I do not have a mpv config file. I have not been following the mpv thread for some time now.

Sent from my SM-G930P using Tapatalk


The possible issue with copyback is that it's slower than DXVA2. Coupled with display sync, I would expect frame dropping. Your first test should be HWA auto and display sync off.

#20 Sammy OFFLINE  

Sammy

    Advanced Member

  • Members
  • 2724 posts
  • Local time: 04:56 AM

Posted 23 October 2017 - 03:35 PM

The possible issue with copyback is that it's slower than DXVA2. Coupled with display sync, I would expect frame dropping. Your first test should be HWA auto and display sync off.

 

That is where it is set right now. No frame drops but no frame rate switching either.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users