Jump to content


Photo

Emby Library network share & Emby refresh ?

emby library source refresh kodi mono network share

  • This topic is locked This topic is locked
16 replies to this topic

#1 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 25 September 2017 - 11:43 AM

Hello experts,

 

 

I'm a KODI user, with Emby for KODI addon installed  (LibreELEC / KODI 17).

 

 

I have an external usb disk, which isn't always plugged, plus it's on a remote computer  (another room).

 

If this usb disk is plugged on the remote computer, a script mounts it in LibreELEC as a network cifs share  (if unplugged, it's unmounted).

 

 

But, it seems Emby doesn't detect the changes :

- it doesn't appear automatically in library sources if i try to add a new folder  (seems normal).

- if i try to restart Emby  (i did a  "systemctl restart service.emby.service"), I notice Emby restarts itself, then i see the mountpoint's path created, but without any subfolders from the share.  Folders are accessible in LibreELEC after the mount.

 

 

How can Emby detect changes in mount points ?

 

 

Thanks for your assistance.

 

Regards,



#2 Angelblue05 OFFLINE  

Angelblue05

    Advanced Member

  • Developers
  • 13011 posts
  • Local time: 01:38 AM

Posted 25 September 2017 - 07:20 PM

Can you give an idea of the paths it is with and without the mount? What is it, what should the path be?

 

@Luke



#3 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 26 September 2017 - 05:57 AM

Can you give an idea of the paths it is with and without the mount? What is it, what should the path be?

 

@Luke

 

 

Hello Angelblue05,

 

I'll try to give maximum details and update.

 

 

1. At OS level

 

Remote Computer :

- when computer is up, it's shared as  "josspc"  network share.

 

LibreELEC :

- when remote computer above is up, a script mounts it in  /media/josspc.   Folder creation (chmod 777 just in case)  +  mount -t cifs "//josspc/JossPC" /media/josspc -o username=xyz,password=xyz,rw

This is working as expected.

 

 

2. In Emby

 

- when remote computer is off :

In LibreELEC  /media/josspc  does not exist, so nothing is mounted  (expected).

In Emby  only existing folders are shown in Libraries  (expected).

 

- if remote computer turns on :

In LibreELEC  /media/josspc  is then mounted as a network share  (accessible with subfolders from remote host as expected).

In Emby  the  /media/josspc  is detected   BUT without any subfolder from the remote host  (it doesn't see the network share but only the created folder  /media/josspc  at OS level)

 

 

My goal would be Emby detects the network share in  /media/josspc  when it becomes available/mounted  (i'm ok with an Emby restart to find it, if needed).

 

 

Thanks for your assistance.

 

Best regards,


Edited by tealc59, 10 October 2017 - 09:48 AM.


#4 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 02 October 2017 - 03:29 AM

Thanks for your assistance,

Regards



#5 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 10 October 2017 - 10:09 AM

Hello experts   :) ,

 

Is someone able to help me ?   Or have ideas of what can cause my problem ?

I'm still blocked and don't know what to do.

 

Best regards,



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124278 posts
  • Local time: 02:38 AM

Posted 10 October 2017 - 12:52 PM

Have you tried running a library scan to pick up the new changes?



#7 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 11 October 2017 - 04:03 AM

Have you tried running a library scan to pick up the new changes?

 

Yes i already tried to run library scans   :wacko:



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124278 posts
  • Local time: 02:38 AM

Posted 11 October 2017 - 11:58 AM

Does the emby web app pick up the changes?



#9 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 11 October 2017 - 04:02 PM

Does the emby web app pick up the changes?

 

 

In KODI, the share is found because it was added as an uPNP source.  But in the Emby for KODI addon nothing is found.

In Emby Web Dashboard if a try to add a new folder in a library it can't find the share when it's available (only the created folder but with no subfolder from the share).

 

I also tried to reboot KODI/Emby with remote share always up and mount done in autostart.sh script, no change  :-\



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124278 posts
  • Local time: 02:38 AM

Posted 11 October 2017 - 04:05 PM

Why can't the Emby dashboard find the share? What happens when you try?



#11 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 11 October 2017 - 04:16 PM

Why can't the Emby dashboard find the share? What happens when you try?

 

 

Thanks,

 

please find below what i can see  (i hope it's not too heavy) :

 

59de7b3100f42_1.jpg

 

59de7b4676b3a_2a.jpg

 

59de7b55b5ce2_2b.jpg

 

59de7b6171ba6_3.jpg

 

59de7b6c309b0_4.jpg

 

59de7b7abcaf3_5.jpg

 

 

Regards,



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124278 posts
  • Local time: 02:38 AM

Posted 11 October 2017 - 05:14 PM

sounds like the server doesn't have permission to that location. the emby server can could help us confirm that.


  • Angelblue05 likes this

#13 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 11 October 2017 - 06:36 PM

folder was with 755 permissions (root:root), i'm now trying with 777 but still nothing in  Emby Library :

 

59de9bccece21_1.jpg

 

what more permissive options could i try ?

(and the folders have 755 and are found in Emby, only difference is that this problematic share is Windows with 'Everyone' + 'Administrators' in sharing security area)

 

Regards,



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124278 posts
  • Local time: 02:38 AM

Posted 11 October 2017 - 06:56 PM

If there's a permissions problem then the emby server log can help us determine that. you can learn how to obtain an emby server log here:

 

https://emby.media/c...port-a-problem/

 

thanks !



#15 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 12 October 2017 - 11:25 AM

If there's a permissions problem then the emby server log can help us determine that. you can learn how to obtain an emby server log here:

 

https://emby.media/c...port-a-problem/

 

thanks !

 

 

Hello Luke,

 

 

Can i send you the server logs ?

 

 

when searching for terms "josspc", i can only find 2 errors because Emby can't find the share (that exists as CIFS mount point in LibreELEC) :

 

System.IO.DirectoryNotFoundException: Could not find a part of the path '/var/media/josspc/Films'.

Info LibraryMonitor: Skipping realtime monitor for /var/media/josspc/Films because the path does not exist

 

i think this is because i created a Movie library with 'forced' share path :

59df890251cac_1.jpg

 

 

Best regards,



#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 124278 posts
  • Local time: 02:38 AM

Posted 12 October 2017 - 12:13 PM

Directory not found means the server just can't see the path at all so that is likely permissions.



#17 tealc59 OFFLINE  

tealc59

    Advanced Member

  • Members
  • 49 posts
  • Local time: 07:38 AM
  • LocationFrance

Posted 20 October 2017 - 11:10 AM

Directory not found means the server just can't see the path at all so that is likely permissions.

 

 

Hello Luke,

 

 

After testing a bit, i suppose it linked to CIFS share (creating new folders on any LibreELEC folder, even with 755 permissions,are correctly displayed in Emby Library paths instantly, that's not the case with the CIFS mount point).

 

I don't know what to do to mount CIFS share in LibreELEC to be visible in Emby  :-\

 

Another option that would be nice would be to be able to "mount" upnp windows shares in Emby

 

 

Regards,







Also tagged with one or more of these keywords: emby, library, source, refresh, kodi, mono, network, share

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users