Jump to content

No playback with browser or XBOX one Emby app


Recommended Posts




We have recently gained an XBOX, so naturally I have installed the Emby Theatre app on the XBOX for playback. with the hope of this replacing the aging Win7 Media Centre PC.




On attempting to play back a movie, TV recording or anything, all we get is a full screen image (backdrop) of what we are playing and nothing plays, very odd.

So I did some playing about, I had recently moved the Emby server to a Windows platform, 

I can play a movie back successfully form the Windows 7 MCE with Emby Plugin installed.

I can play back using Emby Theatre on Windows 10 devices.

I cannot playback with Emby theatre on Android.

I cannot playback via a web browser (Edge and Chrome tested on Windows 10, Chrome on Android). 


This has all worked previously.

So I'm thinking there is a server issue on the windows device running the Emby server, this was a temporary measure as I lost my Ubuntu Emby server when the Freenas upgrade went in.

I have installed the FreeBSD plugin for Freenas and after a bit of editing got it going (service would not start automatically).


I have reconfigured, Emby is accessing media stored on NAS via smb://freenas/path/to/media... I have also specified the alternative path \\freenas\path\to\media...

I can play as above but the issues remain with XBOX and Android.


I'm thinking name resolution? so paths now have IP addresses, but the results are still the same.

Looking at the ffmpeg log it does not appear to be passing the alternate UNC path correctly, but I'm not sure as it works on some devices?


Is this a server bug?





Link to comment
Share on other sites

Based on your library setup you're going to need an ffmpeg build that is compiled with smb support:

smb:// 5th Wave (2016)/The 5th Wave.mkv: Protocol not found

I will ask @@josh4trunks to include this. In the meantime I'm not sure if this might help, but our general FreeBSD instructions mention this:




Although that is not freenas-specific. Thanks.

Link to comment
Share on other sites


Hi Luke,


Thanks for the quick reply

I do have this article open as I'm updating the server to todays release.


I will try this, but as I was having the same issue on the Windows installed server instance, was wondering if it's not something else?


I'll test this and report back.


Thanks for the help.

Link to comment
Share on other sites

It's inapplicable to windows so it would be something else entirely.

Link to comment
Share on other sites


SO I performed the update as advised to ffmpeg.


and the same result really, however no in the ffmpeg log:

smb:// 5th Wave (2016)/The 5th Wave.mkv: Protocol not found
Did you mean file:smb:// 5th Wave (2016)/The 5th Wave.mkv?

Link to comment
Share on other sites

  • 2 weeks later...

HI Luke, I did follow that article, maybe I mised something.


I'll retry the recompile.


Thanks for you assistance.


Adding it into the build would be handy.



Link to comment
Share on other sites


Just thought I would update on this.


So I thought I had resolved this but alas... I fear it is something else.

If I use a windows 10 Client with Emby theatre it plays.

Windows 10 Client with browser, Edge, Chrome does not play.

Emby theatre on XBOX One does not play.

Emby on Android does not play.


With the failures I sill get the same error:

[smb @ 0x81986d0c0] File open failed: Operation timed out
smb:// 5th Wave (2016)/The 5th Wave.mkv: Operation timed out


I reinstalled ffmpeg with all the required options as per the article https://emby.media/freebsd-server.html


To do some additional troubleshooting and comparison I have restarted the Windows based server install, this has the same playback symptoms, no Xbox, no Windows playback via browser.

Yep it's FreeBSD v windows and there are obviously big differences, but one would think windows/windows this would just work as it has been doing until recently.


ffmpeg log on Windows shows:

file:\\freenas\public\Media\MB\Movies\The 5th Wave (2016)\The 5th Wave.mkv: Invalid argument

the clients can resolve the name on the network.


I have attached the windows ffmpeg log file from the Windows installation.


edit: uploading new server log with errors: 403 forbidden ..



Edited by mrvirtual
Link to comment
Share on other sites

I think the issues with the two operating systems are different. On windows we're seeing a network error when trying to access your \\freenas share.


Just from googling around I found this. You may want to go over them:




Let us know if this helps. Thanks !

Link to comment
Share on other sites


Nearly there!


SO I mounted the CIFS share in the Freenas JAIL directly at the storage layer, then added the media via local path with the alternate path using the \\UNC\Path.


Adnroid and web browsers now workikng, XBOX One still a fail, I'll try using IP addresses for this tomorrow.


This was not my prefered method as thsi will at some time in the near future be run from another computer and not the NAS, so I will then need to use the SMB mount path.

I am now trying to mount for Server WMC plugin, the remote WMC recorded TV folder using mount_smbfs, but this seems disabled? running it as root and get mount_smbfs: kldload(smbfs): Operation not permitted

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...