Jump to content

Subtitle download not respecting limits?


sebasmiles
 Share

Go to solution Solved by Luke,

Recommended Posts

sebasmiles

So I have tried on and off to try to get subtitles download to work without success. I tried searching for the problem but the posts I found indicate that once it reaches the 200 limit on a non-VIP it should stop, however that never seems to happen to me.

This has happened over several version (last time I tried was months back) including 3.2.19 which I have loaded right now. I clicked only on episode, then save, then went to tasks and hit the subtitle one to run. It proceeds to spam my activity log and balloons my log file into a massive 200mb file before I was able to stop it by hitting stop manually. Below is my subtitles.xml file (deleted my username and password), and the episode flag is back to false since I had to disable it.

I am running Unraid, with the official Emby docker (or was labeled as such).

<?xml version="1.0"?>
<SubtitleOptions xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <SkipIfEmbeddedSubtitlesPresent>false</SkipIfEmbeddedSubtitlesPresent>
  <SkipIfAudioTrackMatches>false</SkipIfAudioTrackMatches>
  <DownloadLanguages>
    <string>eng</string>
    <string>spa</string>
  </DownloadLanguages>
  <DownloadMovieSubtitles>false</DownloadMovieSubtitles>
  <DownloadEpisodeSubtitles>false</DownloadEpisodeSubtitles>
  <OpenSubtitlesUsername>xxxxx</OpenSubtitlesUsername>
  <OpenSubtitlesPasswordHash>xxxx</OpenSubtitlesPasswordHash>
  <IsOpenSubtitleVipAccount>false</IsOpenSubtitleVipAccount>
  <RequirePerfectMatch>true</RequirePerfectMatch>
</SubtitleOptions>

This is the error where it shows rate limit, I got spammed by these until I was able to tell the scan to stop.

2017-06-21 18:46:34.4418 Error App: Error downloading subtitles
	*** Error Report ***
	Version: 3.2.19.0
	Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /config -restartpath /usr/lib/emby-server/restart.sh
	Operating system: Unix 4.4.30.0
	64-Bit OS: True
	64-Bit Process: True
	Mono: 4.8.1 (Stable 4.8.1.0/22a39d7 Fri Jun  2 05:04:04 UTC 2017)
	Processor count: 2
	Program data path: /config
	Application directory: /usr/lib/emby-server/bin
	System.Exception: OpenSubtitles rate limit reached

Logfile (its too large to attach):

https://www.dropbox.com/s/1tjb09iobrr6wwt/server-63633599999.txt?dl=1

Link to comment
Share on other sites

Just fyi, the daily count is only retained in memory, so if you are restarting the server then that could explain why this is happening. 

Link to comment
Share on other sites

sebasmiles

Just fyi, the daily count is only retained in memory, so if you are restarting the server then that could explain why this is happening. 

Hmm, no restart occurred (I think it would normally split the log file in that case). 

I did download a single subtitle by hand the night before, could it be that the limit wasn't reset yet and it kept trying to get that last one? I did a count and found that it downloaded 199 subtitles in the log file.

 

If that is the case, is there any way to lower the count in memory to say 160 using a flag? that may cover any subtitles downloaded thru other means (ie kodi).

 

Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...