Jump to content

Install emby on Raspbian


Kitraha
 Share

Recommended Posts

Kitraha

Hello,

 

I trying to install emby on a raspberry pi 3 (Raspbian). I have followed the steps: https://software.opensuse.org/download.html?project=home%3Aemby&package=emby-server

 

Debian 8.0

 

1) echo 'deb http://download.opensuse.org/repositories/home:/emby/Debian_8.0/ /' > /etc/apt/sources.list.d/emby-server.list 

ok

2) apt-get update

ok

3)apt-get install emby-server

 

root@raspberrypi:~# apt-get install emby-server

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
               Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-data4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed
               Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
               Depends: libmono-system-transactions4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
               Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libembysqlite3-0 but it is not installable
               Depends: embymagick but it is not installable
               Depends: mono-devel (>= 4.6) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
Can someone help me, please?

Thanks

 

Link to comment
Share on other sites

mastrmind11

try installing mono ahead of emby:

 

sudo mono apt-get install mono-complete

Link to comment
Share on other sites

Kitraha

Hi thanks for your help

 

I have this:

 

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 mono-complete : Depends: mono-runtime (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-runtime-sgen (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-utils (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-devel (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-mcs (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-csharp-shell (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-2.0-gac (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-4.0-gac (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-2.0-service (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: mono-4.0-service (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: monodoc-base (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: monodoc-manual (= 3.2.8+dfsg-10) but it is not going to be installed
                 Depends: libmono-cil-dev (= 3.2.8+dfsg-10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Link to comment
Share on other sites

tdiguy

Are you running raspbian or debian?

Either way these instructions are likely to help:

https://emby.media/community/index.php?/topic/43166-arm-devices-official-instructions/

 

Keep in mind, there are several install instructions on that page. The last time i tried to run docker it did not work out not sure if it was something i did wrong or not.

The section that i used to install last time was:

Installing directly on raspbian or other debian directive without docker (armhf/armv7/aarch64):
wget -qO - http://download.opensuse.org/repositories/home:emby/xUbuntu_14.04/Release.key | sudo apt-key add -
sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/emby/xUbuntu_14.04/ /' >> /etc/apt/sources.list.d/emby-server.list"
sudo apt-get update
sudo apt
-get install emby-server

 

Hope this helps.

Link to comment
Share on other sites

  • 1 month later...
Kitraha

Hello!

 

I succeeded install emby on raspberry pi 3 (thanks to @tdiguy and @@hurricanehrndz ). But is not working well: the CPU is always at 100%. Emby is very slow and the video player is unstable. I think raspberry pi 3 is not powerful enough for a media center.

Link to comment
Share on other sites

tdiguy

Hello!

 

I succeeded install emby on raspberry pi 3 (thanks to @tdiguy and @@hurricanehrndz ). But is not working well: the CPU is always at 100%. Emby is very slow and the video player is unstable. I think raspberry pi 3 is not powerful enough for a media center.

Is emby doing anything when the CPU is 100%? I run emby on a pi3 and it only runs at high CPU usage when it is transcoding, which it now normally doesn't have to since I now convert everything to MP4 format.

 

Sent from my SM-G900P using Tapatalk

Link to comment
Share on other sites

Brian M

Is emby doing anything when the CPU is 100%? I run emby on a pi3 and it only runs at high CPU usage when it is transcoding, which it now normally doesn't have to since I now convert everything to MP4 format.

 

Sent from my SM-G900P using Tapatalk

 

Just out of curiosity, are you using it with Kodi? If so, what's normal CPU usage like for you, and what's transcoding CPU usage? Mine's using less than 3% with occasional spikes to the high sevens, with no transcoding.

Link to comment
Share on other sites

tdiguy

I don't use kodi, never figured out how to get the two to work together. But ya with it not transcoding it normally is pretty low.

 

Sent from my SM-G900P using Tapatalk

Link to comment
Share on other sites

Kitraha

Hi Luke and Brian M!

 

@@Luke Sorry I can not.. I uninstall emby 5 days ago and send back my pi3 to Amazon

 

@Brian M No, just emby

Link to comment
Share on other sites

@@Kitraha, there is a lot of transcoding happening here and that is the reason for your poor playback experience. The RPI is not suited for video transcoding. Transcoding is happening in the browser because browsers do not support HEVC, which your videos contain.

 

Does this help answer your question? If you limit your playback to formats that don't need video transcoding, you'll get a better experience.

Link to comment
Share on other sites

  • 2 weeks later...
mrbrahman

Question is not on Raspberry Pi, but related to the info provided above...

 

... it now normally doesn't have to since I now convert everything to MP4 format.

 

I am playing an mp4 (ripped from my personal DVD) on the latest versions of Firefox and Chrome, and when I play it, I see there an "ffmpeg" process (on Linux where emby-server is installed) which probably means some transcoding is going on. Can someone help understand in what circumstances transcoding will or will not happen?

Link to comment
Share on other sites

tdiguy

Question is not on Raspberry Pi, but related to the info provided above...

 

 

I am playing an mp4 (ripped from my personal DVD) on the latest versions of Firefox and Chrome, and when I play it, I see there an "ffmpeg" process (on Linux where emby-server is installed) which probably means some transcoding is going on. Can someone help understand in what circumstances transcoding will or will not happen?

Easy way to see if it is transcoding is to log onto the server while the movie is playing, on the dashboard it will say who is watching what, if it says direct play its not transcoding. If i remember Luke correctly there are no web browsers currently that support direct play of mp4's. To avoid transcoding you will want to use either an emby app, emby theater or kodi with the emby plugin. I myself have not set up kodi with the emby plugin.

Link to comment
Share on other sites

Easy way to see if it is transcoding is to log onto the server while the movie is playing, on the dashboard it will say who is watching what, if it says direct play its not transcoding. If i remember Luke correctly there are no web browsers currently that support direct play of mp4's. To avoid transcoding you will want to use either an emby app, emby theater or kodi with the emby plugin. I myself have not set up kodi with the emby plugin.

 

The short answer is, the video needs to be supported natively by the browser you're using. If not, then you'll see transcoding.

 

If you would like a more detailed example, then please discuss an example, and then attach the information requested in how to report a media playback issue. thanks !

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...