Jump to content


Photo

Trouble with new app, images in constant refresh loop


  • Please log in to reply
8 replies to this topic

#1 srowley OFFLINE  

srowley

    Newbie

  • Members
  • 5 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 12:33 AM

Sorry, this is my first time posting here, so please forgive me if I am not following protocol.

 

I was updated to the new Roku app, and have been having trouble since. Basically, whenever I go to a movie detail view, the display goes into a frenzy that would give an epileptic nightmares. The backdrop images cycles through the image, grey, black, etc. Related movies and actors also go on the fritz by showing up and then disappearing. I tried it on both my Roku 2 (2015 model) and Roku Express. My friend also had the same issues when connecting to my server. We did notice that we didn't have the issues connecting to his server. I updated to the latest version: 3.2.17.0, so there is nothing to do there. Process of elimination tells me it's something having to do with my server, but I'm not sure what it could be.

 

Any help is greatly appreciated.


Edited by srowley, 23 May 2017 - 12:34 AM.


#2 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 4446 posts
  • Local time: 04:54 PM

Posted 23 May 2017 - 12:44 AM

As a test, can you try using this app:
https://my.roku.com/...el=EmbyBlueNeon

Is there any difference with the images?

Also, are you using premiere? If not, make sure use enhanced images isnt enabled.

Are you using https for your server? If so, can you try again using just http on the server. Roku does not like self-signed certs.

Last one, if you click into "Device Info" in the options row of the blue neon app linked above, what is shown for "Version"?

Edited by speechles, 23 May 2017 - 12:47 AM.


#3 srowley OFFLINE  

srowley

    Newbie

  • Members
  • 5 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 09:49 AM

speechles, thanks for the response.

 

I downloaded the Blue Neon app, and my Roku version is 047.60E04125A

 

I am not using Emby Premiere, so I checked the enhanced images settings and it was already disabled.

 

I am using http for the Roku.

 

I also attempted to disable backdrop images and that doesn't seem to be doing anything.

 

And finally, I'm not sure what you mean by difference with the images. I'm not sure what I'm comparing to.

 

Thanks!



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44762 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 10:35 AM

Hi.  I don't think a comparison to BN will help in this case as everything is completely different with our new app.

 

Can you please follow the instructions for sending a log from the app here?  Thanks.



#5 srowley OFFLINE  

srowley

    Newbie

  • Members
  • 5 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 11:31 AM

I sent the debug log at 15:28 UTC time.

 

The user logged in was 'Shane'

 

I was in the movie detail view and every image tile loaded and disappeared indefinitely.



#6 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44762 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 11:40 AM

And it was doing all that during that session?  How long did you let it sit?

 

There is nothing unusual in the log.



#7 srowley OFFLINE  

srowley

    Newbie

  • Members
  • 5 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 01:10 PM

Yes, the entire time.



#8 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 4446 posts
  • Local time: 04:54 PM

Posted 23 May 2017 - 01:19 PM

The app is too busy for your device unfortunately. I bet all resources are in use, and garbage collection is responsible for blanking your images.

To confirm this, you need to install developer mode on your roku.

See here: https://blog.roku.co...er-setup-guide/


After getting your device into developer mode, setting a developer password, and the roku reboots thats all you need to do. Then try to telnet the roku on port 8080.

telnet [roku ip here] 8080

You should get a > prompt meaning you are in. Once you are in the console, type free and paste what shows up.

When the roku runs less than 25MB of free space it will induce constant garbage collection. The video player must have at least 25MB of cache space or the video player will crash/reboot the roku during buffering.

Is anyone else running express or express+ and having this problem?

How many apps do you have on your roku2? For the same thing to affect a roku2 would require you have a ton of apps installed, and no sd card in the slot to add capacity.

Edited by speechles, 23 May 2017 - 01:27 PM.


#9 srowley OFFLINE  

srowley

    Newbie

  • Members
  • 5 posts
  • Local time: 07:54 PM

Posted 23 May 2017 - 06:00 PM

I have an 8GB SD card in the slot. and 50 apps installed. I will check with the dev mode this week. Thanks for your feedback!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users