Jump to content

3.2.12 & text subtitles not displaying


jbscout
 Share

Recommended Posts

jbscout

Windows 3.2.12 server sending to Amzn Fire TV client.  

 

MKV files with embedded text subtitles (closed captioning).

 

Pre-3.2.12 everything worked great.  Just like it was supposed to.  The text subtitles were picked up as the default and displayed properly.

 

Post-3.2.12,  not so great.  The text subtitles are picked up as default, and Emby tries to show them but fails.  First, I get "Subtitles loading ..." on screen and then a "Unable to load subtitle" message.

 

I can switch to graphics subtitles (e.g., switch from default/text subtitles track #2 to graphics subtitles track #1) and those graphics subtitles will show correctly.

 

Sometimes (but not always) I can then (after a few seconds) switch back to the text subtitles, and they will show correctly now.

 

Emby (post-3.2.12) really doesn't like the subtitles when resuming.  

 

.

 

Has anyone else experienced this?

 

Thanks

Edited by jbscout
Link to comment
Share on other sites

jbscout

Thanks

 

My server.log is attached.

 

At around 2017-04-17 21:50 you'll see (or not, I can't read it intelligently):

  1. The MKV play and fail to load the default (#3) SRT subtitle
  2. Me switch to the DVDSUB #1 subtitle, which loads
  3. Me switch back to the default (#3) SRT subtitle, wich loads

There was no ffmpeg log file for this (which is weird as I have plenty of other ffmpeg files from a few days ago).

server-2017-04-17-19-10_Log.zip

Edited by jbscout
Link to comment
Share on other sites

@@jbscout, if you try to play that video a second time, do the subtitles display? We extract the subtitles from the video on the fly and sometimes this can cause a delay before the subtitles are available. 

 

Can you try to play this again, then submit an in-app fire tv log for @@ebr to review? You can learn how to do that here:

 

https://emby.media/community/index.php?/topic/739-how-to-report-a-problem/

 

Scroll down to the android tv/fire tv logs section. Thanks !

Link to comment
Share on other sites

Thanks

 

My server.log is attached.

 

At around 2017-04-17 21:50 you'll see (or not, I can't read it intelligently):

  1. The MKV play and fail to load the default (#3) SRT subtitle
  2. Me switch to the DVDSUB #1 subtitle, which loads
  3. Me switch back to the default (#3) SRT subtitle, wich loads

There was no ffmpeg log file for this (which is weird as I have plenty of other ffmpeg files from a few days ago).

 

That process sounds like they are being extracted and that takes too long but then they are available for subsequent play attempts.

Link to comment
Share on other sites

jbscout

Sorry it took me so long to reply

 

The assessment that things time out when extracting sounds plausible, but why did it start with 3.2.12?

 

The Fire TV logs were sent on 2017-04-21 at approximately 11:00 pm.  And I was loged on as jbscout on the local server.

 

In addition the local server and now ffmpeg logs (which decided to be generated this time) are attached.  I updated to 6.2.13 earlier in the day.

 

 

 

I can get the subtitles to eventually play.  Res Evil's subtitles played this time.  But you'll see that 3 Days of Condor had subtitle issues.  

 

The issue isn't limited to a single  "bad" file.  

 

 

Thanks

ffmpeg-transcode-e7ba552d-8c91-4c97-b5fe-00f6fe3ba719 04-21-2017 1113 PM.txt

server-63628388943 4-21-2017 1117 PM.txt

Edited by jbscout
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...