Jump to content


Photo

No video playback, multiple monitors. Win 10

video playback multiple montors win10 nvidia black screen

  • Please log in to reply
3 replies to this topic

#1 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 458 posts
  • Local time: 08:31 AM

Posted 30 March 2017 - 06:09 PM

I have never been able to get Emby Theater (software not Win store app)to play on my desktop. It has 3 monitor setup.  I hadn't gotten around to making a post about it. 

 

Emby theater will just play audio of live tv, but just show a black screen. Same black screen with audio plays with local H264 files. When i try to playback my live TV recordings (mpeg2) it just loads it for a sec(black screen) then stops going back to the video description page.   Doesn't matter what monitor I load it up on. No change if I toggle the Video rendered form Madvr to EVR etc.

 

I disable my 2 other monitors via the Nvidia control panel and only use my primary monitor, Emby Theater plays all media fine. 

 

Currently using Emby  Theater 2.5.40.  But this issue I noted even back when it first came out.  I did it on my GTX 970 and still does it on my GTX 1080. Nvidia drivers made no differance but are current. Still using the same monitors.  Windows 10.

 

Not sure on how to get any logs or more info from the software itself. Nothing seems to be reported on the server or transcode logs on the server itself that would indicate an issue. They look the same each time i test it, multi monitor enabled or not. 


Edited by speedingcheetah, 11 April 2017 - 07:20 PM.


#2 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 458 posts
  • Local time: 08:31 AM

Posted 17 April 2017 - 12:10 AM

I discovered that this is happening due to Auto streaming setting. In Auto it will use Direct Play when i load some channels. But other channels default to transcode and those play fine. 

 

When I just get the black screen, I can toggle the Auto - Direct  to a transcode quality setting and it will play the video stream....then set it back to auto Direct and re-loads the stream and shows the video fine in Direct Play.

 

Don't have to mess with disabling monitors or anything.


Edited by speedingcheetah, 17 April 2017 - 12:11 AM.


#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139871 posts
  • Local time: 09:31 AM

Posted 17 April 2017 - 12:30 AM

Thanks for the feedback.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139871 posts
  • Local time: 09:31 AM

Posted 30 April 2017 - 06:16 PM

The next release of the app will feature improved performance, hardware acceleration, and better multi-monitor support. If you'd like to try it out ahead of time you can do so here:

 

https://emby.media/c...mpv-test/page-1

 

Enjoy.







Also tagged with one or more of these keywords: video, playback, multiple montors, win10, nvidia, black screen

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users