Jump to content
kanipek

Legacy HDHomeRun - Setup

Recommended Posts

kanipek

To get legacy HDHomeRun Units (HDHR-US, HDHR3-US etc.) to work within Emby do the following:

 

1 - Minimum firmware required is: 20161117 latest is always best. Find it here: https://www.silicondust.com/support/downloads/

 

2 - Install the HDHomeRun software on your system.

   - I chose "Default" BDA compatibility mode

   - Perform a channel scan from within the HDHomeRun software, before beginning the scan use the pull down menu to select the legacy tuner.

   - When the scan is complete click "Apply" this will generate a new "Digital Cable.xml" or "Digital Antenna.xml" and send the data to Silicondust for use by the tuners.

 

3 - Open the Emby (v3.2.7 and later) dashboard - There is currently no automatic discovery so you will have to set it up by entering the IP address on the tuner setup page (Manage Server->Live TV->+Add).

   - Check "Enable this tuner" - on the Add Tuner page

   - Click "Save" - Once you click save Emby should kick off a "Refresh Guide" task. Let it complete.

   - Map the new - un-mapped channels under Live TV->Guide Providers - this will kick off another "Refresh Guide" task, let it complete.

 

4 - Followed all the instructions but get a black screen or maybe spinning circle when tuning? Try allowing UDP:// through the firewall for the tuner connection(s).

 

That is it.

 

Notes:

There is currently no ability that I know of to disable any channel on these units. If I am wrong in that assumption please let everyone know how you did it.

 

For me I only had to map a few channels 15+/-. The rest of the channels (this is a guess on my part) were previously mapped.

 

You MUST install the HDHomeRun software and do a fresh scan for it all to work.

 

Post from Silcondust that might be helpful:

https://forum.silicondust.com/forum/viewtopic.php?f=92&t=43986

 

I compiled this info from several posts/users here on the forum. My thanks to all of them.

 

Big thanks to @@sle118 for getting this ball rolling and @@Luke for making it happen, I am sure others were helpful too - Great, fast work guys!

Edited by kanipek
  • Like 2

Share this post


Link to post
Share on other sites
BAlGaInTl

Good guide. Thanks for putting it together.  I just got the legacy system up and running as well.

 

I would add to #2 that this can only be done in Windows at the moment.  Not sure about MacOS  as I don't have one to test.  My server system is all Linux and even though I had a full TVHeadend install running/working, the fact that I had to scan in Windows had me scratching my head for a couple of days.

 

I would also like the ability to disable channels as there are a few that I pick up that I just don't care to see.

 

ETA:

 

I created a feature request for this.  Who knows... maybe it will show up.

Edited by BAlGaInTl
  • Like 1

Share this post


Link to post
Share on other sites
arasquinha

how are you getting the hdhr-us (dual) orginal tuner to work. from what i have read in the forum maybe only the ones that support DLNA are working?

Share this post


Link to post
Share on other sites
Luke

how are you getting the hdhr-us (dual) orginal tuner to work. from what i have read in the forum maybe only the ones that support DLNA are working?

 

No, the legacy tuners are supported now just the same.

Share this post


Link to post
Share on other sites
kanipek

how are you getting the hdhr-us (dual) orginal tuner to work. from what i have read in the forum maybe only the ones that support DLNA are working?

 

If you follow the steps in post #1 they will work in Emby. You have to do all of the steps to make them work. The channel scan within the HDHomeRun Setup software is critical and must be performed for each HDHomeRun you wish to use in Emby. It has to be done from the setup software there is no capability to scan those units from the webpage gui. There is currently no channel management capability in Emby or the HDHomeRun Setup software for that matter. So you are going to see ALL the channels available on those tuners - and in my experience you are going to see them duplicating channels that are already in the guide seems to be a limitation of these older units. If you have a number of unwanted channels appearing in your guide you can to some pseudo channel management by using tags to remove those from the guide something like CHANNEL_EXCLUDE - it's not the easiest thing to do but it does work.

 

Hope this helps.

Edited by kanipek

Share this post


Link to post
Share on other sites
arasquinha

No, the legacy tuners are supported now just the same.

ok thank you. i followed all the steps listed here to get it going. I have the other thread open for help with my issue. 

Share this post


Link to post
Share on other sites
BAlGaInTl

Yup.  They work fine.

 

I've been using them for a several months now.  You just have to make sure to check all the boxes.

Share this post


Link to post
Share on other sites
arasquinha

could you post screenshots of the way you settings look like?

i did what was suggested and scanned the channels before i added it to emby. emby seens the channels. It just cant display the video. it just shows a spinning circle. 

 

i think it some sort of codec/transcoding issue.

Share this post


Link to post
Share on other sites
BAlGaInTl

So you have a guide?  And it has information populated in it?

 

But when you try to play something, it just never plays?

 

What device are you trying to play on?  Have you just tried using the web application?

 

You may want to check out How to Report a Problem with some more details if it's really a playback issue.

Share this post


Link to post
Share on other sites
arasquinha

Yes used the web app. The theater and android apps. Had to use the free 1 minute play still nothing in all 3. Also tried kodi saw the channel listing when I went intp the emby app in kodi

Share this post


Link to post
Share on other sites
arasquinha

To clarify. Yes emby sees the channels and the guide maps. I just can't seem to start the stream. The steam works using the hdhomerun and vlc applications

Share this post


Link to post
Share on other sites
kanipek

To clarify. Yes emby sees the channels and the guide maps. I just can't seem to start the stream. The steam works using the hdhomerun and vlc applications

 

What do you see in the server dashboard when attempting to stream a channel? - When I was sorting this out on my Shield the dashboard showed whatever channel I was trying to watch as actually streaming to the device, finally got it working by using the Direct Streaming option, and using VLC for playback and a lot of assistance from @@ebr & @@Luke. If you are not seeing anything in the web app your issue might be different from mine.

 

What types of devices are you trying to watch on? 

 

Reboot all of your hardware - tuners, client devices, server, router, network switches/hubs. Verify your firewall rules are set up - maybe even temporarily disable it.

Share this post


Link to post
Share on other sites
arasquinha

i am not sure where to look in the dashboard. 

when i look while i am trying to play live tv . the main page of the dashbord doesnt really update.

 

all my firewalls are off

i have tried rebooting the hdhomerun. i tried running the emby server in a different vm with a different OS

 

i can use the hdhomerun setup program and stream to vlc. 

 

how do you use vlc and emby?

server.bmp

Edited by arasquinha

Share this post


Link to post
Share on other sites
arasquinha

 went back and tested my music library and it immediately shows up that its playing. However for the live tv the dashboard does not update with anything

Share this post


Link to post
Share on other sites
Luke

Have you tried the new release of the server that went out today?

Share this post


Link to post
Share on other sites
arasquinha

yes just did

no diff :-(

Share this post


Link to post
Share on other sites
kanipek

i am not sure where to look in the dashboard. 

when i look while i am trying to play live tv . the main page of the dashbord doesnt really update.

 

all my firewalls are off

i have tried rebooting the hdhomerun. i tried running the emby server in a different vm with a different OS

 

i can use the hdhomerun setup program and stream to vlc. 

 

how do you use vlc and emby

On the first page of the dashboard you should a list or what I would call tiles/thumbnails of what client is connected and what they are playing and how it is being played - direct play or transcode etc.

 

I guess I should have asked you what you clients you are attempting to playback on - in Emby for android TV if you go into options near the bottom you will see a checkbox to use VLC to play-- You have yo install VLC from the play store to have it work.

 

I'll check back later to see if you have made any progress.

Share this post


Link to post
Share on other sites
arasquinha

on the first page when i looked while playing a music file I saw it update and show up as playing and stopped playing depending on what I was doing. However when I clicked on a live tv channel the space never changed. Its like it was not being told to start. 

 

I am using emby in my chrome browser. I also used it installed on my android tablet and I installed the android theater app in my windows 10 device. All do the same thing. i have not seen a setting in emby anywhere (that I have used) that says play to vlc

On the first page of the dashboard you should a list or what I would call tiles/thumbnails of what client is connected and what they are playing and how it is being played - direct play or transcode etc.

 

I guess I should have asked you what you clients you are attempting to playback on - in Emby for android TV if you go into options near the bottom you will see a checkbox to use VLC to play-- You have yo install VLC from the play store to have it work.

 

I'll check back later to see if you have made any progress.

Share this post


Link to post
Share on other sites
kanipek

on the first page when i looked while playing a music file I saw it update and show up as playing and stopped playing depending on what I was doing. However when I clicked on a live tv channel the space never changed. Its like it was not being told to start. 

 

I am using emby in my chrome browser. I also used it installed on my android tablet and I installed the android theater app in my windows 10 device. All do the same thing. i have not seen a setting in emby anywhere (that I have used) that says play to vlc

 

Okay so you are looking in the right place that is good.

 

You have done the channel scan in the HDHomeRun software? Added the tuners under Live TV in Emby and mapped guide data to those tuners/channels?

 

Are you getting any logs showing something is trying to stream/play when you are trying to play a channel - they would be in the log directory -- ffmpeg-transcode... or anything similar?

 

These are the old original dual tuner units (white) correct? Firmware version? HDHomeRun software version?

 

Using Emby for Android TV - not Emby for Android there is an option to use VLC to play live tv. Emby for Android has a similar setting - Enable external video players -- but again you have to have a player like VLC loaded on the device. Not sure about Emby Theater but I don't think it has this setting currently.

Edited by kanipek

Share this post


Link to post
Share on other sites
arasquinha

my emby logs are in this thread

https://emby.media/community/index.php?/topic/51249-original-hdhr-us-support-with-live-tv/

 

emby detected the hdhomerun and added it. i added xmltv and i can see the channels in it and mapped correctly.  when i go to stream live tv i see the channels/schedule etc and thats what i click on to start playing the stream when nothing seems to happen. 

 

these are the orginal tuners hdhr-us dual/white with a 100 mbps network jack. 

 

the firmware is 20170815

the application that i have used to watch the live stream is the hdhomerun setup app that does the scanning etc. when i click on a channel it detects it pulls it up in vlc player installed (windows 10)

 

the hdhomerun app that is also installed (not the setup but the viewer) does not work. it can see the channels but nothing plays. i thought that limitation of the hdhr app since it only supports newer devices. 

Share this post


Link to post
Share on other sites
kanipek

my emby logs are in this thread

https://emby.media/community/index.php?/topic/51249-original-hdhr-us-support-with-live-tv/

 

emby detected the hdhomerun and added it. i added xmltv and i can see the channels in it and mapped correctly.  when i go to stream live tv i see the channels/schedule etc and thats what i click on to start playing the stream when nothing seems to happen. 

 

these are the orginal tuners hdhr-us dual/white with a 100 mbps network jack. 

 

the firmware is 20170815

the application that i have used to watch the live stream is the hdhomerun setup app that does the scanning etc. when i click on a channel it detects it pulls it up in vlc player installed (windows 10)

 

the hdhomerun app that is also installed (not the setup but the viewer) does not work. it can see the channels but nothing plays. i thought that limitation of the hdhr app since it only supports newer devices. 

 

Okay it seems to me there is a common failure to play going on here. 

 

The HDHR setup app should always play the channels - unless there are issues with the tuners -- seems like the tuners are ok.

 

So Emby and the HDHR view app are showing the same symptoms - Is this the HDHR DVR version? - That is what I am using and the older HDHR duals do work with it -- with some limitations for me they work fine viewing wise but all the channels get duplicated in the HDHR DVR viewer, do I get a duplicate set of channels for each of the older tuners that I connect - eventually went to using just one of the because of that.

 

I am really at a loss here on my end. It is acting like there is an issue with the firewall blocking the streams - your are certain there only 1 firewall installed and it is off?  What router are you using? Is there a firewall in the router? Depending on the configuration of the router some changes might be needed to get it setup on that end also.

 

Could also be an issue with your network - what is the configuration of your network ?

 

I am going to re-do setting one of these up and confirm all is working it will take a while to do that I will let you know how it goes.

Share this post


Link to post
Share on other sites
arasquinha

 

 

ignore above this line. 

 

 

internally i have switches that connect evertying to my Access points. but there are no firewalls running on my local devices that prevent communication with each other. 

 

however externally i do have a firewall. i presume this is some sort of way for the hdhr device to talk to its home base? if so what port would i need to open for it?

 

can you send me a link to the hdhr dvr viewer app you are referring too. i might try to download and install that to see if it works. 

i used the hdhr viewer app that comes from windows 10 store that didnt work. and neither did the hdhr app from the play store in android on my tablet. 

 

the only thing working with my hdhr-us tuner right now is using the hdhr setup program and clicking on the link that shows up in it and when clicked it opens up the stream in vlc

 

see attachment

server.bmp

Edited by arasquinha

Share this post


Link to post
Share on other sites
kanipek

@arasquinha Okay. I have reverified that the procedures from post #1 are in fact still valid.  I haved tested on Android, Android TV and the web app - all work.

 

This doesn't of course solve your issue but does let us know they do in fact still work.

 

Are you doing any transcoding or hardware acceleration by any chance? (in Emby Server) - http://localhost:8096/web/encodingsettings.html

 

What are your live tv settings - http://localhost:8096/web/livetvsettings.html

 

Do you have any plugins installed in Emby? - http://localhost:8096/web/plugins.html

 

Are you trying to transcode with these tuners in live tv devices?

 

I really need to know what the network map looks like, what the router configuration is to proceed further. If you are not comfortable posting that I understand, possibly PM it to me? or another means?

 

When I am talking about firewalls I am talking your Emby server machine and your router specifically. 

 

You asked about ports being open - this tells me that somewhere there is a firewall(s) on the network. Emby server default ports are: http: 8096, and https: 8920.

 

The HDHR DVR viewer is only useable by those that have paid to use it - at least that is how it was originally setup though it may have all been combined by now - https://play.google.com/store/apps/details?id=com.silicondust.view&hl=en

Share this post


Link to post
Share on other sites
arasquinha

i have a windows 2016 server running emby the issues i am having are also occuring on this device so its not a firewall issue. 

i do have the firewall turned off. the hdhomerun is on the same internal network/lan. it should not have firewall issues. 

 

i have not installed any plugins

 

 

server.bmp

server - Copy.bmp

server - Copy - Copy.bmp

server2.bmp

Share this post


Link to post
Share on other sites
Luke

Hi, log files are more helpful right now than those configuration screenshots. thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...