Jump to content

OMV 3 Emby Server 3.1.283~beta13.1


mikeB2210
 Share

Recommended Posts

mikeB2210

Hi,

 

since yesterday OMV 3 NAS offered offered me an update to emby server 3.1.283~beta13.1

 

Anybody knows what going on?

Link to comment
Share on other sites

thatoneguy99

Hopefully the text isn't too small for you to see/read. This is a list of my apt sources.

 

b99e68cb06a01f6e9dc9d1d90ffb1db5.jpg

 

 

Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Bbqninja

Hey guys, to add details, you have uploaded an incorrect ubuntu package (possibly for other linux versions as well).

 

This version is a beta, AND is versioned "3.1.283".

 

IF you look here you will see the packages: http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.10/   

I don't know how it got there, but given the tilde in the name I'm guessing a build-bot messed up a regex?

 

This will cause a huge and ongoing issue for people who install this package.  ANYONE who has done a debian update since the 24th will have this issue!!!!!!!!!!!!!!!!

 

Due to versioning, anyone who installs this version will never update emby again until you publish version 3.1.284 or 3.2.

 

I was able to fix the issue locally adding the following text to /etc/apt/preferences.d/emby_bad  (the file didn't exist before, I created it):

Package: emby-server
Pin: version 3.1.283~beta-13.1
Pin-Priority: -1

This code tells apt to NEVER install that version.  I then had to run the following to get it to swap back to 3.1.4:

 

sudo apt install emby-server=3.1.4-14.1

The way I see it there are 3 ways to fix the issue from the "emby guys" end:

 

  1. Put a notice on the web interface about the issue, with a link to a page with the information I've posted (really relies on people knowing how to toy with linux, so not a super-hot idea)
  2.  update the current version, either to 3.2.1 or 3.1.284.  It will look silly, but that's the issue we have now.
  3. Do some package shenanigans as detailed below.  I warn you these instructions will work, but really are shenanigans...
  • publish emby 3.1.4-14.2 which is the same as 3.1.4-14.1 but with the emby_bad file I detailed above included
  • pblish emby-server 3.1.284, with a dependency on emby-server-fix 1.1.1 (an EXACT version match, not a normal >= 1.1.1 )
  • publish emby-server-fix 1.1.1 which creates emby_bad AND outputs some text with instructions on how to force the apt to downgrade emby-server (eg the command above).
  • publish emby-server-fix 1.1.2 which has a dependancy on emby-server >= 3.1.4, but also still has the emby_bad file

 

What this will happen is:

  • anyone with 3.1.4 will upgrade to the new 3.1.4, which will then prevent the bad-version from ever showing up
  • anyone with 3.1.283 will update to 3.1.284, which will auto-add the emby-server-fix package, which adds the emby_bad
  • A version pin with -1 will NOT cause a package downgrade, hence emby-server-fix doing the prompt telling a user how to do it.  I'm also fairly certain you cannot call apt yourslef from within a dpkg script...
  • Anyone with ember-server-fix will now have the newer emby-server, AND the emby_bad file.  

 

End result is anyone who had the bad file now has it blocked, and everyone else goes on like normal (since users without the bad version will never have gotten the emby-server-fix package).

 

There's possibly a way to make a dependant file FORCE the downgrade of another package, but I'm not 100% on how to do that.

 

 

Happy to chat about it, I've got a bit of experience with linux packaging etc.

  • Like 1
Link to comment
Share on other sites

sualfred

Another solution:

1. sudo nano /var/lib/dpkg/status

2. find the emby-server entry block and remove it

3. save the file

4. apt-get update

5. apt-get install emby-server

  • Like 2
Link to comment
Share on other sites

Thanks for reporting this. We will most likely move to 3.2 very soon, not only for this issue but for other reasons. That will get everybody updated and when we do that, we'll adjust our release process so that this never happens again.

  • Like 1
Link to comment
Share on other sites

Another solution:

1. sudo nano /var/lib/dpkg/status

2. find the emby-server entry block and remove it

3. save the file

4. apt-get update

5. apt-get install emby-server

Ok. I worked

 

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...