Jump to content

Question about Windows sleep


ShoutingMan

Recommended Posts

ShoutingMan

It seems that Emby Server prevents my Win10 HTPC from sleeping. If I manually put the computer to sleep, it will wake up a second or two later. I've quit or disabled various applications that were possible causes. As far as I can tell, it's specifically Emby Server.

 

Is this a known behavior? Is there a server setting I should trying changing so Emby can let the computer go into and remain in sleep mode?

 

Thanks

Link to post
Share on other sites

Hi, Emby does not do anything to wake the machine. If users are connected that might prevent it from sleeping, but once it goes to sleep it's not even possible for Emby to wake it. Most likely your network adapter is responding to activity from other devices on the network.

Link to post
Share on other sites
Happy2Play

I wish EMBY server could do that, even stop it from automatically restarting for updates. But alas, it does not.

There is a Dashboard option for that.  Dashboard-Settings-Automatic Updates-Allow the server to restart automatically to apply updates

Link to post
Share on other sites

There is a Dashboard option for that. Dashboard-Settings-Automatic Updates-Allow the server to restart automatically to apply updates

Ah, I meant the forced restart of the whole machine that windows 10 home does on its own.
Link to post
Share on other sites
ShoutingMan

Hi, Emby does not do anything to wake the machine. If users are connected that might prevent it from sleeping, but once it goes to sleep it's not even possible for Emby to wake it. Most likely your network adapter is responding to activity from other devices on the network.

 

Ok, Thanks. I'll check if the AppleTV's might have the Emby app running and are pinging the server in the background. 

Link to post
Share on other sites

If you don't want your PC to 'Wake On LAN' (that's what it's doing) then simply disable the 'Wake On LAN' setting on the NIC Device properties in Windows 10.    this is totally independent of Emby and will stop ANY device waking your PC from the network .. :)

 

 

Link to post
Share on other sites
ShoutingMan

Thanks for the tips. After some more experimentation, I see that it's not Emby per se. It seems to be one of those deeply weird Windows bugs that affects some few people, preventing Windows from going to sleep automatically. I've tried the standard tweaks of enabling sleeping while streaming, checking the problem with powercfg in the cmd terminal, and so on. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...