Jump to content


Photo

Custom DLNA profile functionality broken?

DLNA custom profile mede8er default behavior direct play

  • Please log in to reply
5 replies to this topic

#1 tgunergun OFFLINE  

tgunergun

    Advanced Member

  • Members
  • 39 posts
  • Local time: 08:53 AM

Posted 14 January 2017 - 06:00 PM

[UPDATE] -> It works if i browse the DLNA server and play content from mede8er! Now testing with 8player client....

[UPDATE2] -> I created another custom profile for 8player client and it did work like a charm!

[SOLVED]

 

Hi Guys,

 

I created a custom profile for my mede8er player but so far could NOT get the direct play functionality working, it keeps converting my flacs to mp3 and then stream to mede8er.

 

Is there any way to change default behavior from streaming to direct play for all files? I edited default.xml, added flac into direct play sections, but every time i restart the server, it  reloads the original files from somewhere.

 

Following log appears WITH OUT my custom profile IN PLACE ; IF i add a custom profile, "Info Dlna" section never appears again (i was hoping to see, yes we found your custom profile type of entry in the log files ;-)) see attached files.

 

2017-01-14 21:43:26.9227 Info Dlna: No matching device profile found. The default will need to be used.
    Host: 10.0.0.30:8096
    User-Agent: RealtekVOD/1.0.0 (Linux)
    Keep-Alive: 300
    Connection: Keep-Alive
    Accept: */*
    transferMode.dlna.org: Streaming
    getcontentFeatures.dlna.org: 1
    Range: bytes=0-
    Accept-Ranges: bytes

 

Many thanks for your help.

 

Cheers,

Tunc

Attached Files


Edited by tgunergun, 14 January 2017 - 07:36 PM.


#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14308 posts
  • Local time: 01:53 AM
  • LocationWashington State

Posted 14 January 2017 - 06:28 PM

Your custom profile is not used in the log.  You will probably have to add the User-Agent. DLNA-Profiles-select your profile-Identification-HTTP Headers

 

To me it looks like you need to add

User-Agent: 8player/2.0

Name:  User-Agent

Value:  8player

Match type:  Substring

 

Ensure you hit save then restart server.

 

If that doesn't work then I would try changing it to RealtekVOD.



#3 tgunergun OFFLINE  

tgunergun

    Advanced Member

  • Members
  • 39 posts
  • Local time: 08:53 AM

Posted 14 January 2017 - 06:44 PM

Your custom profile is not used in the log.  You will probably have to add the User-Agent. DLNA-Profiles-select your profile-Identification-HTTP Headers

 

To me it looks like you need to add

User-Agent: 8player/2.0

Name:  User-Agent

Value:  8player

Match type:  Substring

 

Ensure you hit save then restart server.

 

If that doesn't work then I would try changing it to RealtekVOD.

 

Indeed, I had to create another custom profile for 8player client. 

I always thought DLNA client is just used to browse media (communication wise) even when i select a renderer from client and play a tune.

Seems DLNA renderer never connects to server directly in the above scenario.

 

many thanks and updated my original post.

 

cheers

tunc 


Edited by tgunergun, 14 January 2017 - 07:38 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128649 posts
  • Local time: 04:53 AM

Posted 14 January 2017 - 06:45 PM

What exactly is your issue at this point?



#5 tgunergun OFFLINE  

tgunergun

    Advanced Member

  • Members
  • 39 posts
  • Local time: 08:53 AM

Posted 14 January 2017 - 06:46 PM

What exactly is your issue at this point?

 All solved, I'm a happy bunny ;-)

If you wish, you can delete my post.


Edited by tgunergun, 14 January 2017 - 06:46 PM.


#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128649 posts
  • Local time: 04:53 AM

Posted 14 January 2017 - 06:47 PM

Have fun :)







Also tagged with one or more of these keywords: DLNA, custom profile, mede8er, default behavior, direct play

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users