Jump to content

Live TV Issues


Tezza4x4
 Share

Recommended Posts

Tezza4x4

Hi,

 

Just installed Emby on my Synology NAS and running it with HD HomeRun Connect for Live TV. Currently a MediaPortal / Plex user and thinking about migrating.

Installation was a breeze, and I got everything up and running fairly quickly, but just got a few issues with Live TV. I'm using an xmltv file from IceTV here in Australia for the TV guide. It seems to be a fairly reliable service, as they do tend to pick up many of the "late programming changes" I see many on the various forums complaining about with Australian guide data. 

 

I prefer to use the Guide option for viewing - stuck in my old TV ways, but there are a number of problems with how Emby is presenting the guide. 

 

The first problem is that I can't seem to order the channels in the order I would like. I tried using the sort tag, but it's not working properly. I'm tagging the channels in groups, like 1-1, 1-2 etc for ABC channels, 2-1, 2-2 etc for SBS channels and so forth, so they are grouped by FTA provider. This does change the order of the channels, but it's all messed up and not following the sort tag properly, and displays the channels in different orders on different devices. I guess I'm assuming that's what the sort tag was for - to order the channels as you pleased?  I'd also like the ability to not display some channels. In Australia, we have a lot of duplicate FTA channels with exactly the same programming on them. I'd like to be able to turn these channels off altogether in the guide, but I can't seem to be able to find a way to do that.

 

Second problem is that I can map the duplicates with the same channels found in the xmltv guide, but it seems that it will only actually display program info for the first channel mapped. the duplicates show no data.

 

Third problem is that I can't "unmap" any channels and leave them blank. When the guide is first imported, it did seem to automatically map some channels. There is something in the IceTV guide that must look like a channel number (which I think is just the id IceTV uses for the channel), and it automatically picks that up and maps it to a channel. Problem is, there are some rubbish infomercial channels that it mapped, and now I can't delete the mapping and leave that channel without any EPG. 

 

Final problem is picture quality with Emby Theatre. It's horrible, and not deinterlacing properly at all. Lots of jaggies. Don't seem to have the same problems via the browser / HTML5. How do I turn on deinterlacing in the Emby Theatre client? 

Edited by Tezza4x4
Link to comment
Share on other sites

First thing I would do is to hide channels that you don't want. In your web browser type my.hdhomerun.com and click on hdhomerun connect and then click channel lineup and click on the star next to the channel until channel gets a red cross. Then run the guide update. I have hidden all the sd channels that are now broadcast in hd plus all the other shopping channels that are waste of space. I have 17 channels in the guide and I think there are double that available.

 

I have them sorted how I like it in sort tag I just have 1 for 7, 2 for 7Two and so on

 

 

In video settings are you using MAdvr that one produces the best quality.

 

 

587473104cac2_Capture6.jpg

 

This is my channel line up ok there are 39 channels

 

5874746714109_Capture50.jpg

 

 

Edited by denz
  • Like 1
Link to comment
Share on other sites

linds1234

Hi Tezza,

 

>>Second problem is that I can map the duplicates with the same channels found in the xmltv guide, but it seems that it will only actually display program info for the first channel mapped. the duplicates >>show no data.

 

I've encountered this one too. With Seven's "Summer of Tennis", they decided to change over 7Mate to SD, then have 7HD mirror the schedule of 7 SD instead of 7mate. When I try adding 7HD and 7 SD to the guide (both mapped to the channel ID of 7 SD), the 2nd channel added is blanked out. This is using the XML feed from freepg.tv

 

I do the same channel hiding from the Homerun level that denz does (hello fellow Perthy!)

 

I don't use Emby Theatre so can't comment on that front unfortunately.

  • Like 1
Link to comment
Share on other sites

I am planning on completely redesigning the live tv/gude data setup experience to resolve all of these shortcomings.

 

In the meantime you may need to remove mappings manually from the live tv config file.

/programdata/config/livetv.xml

Just make sure to shut down the server before doing so. thanks.

  • Like 1
Link to comment
Share on other sites

maegibbons

 

>>Second problem is that I can map the duplicates with the same channels found in the xmltv guide, but it seems that it will only actually display program info for the first channel mapped. the duplicates >>show no data.
 
 
I've Also seen this with Duplicate  Channels since I have both HDHomerun and IPTV Tuners.  Duplicate channels need to Populate too.
 
Glad to know this is going to be looked at
 
Krs
 
Mark
Edited by maegibbons
Link to comment
Share on other sites

The entire setup process will be, definitely. For now you will just have to remove them from the config file. Thanks.

Link to comment
Share on other sites

Tezza4x4

Thanks for the replies guys. Good to know this is up for a makeover. For now, I have "cleaned up" the channel list by removing the "duds" on HDHomeRun as suggested by denz. That's 90% of the issue. I still can't get the sort tag to work properly though. Haven't marked any channels as favourites to avoid them going to the top of the list and numbered them 01 through 30, but the order I get is all messed up. This should have all the channel 7 channels first (7 Brisbane and 7 HD are 01 and 02, and 7 TWO is 03), then 9 then 10, then ABC then SBS. Instead I get:

 

58771b88d8680_Capture.jpg

 

 

 

 

Also, would like to know how to get Emby Theatre to deinterlace the stream. 

Edited by Tezza4x4
Link to comment
Share on other sites

Tezza4x4

Ok, well there's a problem with the detection then, because I've got jaggies everywhere.in the Emby Theatre Windows client. Browser is fine.

 

58776b480850e_Capture.jpg

Edited by Tezza4x4
Link to comment
Share on other sites

maegibbons

 

>>Second problem is that I can map the duplicates with the same channels found in the xmltv guide, but it seems that it will only actually display program info for the first channel mapped. the duplicates >>show no data.
 
 
I've Also seen this with Duplicate  Channels since I have both HDHomerun and IPTV Tuners.  Duplicate channels need to Populate too.
 
Glad to know this is going to be looked at
 
Krs
 
Mark

 

 

@@Luke

 

I know you are going to rewrite the whole TV Guide and m3u and tuners stuff.

 

In the meantime is there any quick fix you could do to resolve the duplicate channels issue?

 

To restate it - in manual mapping I would like to map two m3u streams to the SAME Schedules Direct channel guide info.

 

The problem is if you do this now only one channel in the the guide is populated, any other channels have a blank line.

 

This is so that you can have an SD and HD stream share the same guide data.  Allowing you to either record or watch native SD or HD.

 

Any chance of a quick fix on that ? Pretty please?

 

KR's

 

Mark

Link to comment
Share on other sites

maegibbons

Blank line - No program details whatsoever for that channel.

 

Example is channel 22 in Tezza4x4's channel guide picture 5 posts up

 

Krs

 

Mark

Link to comment
Share on other sites

Yeah, I have the same issue.. One channel out of my entire lineup is blank and will not tune, spinning circle.

This must be server related since the channel fails on Android, Theater and Web.

Link to comment
Share on other sites

lifespeed

Any news on the deinterlace issue? Any way to force deinterlace on?

Turn on MadVR as the video renderer in video settings in Emby Theater.  Apparently this does require some CPU power.

  • Like 1
Link to comment
Share on other sites

lifespeed

Can't get MadVR to work reliably. Crashes all the time. EVR+ seems to be a bit better.

 

That is strange, I run MadVR on 4 different PCs and laptops.  No crashes, although sometimes it causes audio sync issues.  Do you have an old PC or OS?

Link to comment
Share on other sites

Tezza4x4

No, all pretty modern. Less than 2 years old.  Windows 10, AMD FX8350 4ghz CPU. Will give it a try on some different systems and see how it goes. 

Link to comment
Share on other sites

Tezza4x4

OK, looks like it's more stable on a different platform. Still windows 10, but a laptop this time. MadVR is deinterlacing well on this machine, but was struggling with the HD channels. Lots of frame drops. Interestingly, CPU was around 20% for both SD and HD channels, so figured it had to be GPU related. Running Intel HD3000 and ATI 6700M adaptors. Switched them both to high performance and problem solved. Silky smooth HD. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...