Jump to content


Photo

H/W Transcoding on Evansport (DS415play/DS214play) Machines

Synology Evansport Hardware Transcoding

  • Please log in to reply
123 replies to this topic

#101 wzzly OFFLINE  

wzzly

    Newbie

  • Members
  • 5 posts
  • Local time: 09:38 PM

Posted 01 March 2019 - 03:29 AM

Is it possible that the official synologyy media server package installed this version? I installed it after emby server. Because I thought it was maybe needed for HW transcoding.

#102 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142318 posts
  • Local time: 02:38 PM

Posted 01 March 2019 - 03:30 AM

OK can you undo the hack? Emby ships it's own ffmpeg. Thanks.



#103 wzzly OFFLINE  

wzzly

    Newbie

  • Members
  • 5 posts
  • Local time: 09:38 PM

Posted 01 March 2019 - 03:36 AM

How because in the first post it says I need to do the hack to get HW transcoding on my ds214play...?

#104 solabc16 OFFLINE  

solabc16

    Advanced Member

  • ForumMod
  • 1974 posts
  • Local time: 07:38 PM

Posted 05 March 2019 - 06:53 AM

Hello @ wzzly

 

The h/w transcoding available on 'evansport' based Synology systems, is essentially proprietary. The FFmpeg changes needed to support the transcoding h/w available did not find their way back into the open source project.

 

I've discussed this elsewhere, for example : https://emby.media/c...hines/?p=443715

 

So this 'workaround' / 'hack' was developed in response to user demand, as you'll see through the evolution of this thread amongst others.

 

It's certainly not clean and there are probably steps we could take to improve it, but it really is a 'best efforts'.

 

Essentially what the instructions mentioned here do, is allow the version of FFmpeg being used by Emby Server to be switched on the fly, so if you have content that can take advantage of the h/w transcoding capabilities offered by the 'evansport' based systems you can try it out and see if it works for you.

 

From Emby Server's perspective, the platform does not provide h/w transcoding support through any of the typical interfaces, which on Synology means the VA-API.

 

Best

- James



#105 jacs OFFLINE  

jacs

    Newbie

  • Members
  • 6 posts
  • Local time: 08:38 PM

Posted 03 June 2019 - 09:47 AM

Hi, I have installed Emby Server onto my Synology DS214play to try out your hardware transcoding, and have two questions please:

 

Does this require a Emby Premiere License to work?

 

Does DTS sound playback with this?

 

Thank you.



#106 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142318 posts
  • Local time: 02:38 PM

Posted 03 June 2019 - 11:34 AM

Hi, I have installed Emby Server onto my Synology DS214play to try out your hardware transcoding, and have two questions please:
 
Does this require a Emby Premiere License to work?
 
Does DTS sound playback with this?
 
Thank you.


Hi, for hardware transcoding yes, and yes, dts sound is supported.
  • jacs likes this

#107 jacs OFFLINE  

jacs

    Newbie

  • Members
  • 6 posts
  • Local time: 08:38 PM

Posted 03 June 2019 - 01:25 PM

Hi, for hardware transcoding yes, and yes, dts sound is supported.

 

Hi again and thanks for your reply,

 

I have been trying it out without a Premier License and DTS is not playing back unless I disable the H/W transcoding, is that supposed to happen?



#108 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142318 posts
  • Local time: 02:38 PM

Posted 03 June 2019 - 01:34 PM

Hi again and thanks for your reply,

 

I have been trying it out without a Premier License and DTS is not playing back unless I disable the H/W transcoding, is that supposed to happen?

 

No, let's look at an example. Please see how to report a media playback issue. thanks !.



#109 jacs OFFLINE  

jacs

    Newbie

  • Members
  • 6 posts
  • Local time: 08:38 PM

Posted 04 June 2019 - 08:46 AM

Hi, I am having no problems playing back my music files, some of my films play back with sound (aac files) but none of my DTS & some AC3 films will playback with sound, the picture quality is perfect.

 

Everything played back perfectly before doing the H/W Transcoding

 

I am including the ffmpeg-remux log...I hope that is correct?

 

Attached File  ffmpeg remux log.rtf   17.28KB   7 downloads

 

 



#110 jacs OFFLINE  

jacs

    Newbie

  • Members
  • 6 posts
  • Local time: 08:38 PM

Posted 11 June 2019 - 07:16 AM

Nothing from anybody, so I am assuming it is a no go on my Synology DS214Play?



#111 sonny_life OFFLINE  

sonny_life

    Member

  • Members
  • 25 posts
  • Local time: 10:38 PM

Posted 11 June 2019 - 11:48 AM

Nothing from anybody, so I am assuming it is a no go on my Synology DS214Play?

As far as I remember there is no DTS sound with emby and H/W transcoding enabled.



#112 patje57 OFFLINE  

patje57

    Advanced Member

  • Members
  • 31 posts
  • Local time: 08:38 PM
  • LocationBelgium

Posted 11 June 2019 - 12:33 PM

Nothing from anybody, so I am assuming it is a no go on my Synology DS214Play?

 

Didn't get the H/W transcoding workaround working with DTS sound on DS415play either. So indeed a no go on DS214play / DS415play. All other formats are working well with the H/W transcoding workaround thou.

There may other work arounds avaible, i stopped googling as DTS isn't really an issue for me. I'm good with this solution.



#113 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142318 posts
  • Local time: 02:38 PM

Posted 11 June 2019 - 12:36 PM

As far as I remember there is no DTS sound with emby and H/W transcoding enabled.

 

This isn't true, that is mis-information, and that log isn't using hardware acceleration anyway so even then it would be inapplicable.



#114 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142318 posts
  • Local time: 02:38 PM

Posted 11 June 2019 - 12:36 PM

Hi, I am having no problems playing back my music files, some of my films play back with sound (aac files) but none of my DTS & some AC3 films will playback with sound, the picture quality is perfect.

 

Everything played back perfectly before doing the H/W Transcoding

 

I am including the ffmpeg-remux log...I hope that is correct?

 

attachicon.gifffmpeg remux log.rtf

 

What Emby app are you playing from here?



#115 sonny_life OFFLINE  

sonny_life

    Member

  • Members
  • 25 posts
  • Local time: 10:38 PM

Posted 11 June 2019 - 12:54 PM

This isn't true, that is mis-information, and that log isn't using hardware acceleration anyway so even then it would be inapplicable.

Sorry to disappoint you, but I already reported DTS playback issues on page 2 in this thread. DTS sound never worked with my DS214play in any of the versions that I tried.



#116 jacs OFFLINE  

jacs

    Newbie

  • Members
  • 6 posts
  • Local time: 08:38 PM

Posted 12 June 2019 - 03:51 AM

Hi, I have Ember Server 4.1.1.0-1 on my Synology DS214play and hear no sound when playing back files on either my web browser (Safari & Chrome Emby mobile 4.1.1.0) or on my Apple TV4K.

 

As I wrote earlier, no problems before doing the H/W transcoding workaround.



#117 jacs OFFLINE  

jacs

    Newbie

  • Members
  • 6 posts
  • Local time: 08:38 PM

Posted 13 June 2019 - 05:15 AM

Don't worry about answering my questions anymore as I am deleting it from my server, thanks to those who tried to help.



#118 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142318 posts
  • Local time: 02:38 PM

Posted 13 June 2019 - 12:55 PM

I would suggest trying again with the next release as there is another round of hardware transcoding improvements. Thanks.


  • jacs likes this

#119 patje57 OFFLINE  

patje57

    Advanced Member

  • Members
  • 31 posts
  • Local time: 08:38 PM
  • LocationBelgium

Posted 14 June 2019 - 04:58 PM

I would suggest trying again with the next release as there is another round of hardware transcoding improvements. Thanks.

 

Luke, are you saying you're considering enabling standard H/W transcoding on Evansport?

At least this is how i tend to understand your answer.

I've always understood neither Emby nor the others have that on their list, I believe due to the processor not supporting VAAPI



#120 jmassaro87 OFFLINE  

jmassaro87

    Advanced Member

  • Members
  • 121 posts
  • Local time: 11:38 AM

Posted 25 November 2019 - 02:16 PM

Is this still necessary? Or are we to a  point where it is built in to the SW package? Just got my DS418play up and running.







Also tagged with one or more of these keywords: Synology, Evansport, Hardware Transcoding

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users