Jump to content


Photo

Emby Theater for Linux


  • Please log in to reply
618 replies to this topic

#581 laufferb OFFLINE  

laufferb

    Newbie

  • Members
  • 7 posts
  • Local time: 07:59 PM

Posted 30 April 2019 - 05:06 PM

I guess i'm not quite following. Are you referring to the clock in the upper right?

5cc8b8c88eaf3_8.jpg



#582 echoxxzz OFFLINE  

echoxxzz

    Advanced Member

  • Members
  • 121 posts
  • Local time: 01:59 PM
  • LocationOntario, Canada

Posted 02 May 2019 - 08:15 AM

I tried using the 3.0.8 deb package and I get the same results. I can hear the audio but continue to only see a black screen. 

 

Did a clean install of Xubuntu 18.04.2 and now it works. The black screen when the OSD is open is tolerable and I know a fix will be addressed in the future. Just glad to be off Windows O/S. Great work Luke!!!!



#583 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131537 posts
  • Local time: 01:59 PM

Posted 02 May 2019 - 02:02 PM

Thanks for the feedback !



#584 laufferb OFFLINE  

laufferb

    Newbie

  • Members
  • 7 posts
  • Local time: 07:59 PM

Posted 04 May 2019 - 09:32 AM

Can I change the OSD display time?



#585 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131537 posts
  • Local time: 01:59 PM

Posted 04 May 2019 - 01:38 PM

Can I change the OSD display time?


Not currently, no.

#586 Pilothobs OFFLINE  

Pilothobs

    Member

  • Members
  • 21 posts

Posted 05 May 2019 - 12:59 PM

Thanks for the feedback !

 

Hey Luke

 

I did an install of 3.08 on a RPI 3B+ and everything seems to work really well. I did notice that once the screen saver stops (I like the pics of movies and shows with the name) and it goes to sleep I can't wake it with the TV remote using CEC. I can however wake it using a connected 2.4ghz remote on USB.

 

Hobs



#587 R40 OFFLINE  

R40

    Newbie

  • Members
  • 7 posts
  • Local time: 07:59 PM

Posted 07 May 2019 - 01:15 PM

Thank for all your work  :D

 

It´s working - but not when i use it headless

 

I want to use it for music only, only sound not video.

 

Do I need to change anything for this?



#588 EODCrafter OFFLINE  

EODCrafter

    Advanced Member

  • Members
  • 708 posts
  • Local time: 12:59 PM
  • LocationSouthEastern USA

Posted 08 May 2019 - 06:03 AM

Thank for all your work  :D

 

It´s working - but not when i use it headless

 

I want to use it for music only, only sound not video.

 

Do I need to change anything for this?

Bit of an overkill.....Plenty of smaller Apps to Play Music in Linux.



#589 R40 OFFLINE  

R40

    Newbie

  • Members
  • 7 posts
  • Local time: 07:59 PM

Posted 08 May 2019 - 02:38 PM

perhaps - but i want to use Emby - is that okay

 

Do I need to change anything for this? please



#590 marcelhehle OFFLINE  

marcelhehle

    Member

  • Members
  • 13 posts
  • Local time: 07:59 PM

Posted 31 May 2019 - 07:36 AM

I tried using the 3.0.8 deb package and I get the same results. I can hear the audio but continue to only see a black screen. 

 

Same here. I see only a black screen.

 

I'm running Ubuntu 18.04.2 LTS



#591 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 333 posts
  • Local time: 12:59 PM

Posted 01 June 2019 - 01:36 PM

I've installed the Emby 3.06 .deb file on Ubuntu 18.04 and Emby Theatre starts but when I try a play video all I see is a black screen. If I hold the mouse button down over the black screen I can see the movie playing behind ET. I've added ontop=yes to my ~/.config/mpv/mpv.conf file and mpv still plays behind ET. Has anyone been to get this working?

 

I have this issue on Mint 19.1.  First time trying Theater on linux.

 

Is there a fix for this? adding the ontop to the mpv.conf did nothing for me either.

 

using 3.08


Edited by speedingcheetah, 01 June 2019 - 01:37 PM.


#592 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 333 posts
  • Local time: 12:59 PM

Posted 07 June 2019 - 01:02 AM

So.....no working Emby Theater on Linux? It is just a black screen...seems to be a issue no matter what distro I install it on.



#593 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131537 posts
  • Local time: 01:59 PM

Posted 07 June 2019 - 11:53 PM

So.....no working Emby Theater on Linux? It is just a black screen...seems to be a issue no matter what distro I install it on.

 

Currently this will happen when the OSD is being shown.



#594 speedingcheetah OFFLINE  

speedingcheetah

    Advanced Member

  • Members
  • 333 posts
  • Local time: 12:59 PM

Posted 08 June 2019 - 01:09 AM

Currently this will happen when the OSD is being shown.

Black screen is constant for me... never shows video. No matter the MPV settings. unusable on multiple Linux distros.

 

Edit: Clarify. Ok. Local media files, the video show after the Emby OSD hides it self.

But for live tv, i will not get picture, and Emby will lock up or give the spinning circle, or playback error when i try to play most tv channels.

A few times it will give a static image of the tv channel program, but is just frozen.


Edited by speedingcheetah, 08 June 2019 - 01:21 AM.


#595 EODCrafter OFFLINE  

EODCrafter

    Advanced Member

  • Members
  • 708 posts
  • Local time: 12:59 PM
  • LocationSouthEastern USA

Posted 08 June 2019 - 05:19 AM

So.....no working Emby Theater on Linux? It is just a black screen...seems to be a issue no matter what distro I install it on.

Didn't I post a work-around on here? I'll try to find it real quick.

 

https://emby.media/c...-28#entry725333


Edited by EODCrafter, 08 June 2019 - 05:20 AM.


#596 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 110 posts
  • Local time: 06:59 PM

Posted 02 July 2019 - 12:20 PM

 

Raspberry Pi Image

 

 

https://github.com/M...r-rpi_3.0.8.zip

 

This is an image that will launch straight into Emby Theater. If there is no network connection then raspi-config is launched allowing users to connect to a network.

 

Or, you can also use the armhf image below with any debian based distro. After installing the Emby Theater .deb, please run the following:

rpi-update
dist-upgrade

 

Hi.

 

This image does not work with the RPi4.



#597 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131537 posts
  • Local time: 01:59 PM

Posted 02 July 2019 - 01:51 PM

Hi, what does "does not work" mean?



#598 Spotta OFFLINE  

Spotta

    Advanced Member

  • Members
  • 110 posts
  • Local time: 06:59 PM

Posted 02 July 2019 - 03:20 PM

Sorry, that was quite a crap error report! I was pushed for time.

 

It doesn't even boot, I believe the pi4 absolutely requires Buster so maybe it's time for an updated image?



#599 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131537 posts
  • Local time: 01:59 PM

Posted 02 July 2019 - 04:50 PM

Ok thanks for the info. We'll update the package to ensure it will work with RPI4. Stay tuned.



#600 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131537 posts
  • Local time: 01:59 PM

Posted 03 July 2019 - 03:16 PM

Hi,

 

@ellnic

I Agree a light-weight window manager like i3 is the way to go, though I prefer awesome, it is much more configurable .... (i.e you won't have any issues with bringing ET up full screen)

 

@Luke

Is there any plans to put this build into a container, like FlatPak? Seems it would be much easier to get across to a lot of platforms that way ..

I would suggest a minimal Archlinux build with Xorg/Awesome window manager, electron and the bare minimum dependencies to have it work ..

 

My 2c.

 

@ebike, we now have Emby Server for Flatpak available for testing:

https://emby.media/c...er-for-flatpak/

 

Please try it out and report your experience. Thanks !






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users