Jump to content


Photo

sqlite package error before update. CentOS

centos linux update sqlite

Best Answer xenu , 02 December 2016 - 11:46 AM

Glad to help.

I think I found the issue:

When I updated from "embymagick-6.9.5-9.1.x86_64" to "embymagick-6.9.6+6-3.1.x86_64" the old folder at "/usr/lib/emby-server/lib64/ImageMagick-6.9.5" didn't get deleted.
Now the emby startup script at "/usr/lib/emby-server/emby-server.sh" searches for the filter path here:

EMBY_LIBRARY_PATH=$(find /usr/lib/emby-server/ -maxdepth 1 -mindepth 1 -type d| grep -v bin | grep -v etc | grep -v -e "/\.")
MAGICK_CODER_FILTER_PATH_ENV="MAGICK_CODER_FILTER_PATH=$(find ${EMBY_LIBRARY_PATH} -type d -name "filters")"
Since the old folder is still present this results in:
/usr/lib/emby-server/lib64/ImageMagick-6.9.5/modules-Q8/filters
/usr/lib/emby-server/lib64/EmbyMagick-6.9.6/modules-Q8/filters
and picks the "wrong" folder.

Manually removing the old folder ("sudo rm -r /usr/lib/emby-server/lib64/ImageMagick-6.9.5/") and restarting emby-server solved the issue.

Edit: And thanks for all your work on emby :) Go to the full post


  • Please log in to reply
34 replies to this topic

#21 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 11:09 PM

Posted 02 December 2016 - 10:39 AM

The version of embymagick is wrong. The folder should be called embymagick not imagmagick. Can you remove all packages and delete /usr/lib/emby-server also check journalctl for the most recent logs instead or /var/lib/emby-server

Sent from my ONEPLUS A3000 using Tapatalk

#22 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 11:09 PM

Posted 02 December 2016 - 11:39 AM

Guys,

 

I also wanted to add my appreciation for you contributions to the project. I personally very thankful and grateful that both of you are giving your time and effort. I'm really sorry you have encountered these issues. If we can get them resolved, hopefully less users will experience similar issues. Emby wouldn't be as good of project if it wasn't for users like yourselves.


  • xenu likes this

#23 xenu OFFLINE  

xenu

    Advanced Member

  • Members
  • 36 posts
  • Local time: 07:09 AM

Posted 02 December 2016 - 11:46 AM   Best Answer

Glad to help.

I think I found the issue:

When I updated from "embymagick-6.9.5-9.1.x86_64" to "embymagick-6.9.6+6-3.1.x86_64" the old folder at "/usr/lib/emby-server/lib64/ImageMagick-6.9.5" didn't get deleted.
Now the emby startup script at "/usr/lib/emby-server/emby-server.sh" searches for the filter path here:
EMBY_LIBRARY_PATH=$(find /usr/lib/emby-server/ -maxdepth 1 -mindepth 1 -type d| grep -v bin | grep -v etc | grep -v -e "/\.")
MAGICK_CODER_FILTER_PATH_ENV="MAGICK_CODER_FILTER_PATH=$(find ${EMBY_LIBRARY_PATH} -type d -name "filters")"
Since the old folder is still present this results in:
/usr/lib/emby-server/lib64/ImageMagick-6.9.5/modules-Q8/filters
/usr/lib/emby-server/lib64/EmbyMagick-6.9.6/modules-Q8/filters
and picks the "wrong" folder.

Manually removing the old folder ("sudo rm -r /usr/lib/emby-server/lib64/ImageMagick-6.9.5/") and restarting emby-server solved the issue.

Edit: And thanks for all your work on emby :)

Edited by xenu, 02 December 2016 - 11:48 AM.

  • altramarine likes this

#24 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 11:09 PM

Posted 02 December 2016 - 12:01 PM

Glad to help.

I think I found the issue:

When I updated from "embymagick-6.9.5-9.1.x86_64" to "embymagick-6.9.6+6-3.1.x86_64" the old folder at "/usr/lib/emby-server/lib64/ImageMagick-6.9.5" didn't get deleted.
Now the emby startup script at "/usr/lib/emby-server/emby-server.sh" searches for the filter path here:

EMBY_LIBRARY_PATH=$(find /usr/lib/emby-server/ -maxdepth 1 -mindepth 1 -type d| grep -v bin | grep -v etc | grep -v -e "/\.")
MAGICK_CODER_FILTER_PATH_ENV="MAGICK_CODER_FILTER_PATH=$(find ${EMBY_LIBRARY_PATH} -type d -name "filters")"
Since the old folder is still present this results in:
/usr/lib/emby-server/lib64/ImageMagick-6.9.5/modules-Q8/filters
/usr/lib/emby-server/lib64/EmbyMagick-6.9.6/modules-Q8/filters
and picks the "wrong" folder.

Manually removing the old folder ("sudo rm -r /usr/lib/emby-server/lib64/ImageMagick-6.9.5/") and restarting emby-server solved the issue.

Edit: And thanks for all your work on emby :)

 

Yup I suspected as much. I have made some small minor changes to the packages for any user experiencing issues. If we can get this tested and worked out I will commit the changes to the main repo:

The repo with the fixes can be found on here:

https://software.ope...age=emby-server

 

Please temporarily disable the emby main repo.

 

Currently the fixes are building. Thank you again. Please report back with the results. This should also fix the need to having to uninstall emby before being able to upgrade.


Edited by hurricanehrndz, 02 December 2016 - 12:02 PM.

  • altramarine likes this

#25 altramarine OFFLINE  

altramarine

    Advanced Member

  • Members
  • 212 posts
  • Local time: 06:09 AM

Posted 02 December 2016 - 12:51 PM

Man, i feel like this isn't my couple of days. I should have read @xeno's last reply.

I went ahead and deleted emby-server related packages and the /usr/lib/emby-server directory.

I then reinstalled emby-server from repo and now /usr/lib/emby-server  is empty.

How badly did I butcher it?



#26 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 11:09 PM

Posted 02 December 2016 - 12:54 PM

Man, i feel like this isn't my couple of days. I should have read @xeno's last reply.

I went ahead and deleted emby-server related packages and the /usr/lib/emby-server directory.

I then reinstalled emby-server from repo and now /usr/lib/emby-server  is empty.

How badly did I butcher it?

Not badly at all. All personal configuration and settings are stored in `/var/lib/emby-server`, make a backup of that directory before proceeding further. If you reinstalled emby-server /usr/lib/emby-server should not be empty. 



#27 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 11:09 PM

Posted 02 December 2016 - 01:01 PM

Would you guys prefer that I merge the changes into the main repo? I would have rather had some testing to confirm that my changes would have fixed the issues before proceeding.



#28 altramarine OFFLINE  

altramarine

    Advanced Member

  • Members
  • 212 posts
  • Local time: 06:09 AM

Posted 02 December 2016 - 01:07 PM

Thanks @hurricanehrndz,

 

Well, i did indeed butcher it up big time. I deleted /var/lib/emby-server instead of /usr/lib/emby-server so ignore my previous post.

I have a backup of my configuration but I will need to re-install emby from scratch.

Thats the price I have to pay for doing things wile being tired heh.



#29 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146738 posts
  • Local time: 01:09 AM

Posted 02 December 2016 - 02:19 PM

Thank you for your patience and for helping us test these new package changes. We apologize for the instability but it is only temporary while the initial kinks are being worked out. You can read the full list of improvements that has been applied here:

 

https://emby.media/c...ackage-changes/

 

Thanks.


  • altramarine likes this

#30 hurricanehrndz OFFLINE  

hurricanehrndz

    Advanced Member

  • Developers
  • 1249 posts
  • Local time: 11:09 PM

Posted 03 December 2016 - 06:00 PM

All fixes have been merged. I hope this resolves the last of the minor issues with the packages.

Thank you so much for contributing back to the project your feedback and patience is what will make it better and better.

Edited by hurricanehrndz, 04 December 2016 - 01:57 AM.

  • altramarine and xenu like this

#31 altramarine OFFLINE  

altramarine

    Advanced Member

  • Members
  • 212 posts
  • Local time: 06:09 AM

Posted 03 December 2016 - 09:56 PM

Thanks guys, you rock!



#32 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146738 posts
  • Local time: 01:09 AM

Posted 03 December 2016 - 09:58 PM

Has this resolved your issue?

#33 altramarine OFFLINE  

altramarine

    Advanced Member

  • Members
  • 212 posts
  • Local time: 06:09 AM

Posted 04 December 2016 - 02:54 AM

Unfortunately, I cannot confirm how the merged changed would have worked with my existing install.

I ended up reinstalling emby from scratch in which case everything installed fine.

Prior to screwing my setup completely I too, same as @xeno, noticed the presence of old ImageMagick-6.9.5 folder along with the newer EmbyMagick-6.9.6 in /usr/lib/emby-server/lib64/.

After the new install, only EmbyMagick-6.9.6 is present, and emby is working well. Sorry I couldn't have been more help.

I sincerely thank you for your speedy response to this.


Edited by altramarine, 04 December 2016 - 02:59 AM.


#34 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 146738 posts
  • Local time: 01:09 AM

Posted 04 December 2016 - 03:06 AM

Thanks for confirming.



#35 xenu OFFLINE  

xenu

    Advanced Member

  • Members
  • 36 posts
  • Local time: 07:09 AM

Posted 04 December 2016 - 03:13 PM

Sorry @hurricanehrndz, I don't have a snapshot with the old version anymore and can't test your fix easily.







Also tagged with one or more of these keywords: centos, linux, update, sqlite

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users