Jump to content

Subtitle selection


danergo
 Share

Recommended Posts

Hello,

 

I'm using Emby Server (3.0.8500.0) for serving media onto my TV via DLNA.

However, subtitles are not handled correctly.

Please see this image shot of the media info (attached).

 

My questions:

1.) Why is the first subtitle (subrip) marked as default?

2.) Why is the first subtitle (subrip) marked as forced?

3.) I have set smart subtitle handling in my profile, and set the preferred language to Hungarian. I have the hungarian external subtitle file, but it's not forced. Why?

 

Result: first subtitle is played over DLNA which is english (forced). How can I override it to use my language preference (which is hun, set in profile settings) over DLNA?

 

Thank you.

 

 

post-65825-0-29805700-1478442558_thumb.png

Link to comment
Share on other sites

Hello,

 

I'm using Emby Server (3.0.8500.0) for serving media onto my TV via DLNA.

However, subtitles are not handled correctly.

Please see this image shot of the media info (attached).

 

My questions:

1.) Why is the first subtitle (subrip) marked as default?

2.) Why is the first subtitle (subrip) marked as forced?

3.) I have set smart subtitle handling in my profile, and set the preferred language to Hungarian. I have the hungarian external subtitle file, but it's not forced. Why?

 

Result: first subtitle is played over DLNA which is english (forced). How can I override it to use my language preference (which is hun, set in profile settings) over DLNA?

 

Thank you.

post-65825-0-20650200-1478456826_thumb.png

Link to comment
Share on other sites

Happy2Play

All those option are set inside the mkv container for the internal subs.  So you would have to use a tool like mkvmerge to change those values if they are incorrect.  

 

581f7d0b77d04_mkvtool.jpg

Link to comment
Share on other sites

Hm, but there is no way to force the DLNA server to use the external srt if available and matches with my lang pref?

Can I somehow make the external subtitle to forced? In this case, Emby would chose the external one, because both are forced, but the external also matches my lang pref, right?

Link to comment
Share on other sites

The first subtitle is marked as default or forced because that's what ffprobe told us.

 

For the external subtitle, what is the file name?

Link to comment
Share on other sites

Happy2Play

@@Luke

 

Why would default and forced matter if language is set to Hungarian  for "Smart" subtitle option and there is only one Hungarian subtitle available?

Link to comment
Share on other sites

He asked why it's not marked as forced. Playback settings are separate from media info. If he had asked why they are not activated on playback, then that would be a different question.

Link to comment
Share on other sites

Happy2Play

Duplicate topics merged

Edited by Happy2Play
Link to comment
Share on other sites

I'd change the question to Happy2Play's recommendation.

If I have smart subtitle selection and lang pref set to Hungarian, and I have only one Hungarian subtitle, why is that not get selected for playback?

 

Filename is "Narcos - 2x01 - Free at Last.hun.srt".
 

Link to comment
Share on other sites

well i would suggest marking it based on what it actually is, then adjusting your playback settings.

Link to comment
Share on other sites

Happy2Play

So is there really any difference in "Smart" and "Default" subtitle mode if they both just look at default or forced flags?

Link to comment
Share on other sites

Happy2Play

Right, "Subtitles matching the language preference will be loaded when the audio is in a foreign language."  This is the exact question danergo is asking.

 

A English audio tracked movie with embedded en subtitles and an external hu subtitle.  Language set to Hungarian but still plays en subtitles.  So does "Smart" not work in internal external subtitle environment?

Link to comment
Share on other sites

Happy2Play

Does it work renaming your external sub to "Narcos - 2x01 - Free at Last.hun.forced.srt" and performing another library scan to catch the changes?  If not you will probably have to change the internal subtitle flags.

Link to comment
Share on other sites

Happy2Play

The issue points to the first internal subtitle track default/forced from your screenshot.

Link to comment
Share on other sites

Yes, the first subtitle is both forced and default. However, its language is different, so Smart subtitle handler should recognize this, and chose my external one instead of this.

But this lead to a moral argument, because forced might be harder than language preferences. This also makes sense.

 

So, I tried setting it to forced, and works. Gets selected on the TV. Also, there is a possibility to change between external and internal subtitles, but in this case its default is the external one.

 

I can live with this now, but it might worth a bit discussion whether smart subtitle handler should prioritize based on mainly the language preferences or not.

 

 

Thanks, guys!

  • Like 1
Link to comment
Share on other sites

Happy2Play

Personally forced should only apply to same language preference.  Do to foreign subs are already there for everything.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...