Jump to content

New sync issue


meddaugh
 Share

Go to solution Solved by meddaugh,

Recommended Posts

Seems like syncing got a little messed up on the last update, v 2.8.15.  It starts syncing and keeps restarting, after running all night it never fully synced hardly anything.  It seems extremely slow now.  I've attached the Android logs, I attached the latest server log, I'm hoping you might have this noticed and sorted out already.

 

Thanks.

 

---Eric

 

8eddcc3f-6a9f-4776-b47f-0d281f827f07.log

9eb62d98-b29c-4435-8231-81b3cbf96048.log

10e4cb94-9a48-45d4-8c4f-3356d78dcde5.log

b84c9e0b-80ed-457a-9289-b5fdeeb031b5.log

server-63613573941.txt

Link to comment
Share on other sites

I looked at the largest android log and that seems to indicate that it was successful. If/when it happens again, please try to find the precise log from the timeframe. thanks !

Link to comment
Share on other sites

It was not at all successful, the app deleted it and restarted it.  The server side still show it ready to transfer, so not sure  why.

 

Attached is the server log from that interval..... seems like it had some issues during that 4:16-4:36 time, hope it helps....

 

 

server-63613555199.txt

Link to comment
Share on other sites

Attached is the current server log.  It's been trying to sync a file since 5:17am.  I do not have access to the Android device currently, I can get the logs later tonight.  The sync job in the notification area kept refreshing at 0:00, never going up.

server-63613573941.txt

Link to comment
Share on other sites

Well the server doesn't try to sync a file, it just tells the app that it's ready for download and the app downloads it. i do see some download failures in the log so it looks like the app is losing it's connection to the server.

Link to comment
Share on other sites

This morning I rebooted everything, android tablet, server, all of it.  I left it for the day to sync up.  It usually has no issues syncing overnight anything that is automatically updated, it just this morning nothing was synced properly.  I'll get local android logs when I get home to attach.

Link to comment
Share on other sites

Attached is the log, it was still trying to sync...nothing new in the log since 6:36am.... not sure why it's failing...

 

 

Link to comment
Share on other sites

2.7.98 worked perfectly to sync 6-7 files about 1g each.  Very quickly....  I'll try 2.8.15 again at some point.  I'm not sure if this is related, but in the logs did not work there was this error below, the logs that worked did not have it (attached):

 

04:16:18.531 [main] INFO  App - undefined: Line 0 : Uncaught (in promise) SecurityError: Failed to register a ServiceWorker: The URL  protocol of the current origin ('file://') is not supported.
 

d63546be-e347-4add-825a-db5796067578.log

Link to comment
Share on other sites

There aren't really any sync differences between those two versions so it's probably like i said earlier. your test against 2.7.x came at a time when there wasn't any network disruption. In any event, even when this happens, the sync process will try again at the next scheduled sync, it will just end up taking a little longer.

Link to comment
Share on other sites

Ok.....it's back to the 2.8.15 version. I'll see what happens next time, this has been working at my house just fine, then all of a sudden it stopped, even over 12 hours it could not get more then 36Mg synced.  I'll see if the next job works.  The 2.7 version had ~4-6g synced in less than 1 hour, no other changes.   I'll let you know the next sync when it tries to do some things. I hope it works.

 

Thanks.

 

---Eric

Link to comment
Share on other sites

I just updated to Emby Premiere and tried to Sync for the first time.  It goes to 50% and just sits there on one of my user's phones. 

Link to comment
Share on other sites

I just updated to Emby Premiere and tried to Sync for the first time.  It goes to 50% and just sits there on one of my user's phones. 

 

Hi, it registers an hourly sync process with the device. In most cases the content will start downloading immediately, but in some cases it may wait for the next scheduled sync. If the issue persists, ask them to customize the sync location under app settings -> sync.

Link to comment
Share on other sites

  • Solution

Synced went again, v 2.8.16 now, all synced ok.  There appears to be a small issue, but easy to get around.  If I use a file explorer and list the directory, the sync job appears to "hang", it must be killed and restarted.  I did it to see the file size growing, which I could see the job syncing, but when I listed it, it got stuck.  If I just ignored it and let it sync, it went ok.  One other thing was I had only 2.4g turned on (don't remember why), when I put it back to auto, it connected at 5gh (faster) and the sync jobs completed much quicker.  Issue solved...was weird to begin with that even over 12 hours it wouldn't sync more then 97mg.   Thanks for helping and reading...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...