Jump to content

Emby server crach since last update


Kujuta
 Share

Go to solution Solved by solabc16,

Recommended Posts

Hi all,

 

I have a problem with my emby server since the last update which I do last night.

When the emby server is launching, it start to be "try to starting" to "stop" with some errors on the start-stop-status log like this :




[2016-10-15 17:02:57 UTC] Script called with action [status]...
[2016-10-15 17:02:57 UTC] >> PID file [/var/packages/EmbyServer/target/var/embysvr.pid] does not exist.
[2016-10-15 17:02:57 UTC] >> Emby Server is not running.
[2016-10-15 17:02:57 UTC] >> Exit status is [3].
[2016-10-15 17:02:57 UTC] Script called with action [start]...
[2016-10-15 17:02:57 UTC] >> PID file [/var/packages/EmbyServer/target/var/embysvr.pid] does not exist.
[2016-10-15 17:02:57 UTC] >> Emby Server is not running.
[2016-10-15 17:02:57 UTC] >> Starting Emby Server.
[2016-10-15 17:02:57 UTC] >> Launch command [env PATH=/var/packages/EmbyServer/target/mono/bin:/var/packages/EmbyServer/target/ffmpeg/bin:/var/packages/EmbyServer/target/imagemagick/bin:/var/packages/EmbyServer/target/sqlite/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin LD_LIBRARY_PATH=/var/packages/EmbyServer/target/ffmpeg/lib /var/packages/EmbyServer/target/mono/bin/mono /var/packages/EmbyServer/target/server/MediaBrowser.Server.Mono.exe -package=\"synology\" -programdata /var/packages/EmbyServer/target/var -ffmpeg /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg -ffprobe /var/packages/EmbyServer/target/ffmpeg/bin/ffprobe 1>> /var/packages/EmbyServer/target/var/logs/embysvr.stdout 2>> /var/packages/EmbyServer/target/var/logs/embysvr.stderr & echo $! > /var/packages/EmbyServer/target/var/embysvr.pid;].
[2016-10-15 17:02:57 UTC] >> Waiting for daemon status to become [0].
[2016-10-15 17:02:57 UTC] >> Checking status [20/20].
[2016-10-15 17:02:57 UTC] >> Process [10714] exists.
[2016-10-15 17:02:57 UTC] >> Emby Server is running.
[2016-10-15 17:03:05 UTC] >> Emby Server started successfully.
[2016-10-15 17:03:05 UTC] >> Exit status is [0].
[2016-10-15 17:03:09 UTC] Script called with action [status]...
[2016-10-15 17:03:09 UTC] >> Process [10714] exists.
[2016-10-15 17:03:09 UTC] >> Emby Server is running.
[2016-10-15 17:03:09 UTC] >> Exit status is [0].
[2016-10-15 17:03:10 UTC] Script called with action [status]...
[2016-10-15 17:03:10 UTC] >> Process [10714] exists.
[2016-10-15 17:03:10 UTC] >> Emby Server is running.
[2016-10-15 17:03:10 UTC] >> Exit status is [0].
[2016-10-15 17:03:15 UTC] Script called with action [status]...
[2016-10-15 17:03:15 UTC] >> Process [10714] exists.
[2016-10-15 17:03:15 UTC] >> Emby Server is running.
[2016-10-15 17:03:15 UTC] >> Exit status is [0].
[2016-10-15 17:03:15 UTC] Script called with action [status]...
[2016-10-15 17:03:15 UTC] >> Process [10714] exists.
[2016-10-15 17:03:15 UTC] >> Emby Server is running.
[2016-10-15 17:03:15 UTC] >> Exit status is [0].
[2016-10-15 17:03:32 UTC] Script called with action [status]...
[2016-10-15 17:03:32 UTC] >> Process [10714] exists.
[2016-10-15 17:03:32 UTC] >> Emby Server is running.
[2016-10-15 17:03:32 UTC] >> Exit status is [0].
[2016-10-15 17:03:50 UTC] Script called with action [stop]...
[2016-10-15 17:03:50 UTC] >> PID file [/var/packages/EmbyServer/target/var/embysvr.pid] does not exist.
[2016-10-15 17:03:50 UTC] >> Emby Server is not running.
[2016-10-15 17:03:50 UTC] >> Stop request ignored, package is stopped!
[2016-10-15 17:03:50 UTC] >> Exit status is [0].
[2016-10-15 17:03:49 UTC] Script called with action [status]...
[2016-10-15 17:03:49 UTC] >> Process [10714] does not exist.
[2016-10-15 17:03:49 UTC] >> Removed PID file [/var/packages/EmbyServer/target/var/embysvr.pid].
[2016-10-15 17:03:50 UTC] >> Ensuring package status is correct in DSM.
[2016-10-15 17:03:50 UTC] >> Emby Server is not running.
[2016-10-15 17:03:50 UTC] >> Exit status is [1].
[2016-10-15 17:04:00 UTC] Script called with action [log]...
[2016-10-15 17:04:00 UTC] >> Returning log file location [/var/packages/EmbyServer/target/var/logs/start-stop-status_20161015.log].
[2016-10-15 17:04:00 UTC] >> Exit status is [0].
[2016-10-15 17:04:06 UTC] Script called with action [status]...
[2016-10-15 17:04:06 UTC] >> PID file [/var/packages/EmbyServer/target/var/embysvr.pid] does not exist.
[2016-10-15 17:04:06 UTC] >> Emby Server is not running.
[2016-10-15 17:04:06 UTC] >> Exit status is [3].
[2016-10-15 17:04:15 UTC] Script called with action [status]...
[2016-10-15 17:04:15 UTC] >> PID file [/var/packages/EmbyServer/target/var/embysvr.pid] does not exist.
[2016-10-15 17:04:15 UTC] >> Emby Server is not running.
[2016-10-15 17:04:15 UTC] >> Exit status is [3].


 

I'm running a RunDiag and SendDiag and I can see a Failed operation on "Listening files open for user".

So i Think I have a permission errors but where ? why ? I don't change anything, I just launch the update.

 

 

Thanks to help me without lost all my config :'( 



Upload completed successfully, please include this filename with your ticket...
sendlogs_Ikari_DS_synology_armada38x_ds216j_20161015T171704UTC.tgz


 

Regards and sorry for my bad english, it's not ma natural language ;)

Kujuta

Link to comment
Share on other sites

solabc16

Hello @@Kujuta

 

Sorry to hear you are having issues. Do not worry about losing your configuration, it will still be there.

 

Well done on running the diagnostics and send logs utilities, that's what I need.

 

I'll get back to you as soon as possible.

 

Best

- James

Link to comment
Share on other sites

solabc16

Hello Again

 

Do not worry about this, the error is simply because Emby Server is not running, so it can't list the open files for the process.

[2016-10-15 17:06:07 UTC] Listing open files for user [embysvr]:
[2016-10-15 17:06:07 UTC]   Command failed [ES=1]

Here's the real problem:-

2016-10-15 11:21:49.5959 Info HttpServer: Adding HttpListener prefix https://+:518920/

Which produces the following on startup:-

One or more errors occurred.
System.AggregateException
  at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, Int32 millisecondsTimeout, CancellationToken cancellationToken) <0x72086190 + 0x004f4> in <filename unknown>:0
  at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks, Int32 millisecondsTimeout) <0x72086138 + 0x00027> in <filename unknown>:0
  at System.Threading.Tasks.Task.WaitAll (System.Threading.Tasks.Task[] tasks) <0x720860f0 + 0x00017> in <filename unknown>:0
  at MediaBrowser.Server.Mono.MainClass.RunApplication (MediaBrowser.Server.Implementations.ServerApplicationPaths appPaths, ILogManager logManager, MediaBrowser.Server.Startup.Common.StartupOptions options) <0x73f1c488 + 0x002ff> in <filename unknown>:0
  at MediaBrowser.Server.Mono.MainClass.Main (System.String[] args) <0x769918c8 + 0x0017b> in <filename unknown>:0
InnerException: System.ArgumentException
Invalid port.
  at SocketHttpListener.Net.ListenerPrefix.CheckUri (System.String uri) <0x72085748 + 0x00138> in <filename unknown>:0
  at SocketHttpListener.Net.HttpListenerPrefixCollection.Add (System.String uriPrefix) <0x72085650 + 0x00027> in <filename unknown>:0
  at MediaBrowser.Server.Implementations.HttpServer.SocketSharp.WebSocketSharpListener.Start (IEnumerable`1 urlPrefixes) <0x72088000 + 0x00147> in <filename unknown>:0
  at MediaBrowser.Server.Implementations.HttpServer.HttpListenerHost.StartListener () <0x720a75a8 + 0x00297> in <filename unknown>:0
  at MediaBrowser.Server.Implementations.HttpServer.HttpListenerHost.Start (System.String listeningAtUrlBase) <0x720a7500 + 0x00017> in <filename unknown>:0
  at MediaBrowser.Server.Implementations.HttpServer.HttpListenerHost.StartServer (IEnumerable`1 urlPrefixes, System.String certificatePath) <0x720a6e08 + 0x00073> in <filename unknown>:0
  at MediaBrowser.Server.Implementations.ServerManager.ServerManager.ReloadHttpServer (IEnumerable`1 urlPrefixes, System.String certificatePath) <0x720a6688 + 0x000db> in <filename unknown>:0

Were you trying to change your HTTPS port number?

 

- James

Edited by solabc16
Link to comment
Share on other sites

  • Solution
solabc16

So here's how to resolve the error...

- SSH to your Synology NAS and login as 'admin'.

- Run: sudo vi /var/packages/EmbyServer/target/var/config/system.xml

- Edit the PublicHttpsPort and HttpsPortNumber elements to make them valid.

- Currently configured as:-

  <PublicPort>18096</PublicPort>
  <PublicHttpsPort>518919</PublicHttpsPort>
  <HttpServerPortNumber>18096</HttpServerPortNumber>
  <HttpsPortNumber>518920</HttpsPortNumber>

- Save the file, quit VI and exit the SSH session.

- Start Emby Server from Package Center.

Let us know how you get on....

 

- James

Link to comment
Share on other sites

Hi,

 

Thanks for your fast return :)

 

Ok, I doesn't knew if the failed listening files reflecting normal acces permission or just files which are opened by emby server when it is running.

 

Waoh, I don't know why the https port is like that ?!?

Where the first "5"  is incomming from ? Have you got a idea ?

 

Thanks to have seen this error et I get back soon, this night I try, in order to say you if the problem is solved :)

 

Thanks & regards

Kujuta

Link to comment
Share on other sites

Hi,

 

Thanks you very much !

My Emby server is now running with the resolve that you done :)

 

Happy that this probleme was just https port number failed, but I don't know how and why this port number have been changed.

 

Thank solabc16  :)

 

Kujuta

Link to comment
Share on other sites

solabc16

You're welcome @@Kujuta, it must have been inadvertently edited at some point prior to the server being restarted.

 

Glad you're up and running again and no real harm done.

 

@@Luke - can we get some input validation put in place on these configuration fields?

 

- James

Edited by solabc16
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...