Jump to content


Photo

Cannot connect on LAN, Windows 2012 Server

port connectivity windows firewall TCP Windows 2012 Server

  • Please log in to reply
4 replies to this topic

#1 Tahlor OFFLINE  

Tahlor

    Newbie

  • Members
  • 3 posts

Posted 10 October 2016 - 03:10 PM

I'm unable to connect to the server from other computers on my LAN, only on the local machine (e.g. 127.0.0.1:8096).

 

Some things I've tried:

  • Added rules to Windows Firewall
  • Disabled Windows Firewall (turned it off within Windows Firewall; separately disabled the service)
  • Used other ports

There is no other firewall software on the server that I'm aware of. For my sanity, I installed Emby on a Windows 10 machine and it worked flawlessly the first time. Is there anything else I could be missing?

 

Netstat results below:

 

  Proto  Local                   Foreign              State                    PID

  TCP    0.0.0.0:8096       0.0.0.0:0            LISTENING          11944 (Emby)
  TCP    [::]:8096              [::]:0                   LISTENING          11944
 
When I'm connected on the local machine, I also get:
 
  TCP    [::1]:8096            [::1]:51528         ESTABLISHED     11944
  TCP    [::1]:51528          [::1]:8096           ESTABLISHED      9304 (Chrome)

Edited by Tahlor, 10 October 2016 - 03:32 PM.


#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 16056 posts
  • Local time: 06:10 AM
  • LocationWashington State

Posted 10 October 2016 - 03:31 PM

Did you restart the machine after setting the firewall?



#3 PenkethBoy OFFLINE  

PenkethBoy

    Advanced Member

  • Members
  • 3408 posts
  • Local time: 02:10 PM
  • LocationWarrington,UK

Posted 10 October 2016 - 04:18 PM

can you browse to the server from another machine?

 

either \\ip or \\servername

 

can you see the server in explorer on the win 10 machine

 

my initial guess would be you have not enabled "file sharing" on the server so its not discoverable - as its a server the machine is much more locked down than Win 10 by default



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139743 posts
  • Local time: 09:10 AM

Posted 10 October 2016 - 04:19 PM

Check windows firewall and make sure there are no rules blocking mediabrowser.serverapplication.exe



#5 Tahlor OFFLINE  

Tahlor

    Newbie

  • Members
  • 3 posts

Posted 10 October 2016 - 05:33 PM

Thanks for the responses. I ended up trying another new port and it worked. I still don't understand why 8096 didn't work, but I'm at peace with it and can move on, it's pretty awesome so far.







Also tagged with one or more of these keywords: port, connectivity, windows firewall, TCP, Windows 2012 Server

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users