Jump to content

New Plugin: Emby.Notification.Slack


ackbarr
 Share

Recommended Posts

Hi, 

 

Can you add the possibility to edit the notification message?

 

I would like to add an image like I do in omby when I post a notification on my slack channel : 

 

Hey

is this format possible with Omby?

Link to comment
Share on other sites

  • 3 months later...

When an update is out, I receive a notification on Slack, after a reboot the notification is spam every minute into my channel.

 

5cb0dff7693bd_firefox_20190412_205822.pn

Edited by Floflobel
Link to comment
Share on other sites

  • 2 months later...

Please help the plugin developer by providing the information requested in how to report a problem. thanks.

 

With pleasure, my friend.
 
I attached the log
 
Emby Server Version 4.2.0.16 beta
 
Plugin Slack 1.0.0.2
Plugin Slack 1.0.0.2 Beta
Plugin Slack 1.0.0.2 Beta 2
 
Plugin does not save settings

embyserver.txt

Link to comment
Share on other sites

I took a look at the log and didn't see anything obvious there.  I'm still running the latest stable and the configuration page works fine there. Once I can get an emby server setup with the beta I'll attempt to duplicate.

  • Like 1
Link to comment
Share on other sites

I took a look at the log and didn't see anything obvious there.  I'm still running the latest stable and the configuration page works fine there. Once I can get an emby server setup with the beta I'll attempt to duplicate.

\Thank you friend

 
I will be following here the answer of your test in the beta, because it is not working here.
 
Thank you
Link to comment
Share on other sites

hey @@ackbarr

any idea how to fix the problem with the "&" symbol?

I'd really like to use the new cumulative "new content notification" of the playback reporting plugin, but if one of the titles includes a "&" symbol the whole notification stays empty in Rocket.Chat.

 

@@TeamB in case of need, would it be possible to replace all "&" with "and" in your notification system?

 

Best regards

Edited by horstepipe
Link to comment
Share on other sites

When an update is out, I receive a notification on Slack, after a reboot the notification is spam every minute into my channel.

 

5cb0dff7693bd_firefox_20190412_205822.pn

@@Luke Have you got an idea for solve the problem ?

Link to comment
Share on other sites

What does that translate to?

A new version of Emby Server for Emby Server is available for download.

Please see emby.media for details.

Link to comment
Share on other sites

@@horstepipe

I think it will be more than just & that is causing an issue. The Notification plugin should escape any characters it can not handle.

 

Exactly, if it is a concern specific to Slack, then it should be handled within the plugin, not anywhere else. Thanks.

Link to comment
Share on other sites

Exactly, if it is a concern specific to Slack, then it should be handled within the plugin, not anywhere else. Thanks.

 

Unfortunately it seems to be a concern specific to Rocket.Chat. In Slack it works fine.

Link to comment
Share on other sites

@@horstepipe

I think it will be more than just & that is causing an issue. The Notification plugin should escape any characters it can not handle.

 So @@ackbarr will you take a look at it to escape the characters in your plugin?

Edited by horstepipe
Link to comment
Share on other sites

It should be handled by the notification plugin.

Agreed - based on the slack API docs, looks like they have a few characters that need to be htmlencoded. I don't have my visual studio environment setup atm, but once I do it looks like a straightforward fix.

  • Like 2
Link to comment
Share on other sites

  • 4 weeks later...

Not sure if it has ever been reported here, but Slack notifications won't send notifications if your emby user starts with a lower case letter. Not too big of a deal since I can just rename users, just an FYI.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

 

\Thank you friend

 
I will be following here the answer of your test in the beta, because it is not working here.
 
Thank you

 

 

I'm having this issue on latest stable - can't save the page so can't setup the plugin

 

Thanks

Link to comment
Share on other sites

  • 1 month later...

Same doesn't work on the last beta i'm getting this error :

VM454:83 Uncaught (in promise) TypeError: $(...).html(...).selectmenu is not a function

    at <anonymous>:83:29
Link to comment
Share on other sites

 

Same doesn't work on the last beta i'm getting this error :

VM454:83 Uncaught (in promise) TypeError: $(...).html(...).selectmenu is not a function

    at :83:29

 

 

@@ackbarr, just remove the use of the .selectmenu(...) method, or even better, convert to vanilla  js and that will be fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...