Jump to content


Photo

ASS subtitles causing video to be transcoded

ass subtitles transcoding

  • Please log in to reply
7 replies to this topic

#1 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2464 posts
  • Local time: 04:31 PM
  • LocationPerth, Australia

Posted 27 September 2016 - 06:53 AM

Today I noticed that some episodes my wife was watching in ET were all transcoding instead of Direct Playing.

 

It turned out that the only thing making them transcode was the fact that they had external ASS subtitles. I converted the subs to SRT and (after a rescan) the video now direct plays.

 

Considering that the subs in both cases are being rendered by XySubFilter why is it transcoding?

 

This displays in the log when ASS subs exist:

  • isEligibleForDirectPlay: False, isEligibleForDirectStream: False

 

But after changing them to SRT this displays:

  • isEligibleForDirectPlay: True, isEligibleForDirectStream: True

 

 



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142432 posts
  • Local time: 03:31 AM

Posted 27 September 2016 - 01:02 PM

Thanks for the report.



#3 AdrianW OFFLINE  

AdrianW

    Advanced Member

  • Super Testers
  • 2464 posts
  • Local time: 04:31 PM
  • LocationPerth, Australia

Posted 16 February 2017 - 10:59 AM

Not sure when it was fixed, but videos with external ass subs are now direct playing instead of being transcoded.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142432 posts
  • Local time: 03:31 AM

Posted 16 February 2017 - 11:57 AM

Thanks for the report.

#5 jaredallard OFFLINE  

jaredallard

    Member

  • Members
  • 25 posts
  • Local time: 12:31 AM

Posted 25 January 2018 - 09:54 PM

I'm actually experiencing this same thing right now.



#6 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12887 posts
  • Local time: 12:31 AM

Posted 25 January 2018 - 10:08 PM

Which app are you using?



#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 142432 posts
  • Local time: 03:31 AM

Posted 25 January 2018 - 11:34 PM

@ jaredallard , yes please let us know which Emby app and also attach the information requested in how to report a media playback issue. thanks !



#8 jaredallard OFFLINE  

jaredallard

    Member

  • Members
  • 25 posts
  • Local time: 12:31 AM

Posted 26 January 2018 - 12:54 AM

@ jaredallard , yes please let us know which Emby app and also attach the information requested in how to report a media playback issue. thanks !

 

 

Which app are you using?

 

Was using chrome, can't reproduce it anymore so. I'll post a log when I get it to reliably repro :shrug: 







Also tagged with one or more of these keywords: ass, subtitles, transcoding

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users