Jump to content

PS4 Web browser support


knottz
 Share

Go to solution Solved by Luke,

Recommended Posts

The only thing holding me back from supporting the app with my hard earned cash is your lack of support for the ps4, things are worse and worse with each update.

I am assuming there is no app being developed so why not tweak the web ui to support the ps4 better? videos play and transcode 90% okay but the interface itself is becoming more and more jumbled up with each update to the point where i have chosen to discontinue updating the server. It's a little backwards IMO to have your web ui which used to work great to slowly fall apart for the ps4. 

Please think about it.

 

Link to comment
Share on other sites

I have tried this using an updated version for temporary purposes off my laptop.
 

  • There are certain parts of the UI that look bare
  • There are parts such as the purchase emby premiere part which get shoved into the top left corner (they should appear central)
  • Once playing a video there is no way to come out of it, such as a home button or a 'X' to close the playing video
  • In general terms there seems to be UI buttons that just dont exist, an menu button, return back, etc. (I understand the bumpers work kinda but its not very user friendly this way)
  • In some ways, this is worse.
  • Not having a direct link to my specific server is strange also (why must it be access via tv.emby.media) 
  • In general there are a lot of visual glitches and things, I guess this tv.emby.media is a work in progress?

Maybe I am missing something?

Edited by knottz
Link to comment
Share on other sites

  • 1 month later...

Sorry to bump an old thread, but I feel I didn't get an answer as such...

I am still using Version 3.0.5972.0 as it is the last compatible build to work with the ps4s browser correctly...

tv.emby.media does not play well with the browser either as it currently stands (using an upto date server configuration)

This is literally the only thing holding me back from buying lifetime subscription, you guys do a great job and I am sure you are very busy but please re-consider your support for ps4. Am I really the only one who wants this?

 

Link to comment
Share on other sites

What are the issues with tv.emby.media? Because that is what we would fix since that is the app that is designed for use on a TV. Thanks.

Link to comment
Share on other sites

Hi, the interface doesn't play nicely with the browser, objects seem sized incorrectly or in the wrong place or they even overlap each other sometimes... There is no official back button of sorts which doesn't help.

I will go ahead and take some screenshots when i get time to demonstrate better but ideally someone on your team would be better trying it on a ps4 themselves if you had one to hand.

Thanks.

 

P.S: Is there any way to get a direct link to a tv.emby.media version of the site? instead of having to goto tv.emby.media and then manual login etc? 

Edited by knottz
Link to comment
Share on other sites

  • Solution

See here:

 

https://emby.media/community/index.php?/topic/41691-emby-theater-on-ps4/

 

I tested last night on a PS4 and everything was sized perfectly - just avoid using the PS4 buttons that zoom in and out. That's probably what you did.

 

Everything was perfect in my testing except for the video OSD which I will be looking at resolving. Yes, on-screen back button might be nice but the PS4 L1/R1 are dedicated back and forward buttons for the PS4 browser.

  • Like 1
Link to comment
Share on other sites

The key thing is, the PS4 browser is not that great so you unfortunately have to learn the quirks of the browser a little bit more so than other browsers.

Link to comment
Share on other sites

I will go have a look shortly and report anything unusual I find, you have me optimistic that it may have been me doing something wrong. 

Is there anyway to get directly to my site with tv.emby.media instead of having to manual connect? I'd prefer to just use my domain or ip and get straight there?

Link to comment
Share on other sites

Not at this time but all connections are direct from your PS4 to your server. The only thing being pulled from our server is the static html user interface.

Link to comment
Share on other sites

Any particular reason you are doing it that way or is it just temporary for now?

Sorry for this bad screenshot, but one thing i noticed straight away is the emby buy now thing doesn't display correctly but so far the rest (on my test server) does work much better than when i last tested it. I'm going to backup my old server and buy a month subs and do some further testing. Looking good so far though.

 

 

5834b0958310e_20161122_205110.jpg

 

 

Link to comment
Share on other sites

Thanks I will test that as well as other popups. It's an issue with the popups in general, they are using newer css flex layouts which the ps4 browser does not support.

Link to comment
Share on other sites

Okay when actually watching a video, the bottom overlay doesnt hide away? (where you can rewind fast forward and pause) 

Link to comment
Share on other sites

When you have selected a movie and are about to press play, you cant scroll down the page to view cast and crew without using the d pad as a workaround. When pressing the play button during playback the animation behind the icon doesnt render back out (press the pause play button a few times to get the result i am talking about) -EDIT Actually it does this anywhere where you can click something.

Edited by knottz
Link to comment
Share on other sites

But yeah sorry, overall it gets the job done. just need the osd to disappear i noticed it fades though

Link to comment
Share on other sites

  • 3 years later...
3 hours ago, Rysss said:

Hi, tv.emby.media doesn't work on PS4! Do you have a solution for "connection error"?

Hi there @Rysss, it works just fine. Can you please describe the issue that you're having? Are you trying to connect to your own Emby Server, or someone else's?

Link to comment
Share on other sites

8 minutes ago, Luke said:

Hi there @Rysss, it works just fine. Can you please describe the issue that you're having? Are you trying to connect to your own Emby Server, or someone else's?

Thank you for your return. I'm trying to connect to my server, the ps4 is on the same network. Given the new rules of the firewall under W10, everything is open... Whether I connect in manual or by Emby Connect it doesn't work. 'connection error' every time. My server is well turned on, I'm live on PC and smartphone when I try to connect to PS4.

Edited by Rysss
Link to comment
Share on other sites

3 minutes ago, Rysss said:

Thank you for your return. I'm trying to connect to my server, the ps4 is on the same network. Given the new rules of the firewall under W10, everything is open... Whether I connect in manual or by Emby Connect it doesn't work. 'connection error' every time. My server is well turned on, I'm live on PC and smartphone when I try to connect to PS4.

What address is in the ps4 browser address bar?

Link to comment
Share on other sites

try prefixing it with http:// in order to avoid getting the https:// version.

You can only use the https version if you have setup https on your emby server.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...