Jump to content

Port 8920 ssl problem


robello84
 Share

Go to solution Solved by anderbytes,

Recommended Posts

robello84
Good evening guys, is from about 1 week that the ssl connection on port 8920, does not work anymore.
I try to restart emby, and it works for about half an hour, then do not work anymore.
 
I have the latest version of emby installed.
 
It works via http.
 
Using the certificate of let'sencrypt from 6 months is it always worked.
 
Can someone help me?
 
The only mistake that I find in the log is this.
 
Thank you
 
2016-09-15 14:30:14.1333 Error ServiceStackHost: Error occured while Processing Request: Access token is required.
	*** Error Report ***
	Version: 3.0.7100.0
	Command line: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe -programdata /var/lib/emby-server -ffmpeg /usr/bin/ffmpeg -ffprobe /usr/bin/ffprobe -restartpath /usr/lib/emby-server/restart.sh
	Operating system: Unix 3.19.0.42
	Processor count: 8
	64-Bit OS: True
	64-Bit Process: True
	Program data path: /var/lib/emby-server
	Mono: 4.4.2 (Stable 4.4.2.11/f72fe45 Tue Aug 30 15:48:05 UTC 2016)
	Application Path: /usr/lib/emby-server/bin/MediaBrowser.Server.Mono.exe
	Access token is required.
	MediaBrowser.Controller.Net.SecurityException
	  at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateSecurityToken (IServiceRequest request, System.String token) <0x413e2870 + 0x00107> in <filename unknown>:0 
	  at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.ValidateUser (IServiceRequest request, IAuthenticationAttributes authAttribtues) <0x413e0eb0 + 0x0007b> in <filename unknown>:0 
	  at MediaBrowser.Server.Implementations.HttpServer.Security.AuthService.Authenticate (IServiceRequest request, IAuthenticationAttributes authAttribtues) <0x413e0e80 + 0x00017> in <filename unknown>:0 
	  at MediaBrowser.Controller.Net.AuthenticatedAttribute.RequestFilter (IRequest request, IResponse response, System.Object requestDto) <0x413e0de0 + 0x0007a> in <filename unknown>:0 
	  at ServiceStack.ServiceStackHost.ApplyRequestFiltersSingle (IRequest req, IResponse res, System.Object requestDto) <0x41324b60 + 0x0029e> in <filename unknown>:0 
	  at ServiceStack.ServiceStackHost.ApplyRequestFilters (IRequest req, IResponse res, System.Object requestDto) <0x41322590 + 0x000d5> in <filename unknown>:0 
	  at ServiceStack.Host.RestHandler+<ProcessRequestAsync>d__13.MoveNext () <0x4131d1d0 + 0x00595> in <filename unknown>:0 
	

 

Link to comment
Share on other sites

  • Solution
anderbytes

Hi Luke thank you for welcome. I love Emby

 

 

See attach for log

 

 

thank you

 

It seems to be losing the session token.

 

Are you using which Browser? Have you tried with others? Private or normal browsing? Disabled all addons?

Running via Emby Theater works?

  • Like 1
Link to comment
Share on other sites

robello84

It seems to be losing the session token.

 

Are you using which Browser? Have you tried with others? Private or normal browsing? Disabled all addons?

Running via Emby Theater works?

Hi Ander, thank you for reply.

 

i have 50 friend connected with raspberry (OSMC), i use chrome only for access and insert movie, normal browsing.

 

The only plugin i have installed is pushover.

 

I try with other browser but not work.

Link to comment
Share on other sites

  • 3 weeks later...
oneil31

After make backup, uninstall and install new version without pushbullet plugin. Work like a charm.

 

Thank you guys

:)

Hi robello,

Same issue solved with uninstall only pushbullet :)

 

By security i make a little script with crontab who check https over 8920 responce log and restart emby-server. But since uninstall of pushbullet no new issue.

res="KO"
dt="date +%F_%T"
res=$(curl -sikm 2 -D - https://127.0.0.1:8920/web/index.html -o /dev/null | grep -e "HTTP.*200 OK")
echo $($dt)" : curl - $res"
if [ -z "$res" ] || [ "$res" = "KO" ]
then
 echo $($dt)" $0 : KO"
 echo "EREUR emby => restart"
 /etc/init.d/emby-server stop
 /etc/init.d/emby-server start
else
 echo $($dt)" $0 OK"
fi

Not perfect but it make the job :D

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...