Jump to content

Playback subtitles weird display


djhifi
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

Problem to report. Since I've applied the alpha EMBY for KODI addon, my KODI client started streaming from the server instead of direct playback. I found this because as I'm from Portugal and we use special characters  on subtitles such as: é, á, ão, etc, it is replacing them for "?" instead.

 

This wasnt happening yesterday so something must be messed up in the paths. The only thing is that I cannot sort this out, because everything is correctly setted up on my server (path substitutions).

 

PS: Dashboard diferentiates direct play (smb) from transcoding by any chance? Cause I only get "direct playing"...but the stuff with the subtitles makes me think its using EMBY server, cause if I reproduce anything on the emby server that problem shows up (yes, im aware its because UTF-8 vs ANSI encoding).

Edited by djhifi
Link to comment
Share on other sites

Please start a new thread when reporting issues unrelated to OP (I split your post from the thread, this is for future reference). Otherwise it makes my life difficult to track stuff to verify. Are you using add-on playback? The default is to play from HTTP - to change back to smb, you need to go in add-on settings > playback > uncheck play from HTTP. However there should not be an issue displaying subtitles. At least French subs are displaying correctly in my case, even when playing from HTTP.

 

http://emby.media/community/index.php?/topic/17599-how-to-report-a-problem/

Edited by Angelblue05
Link to comment
Share on other sites

Please start a new thread when reporting issues unrelated to OP (I split your post from the thread, this is for future reference). Otherwise it makes my life difficult to track stuff to verify. Are you using add-on playback? The default is to play from HTTP - to change back to smb, you need to go in add-on settings > playback > uncheck play from HTTP. However there should not be an issue displaying subtitles. At least French subs are displaying correctly in my case, even when playing from HTTP.

 

http://emby.media/community/index.php?/topic/17599-how-to-report-a-problem/

EDIT: You were right, it was defaulting to HTTP. Strange...the RC addon is not standard for HTTP.

 

Thanks. For a second I thought it was something in the alpha..

Edited by djhifi
  • Like 1
Link to comment
Share on other sites

As I said, it's because we changed the default playback mode for add-on playback. It's set to play from HTTP when you do a fresh install, which I think you did. Just go to the add-on settings > playback tab > disable play from HTTP.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

As I said, it's because we changed the default playback mode for add-on playback. It's set to play from HTTP when you do a fresh install, which I think you did. Just go to the add-on settings > playback tab > disable play from HTTP.

 

Yup, you are right. Sorry for posting in the wrong section. I thought it could be addon related.

 

Regarding subtitles, when they are encoded in ANSI there is the display problem when transcoding from EMBY. To solve it people must change to UTF-8 but as I don't do transcode i dont' care.

Edited by djhifi
Link to comment
Share on other sites

EDIT: You were right, it was defaulting to HTTP. Strange...the RC addon is not standard for HTTP.

 

Thanks. For a second I thought it was something in the alpha..

 

The reasoning is that a lot of users do not know how to get their paths working the first time around. It's easier to default to HTTP playback since we know playback will work 100% of the time. Play from SMB is considered advanced and it is expected of the user to know how to get their own set up working. Unfortunately, the reality is that it's not my job to help people figure out their network/path issues. By defaulting to HTTP playback, users know they have a way to get playback going, and if they wish to get SMB playback, then they can do it on their own time without being stumped the first time they install Emby for Kodi.

 

@@djhifi are your subtitles external? If so, can you provide the srt file?

  • Like 1
Link to comment
Share on other sites

The reasoning is that a lot of users do not know how to get their paths working the first time around. It's easier to default to HTTP playback since we know playback will work 100% of the time. Play from SMB is considered advanced and it is expected of the user to know how to get their own set up working. Unfortunately, the reality is that it's not my job to help people figure out their network/path issues. By defaulting to HTTP playback, users know they have a way to get playback going, and if they wish to get SMB playback, then they can do it on their own time without being stumped the first time they install Emby for Kodi.

 

@@djhifi are your subtitles external? If so, can you provide the srt file?

Yes i'm aware that it's for advanced users (once you get the hang of it it's easy) but I agree on your choice there. Tres bien pensée :)

 

My subtitles are external yes, and on EMBY transcoding it displays "?" on special characters, I searched and came to the conclusion that the internal player from EMBY only uses UTF-8 external encodes of .srt's right? Mines are all in ANSI. I will attach 2 or 3 examples in 30 sec.

 

@@Angelblue05

http://www.filedropper.com/subsfortesting

Edited by djhifi
  • Like 1
Link to comment
Share on other sites

It's very strange, in my play from HTTP testing, the subs display fine. Not a single ? in sight. I'll keep this in mind...

 

But did you notice its encoded in ANSI? Your subs are encoded in what ? Maybe this is language related? Idk. My server is in english, country portugal. I didnt change language of server.

If i put them in UTF-8 dunno why but the server displays them fine

 

edit:

 

http://emby.media/community/index.php?/topic/7719-external-subtitles-ansi/?p=103117

 

Check lukes answer to this. Idk why it's still happening with me

Edited by djhifi
Link to comment
Share on other sites

Yeah, I tested with the subs you provided last post and they display fine here... Maybe it's because I'm running on Windows? Hmm...

 

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

Yeah, I tested with the subs you provided last post and they display fine here... Maybe it's because I'm running on Windows? Hmm...

 

 

Sent from my iPhone using Tapatalk

 

Is it? Im using Synology hence Linux. Wierd wierd. Digging into this a little more and try to find a root cause. But just for the sake of exclusion, theres no setting to be changed about this encoding part, right?

Link to comment
Share on other sites

No, I didn't change any settings on my side. It just worked. I will test on my firetv stick later to compare.

 

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

I am having the same problem as djhifi, I am also Portuguese. My server is running on a Freenas 9.10.1, in a jail based on FreeBSD.

 

I have also reported in the thread http://emby.media/community/index.php?/topic/7719-external-subtitles-ansi/page-3&do=findComment&comment=366722

 

@@rbanaco eu também fiz report nessa thread. O engraçado é que o @@Angelblue05 diz que consegue reproduzir ANSI sem quaisquer erros, sendo ele Francês e tendo as letras especiais...não deixa de ser estranho.

 

I've also made report in that thread. Funny thing is that @@Angelblue05 says he can play with the external ANSI subtitles I've sent him without any kind of "????" errors. Being him French hence having accented characters on his subtitles just like us....makes me wonder what kind of spell is going on for some of us :D

Edited by djhifi
  • Like 1
Link to comment
Share on other sites

I've tested it on my FireTV stick and your provided subs displays fine. I was playing from HTTP, with external subs being downloaded to Kodi locally. It displays correctly. I don't know what to think of the issue...

 

The fact that external subtitles were downloaded locally removes Emby from the equation when it comes to providing the subtitles. Kodi reads them directly from the file locally and it displays correctly. I also tried without downloading the subtitles locally, and it works just the same! Go figure...

 

Maybe you can try play from HTTP, but to test, you would need to rename your external subtitle to contain the language tag like: Orphan Black - 1x01 - Natural Selection.pt.srt

You need to then refresh the episode in the emby metadata manager. Try to playback, does it display correctly?

Edited by Angelblue05
Link to comment
Share on other sites

@@Angelblue05 what system are you running your server from? 

 

I don't know how can you remove Emby from the equation since I run the subtitles fine from Kodi, Plex and only Emby gives me problems. Only if I change the enconding to UTF-8 with the help of notepad++ I can read them correctly.

 

I attach an example of narcos s02e03.

 

with the subtitle as Narcos S02E03 720p WEBRip x264-TheRival.pt.srt and movie as Narcos S02E03 720p WEBRip x264-TheRival.mp4

 

Thanks

post-155805-0-28831500-1474211041_thumb.jpg

Edited by rbanaco
Link to comment
Share on other sites

Running on windows. But when the language tag is added to the subtitles and the server sees it, the add-on downloads the srt files locally for playback and Kodi reads from it. So you understand how Emby is not part of the external subs being loaded in, because it's read the subs from the local Kodi storage (in this case, firetv stick).

 

Anyway, it's not truly an add-on issue. I don't know what you expect the resolution to this issue will be?

 

 

Sent from my iPhone using Tapatalk

Edited by Angelblue05
Link to comment
Share on other sites

Well, I am not a developer so I'm basically the part of the problem lol 

 

I'm just commenting on bugs, I wanted it to work because there are other stuff where emby is better than others, however this one is a major thing, for me at least, but if you can't or simly don't think is worth to work it out, not problem.

 

I am yet to test installing emby server on windows (I have a feeling that is where the problem resides).

 

@@Angelblue05 as you can see from the screenshot I attached, it's not kodi that is reading, but emby on chrome (http) so you can't exclude Emby of the equation.

This also happens in Android with emby app. For Kodi I don't need Emby, I need emby for outside my home, that's where I use it the most.

 

What I was saying is that this doesn't happen on PLEX (both app and http) and Kodi (stand-alone not emby addon)

Edited by rbanaco
Link to comment
Share on other sites

Ok, well glad you found the source of the issue.

 

I feel foolish. I just tested again and realize the setting to download external subs was not turned on in my settings, doh! So the server was providing the subs during my testing which is why it worked as intended (windows server). I enabled download external subs under the add-on settings > playback, and it displays correctly (which excludes the server from providing the subs)...

 

Can you confirm when you tested, the subs showed up as Portuguese external and not Unknown external (essentially, make sure the settings is enabled in the add-on settings)? Let me know, because there might be a way I can make the add-on save the file as utf-8 on the fly during playback in Kodi while using play from HTTP.

Edited by Angelblue05
Link to comment
Share on other sites

I'm sorry @@Angelblue05 i realized that this is not the right thread. My problem is not with emby addon for kodi, I don't even use it.

 

My problem is with emby server for FreeBSD. When I play any file with portuguese subtitles not encoded to UTF-8 they do that "?" stuff. 

If I play through emby server for Windows, they run fine.

 

If you have any clue to solve that I will be glad.

 

Thanks and sorry for the inconvenience.

Edited by rbanaco
Link to comment
Share on other sites

Ah ok, I didn't realize you were not using Emby for Kodi. Sorry, I don't know how to resolve this server side.

 

 

Sent from my iPhone using Tapatalk

  • Like 1
Link to comment
Share on other sites

@@djhifi

 

While playing content, go to the OSD option for subtitles, is the track labelled or is it Unknown (external). If it shows as Unknown, can you rename the subtitles file with the language tag, like {filename}.{language}.srt. Then in Kodi, open the context menu > Emby options > Refresh this item. Wait a few moments, then try to playback. Is the track labelled then? Does it display correctly? Let me know.

Link to comment
Share on other sites

  • Solution

I'm marking this thread as solved. This is not an issue with Emby for Kodi, this is a server-related issue, in this case FreeBSD and Synology; this issue might exists on other linux systems as well.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...