Jump to content

Emby for KODI : kodi cannot find next item to play


grbharati
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

grbharati

Hello Everyone,

 

I have Emby server V.3.0.6300.0-1 running in my Synology. It is working perfectly in Web, iOS, and android environments. I recently installed KODI in my mac and Emby add-on for KODI. Now, KODI is able to fetch all the information from Emby server, However, if I try to play some movies, or videos it throws the error :

cannot find next item to play

Instead of using add-on from Emby, if I add files from my Synology smb server, it is able to play the movies. Therefore, I am assuming that there is something going wrong with KODI - Emby interface. I have attached the recent log file. One thing peculiar in the log file that got my attention was:

0:40:45 T:123145303453696  NOTICE: EMBY.playbackutils -> Play called.
00:40:45 T:123145303453696  NOTICE: EMBY.playutils -> Verifying path: /volume1/downloads/filestream/Movies/The Hateful Eight (2015).mkv
00:40:45 T:123145303453696  NOTICE: EMBY.playutils -> Can't verify path, assumed linux. Still try to direct play.
00:40:45 T:123145303453696  NOTICE: EMBY.playutils -> File is direct playing.
00:40:45 T:123145303453696  NOTICE: EMBY.playbackutils -> Setting up properties in playlist.
00:40:45 T:123145303453696  NOTICE: EMBY.playbackutils -> Processed as a playlist. First item is skipped.

Why was it not able to verify the path, and why it is assuming Linux? I am using smb. 

 

There is similar post:

 

http://emby.media/community/index.php?/topic/31500-cant-play-since-new-update-playlist-error/

 

Which, has been fixed by changing parameters in advancedsettings.xml, which in my case cannot find the location of the file. Also the topic is closed.

 

Your help would be greatly appreciated.

kodi.log

Link to comment
Share on other sites

grbharati

Use path substitution in Emby to make your paths compatible. You are not using smb at this time. 

https://github.com/MediaBrowser/Wiki/wiki/Path%20Substitution

 

Or enable play from http in the add-on settings > playback.

 

Hi Angel Blue, enable play from https worked. I also tried using path substitution but it did not work. Checking the log file, it is stating that file cannot be found. I have r/w permission for the username I used for the KODI. I checked it in mac by checking the permissions. Am I doing something wrong? I have attached the log files.

 

In path substitution I used:

 

From :   /volume1/video

To:  \\MeroFile\video

 

checking smb link in mac works fine for the username (embysvr)

kodi.log

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...