Jump to content


Photo

.NET 4.6.2


  • Please log in to reply
38 replies to this topic

#1 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 03:07 AM

Posted 16 August 2016 - 01:28 AM

There are some nice improvements here:

 

https://blogs.msdn.m...ramework-4-6-2/

 

The installers are being updated to bundle 4.6.2 now (from previous 4.6.1). Enjoy.


  • Abobader likes this

#2 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14703 posts
  • Local time: 12:07 AM
  • LocationWashington State

Posted 16 August 2016 - 03:34 AM

Users with remote servers will have to ensure they log into there server and click on the Dot net downloader then run it.  Then it requires a system start.


Edited by Happy2Play, 16 August 2016 - 03:35 AM.

  • fraenhawk likes this

#3 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15252 posts
  • Local time: 08:07 AM
  • LocationKent, England.

Posted 16 August 2016 - 04:52 AM

http://emby.media/co...anual-updating/



#4 denz OFFLINE  

denz

    Advanced Member

  • Members
  • 2106 posts
  • Local time: 03:07 PM
  • LocationPerth, Australia

Posted 16 August 2016 - 05:55 AM

I was wondering why I can't connect. That must be a reason why.
  • CBers likes this

#5 fraenhawk OFFLINE  

fraenhawk

    Advanced Member

  • Members
  • 386 posts
  • Local time: 03:07 AM
  • LocationDeLand, FL

Posted 16 August 2016 - 08:40 AM

I was wondering why I can't connect. That must be a reason why.

Same, I did the update and Emby restart from work and couldn't connect back in. Remoted in to server and saw the 4.6.2 warning box.


  • CBers likes this

#6 pir8radio OFFLINE  

pir8radio

    NGINX

  • Members
  • 2798 posts
  • Local time: 02:07 AM
  • LocationChicago

Posted 16 August 2016 - 08:54 AM

Installed and running...   good work!


Edited by pir8radio, 16 August 2016 - 09:05 AM.


#7 denz OFFLINE  

denz

    Advanced Member

  • Members
  • 2106 posts
  • Local time: 03:07 PM
  • LocationPerth, Australia

Posted 16 August 2016 - 09:36 AM

I got home and had to install it and it works now.

#8 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15252 posts
  • Local time: 08:07 AM
  • LocationKent, England.

Posted 16 August 2016 - 09:40 AM

I got home and had to install it and it works now.

 

Chrome Remote Desktop


  • denz likes this

#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 03:07 AM

Posted 16 August 2016 - 11:00 AM

Well done everyone.



#10 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15252 posts
  • Local time: 08:07 AM
  • LocationKent, England.

Posted 16 August 2016 - 01:17 PM

So this has gone out to BETA already?

Getting calls from friends and family asking why Emby isn't working.

A really bad release experience.

#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 03:07 AM

Posted 16 August 2016 - 01:27 PM

There will be an announcement for the stable release. It won't be included in the next stable in order to give the general audience advanced notice.



#12 MSattler OFFLINE  

MSattler

    Advanced Member

  • Alpha Testers
  • 1458 posts
  • Local time: 03:07 AM

Posted 16 August 2016 - 01:42 PM

So this has gone out to BETA already?

Getting calls from friends and family asking why Emby isn't working.

A really bad release experience.

 

Thank you for testing Beta? =)


  • CBers, MrWebsmith and fraenhawk like this

#13 Abobader OFFLINE  

Abobader

    Super-Tester

  • Administrators
  • 14471 posts
  • Local time: 10:07 AM

Posted 16 August 2016 - 07:40 PM

So this has gone out to BETA already?

Getting calls from friends and family asking why Emby isn't working.

A really bad release experience.

 

It all fun, well at the end of the day tho :)


  • MrWebsmith likes this

#14 denz OFFLINE  

denz

    Advanced Member

  • Members
  • 2106 posts
  • Local time: 03:07 PM
  • LocationPerth, Australia

Posted 18 August 2016 - 12:28 AM

Thanks for the suggestion didn't know about it but I discovered while testing it doesn't work when wmc is full screen and on that pc it always full screen. It was worth a try.

 

Edit: I can minimise WMC just had to to guess the location of the minimise button and we have picture now should have tried that yesterday. Yay.

 

Thanks again


Edited by denz, 18 August 2016 - 01:02 AM.


#15 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15252 posts
  • Local time: 08:07 AM
  • LocationKent, England.

Posted 18 August 2016 - 02:50 AM

Thanks for the suggestion didn't know about it but I discovered while testing it doesn't work when wmc is full screen and on that pc it always full screen. It was worth a try.

 

Edit: I can minimise WMC just had to to guess the location of the minimise button and we have picture now should have tried that yesterday. Yay.

 

Thanks again

 

Yes I've found that as well when connecting to family PC's, but I just get them to close WMC off :)



#16 moviemadnessman OFFLINE  

moviemadnessman

    Advanced Member

  • Members
  • 72 posts
  • Local time: 03:07 AM

Posted 25 August 2016 - 08:44 PM

Warning: .NET 4.6.2 does not have support prior to Windows 7 (ie Vista).  Trying to update Emby and .NET will break your Emby install, unless you have a backup to roll the server back.

 

Repeat: Trying to update now that Emby uses .Net 4.6.2, if you are on Vista, DO NOT UPDATE.

 

Thank you.



#17 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 14703 posts
  • Local time: 12:07 AM
  • LocationWashington State

Posted 25 August 2016 - 08:51 PM

57bf92895113e_NET.jpg



#18 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 03:07 AM

Posted 25 August 2016 - 09:03 PM

If you follow that table, that says 4.61 isn't supported on Vista either and yet nobody has reported a problem with that. That means either hardly anyone is using Vista, or it might still work even if not officially supported.

 

Why didn't you take advantage of the free upgrade option to Windows 10?



#19 moviemadnessman OFFLINE  

moviemadnessman

    Advanced Member

  • Members
  • 72 posts
  • Local time: 03:07 AM

Posted 25 August 2016 - 09:13 PM

If you follow that table, that says 4.61 isn't supported on Vista either and yet nobody has reported a problem with that. That means either hardly anyone is using Vista, or it might still work even if not officially supported.

 

Why didn't you take advantage of the free upgrade option to Windows 10?

4.6.1 still works on Vista.  The installer for 4.6.2 won't run and simply says that the operating system is not supported.  I'm working on a workaround, but might not have any luck (even rolling back Emby hasn't worked).

 

As to why I didn't update to 10, it's for the same reason that is causing Emby to no longer work ... Vista was not included.  Windows 7 and Windows 8.1 were the ones included.



#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 131347 posts
  • Local time: 03:07 AM

Posted 25 August 2016 - 09:25 PM

In MediaBrowser.ServerApplication.exe.config you can change supported runtime to 4.61 and it should start up and work fine. You'll have to do it everytime you update though so it's better to stay on the stable release so that it's less often. Right now the main benefit of 4.62 is a couple bug fixes. This workaround should last you a little while, at least until we start using new features and then it will just fail. But I don't think that will happen on 4.62, but something later.


  • moviemadnessman likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users