Jump to content

Emby ignoring parental controls with background images


GothsterC
 Share

Recommended Posts

GothsterC

This seems to be a new behavior that I don't recall ever happening.  My 10 year daughter showed me some very inappropriate background images being displayed while she browsed the kids library.  The background images were from movies that she doesn't have access to.  So if she doesn't have access to those movies, why are background images from those movies being displayed in the kids library?  I recall that before only images from movies that she had access to were shown in the background while browsing.

 

The only thing I have found is that I can go into each client as the kid user and disable backgrounds, but this needs to be done with many different clients and there is nothing stopping the kids from turning the backgrounds back on.

 

Please help.

Link to comment
Share on other sites

GothsterC

I'm using Emby Server 3.0.6060 on the latest update to Windows 10.

 

I checked and saw this behavior in both the Windows web app (using Chrome and Firefox) as well as the Amazon Fire TV app.

I haven't checked the Amazon Fire tablet yet, but they also have those.    I have several libraries including Kids (G, PG), Teens (PG-13) and Grownups ®.  They can only access the kids library but were seeing background (fanart) images from the R-rated library.  I selected and became a supporter of Emby because of the parental controls.

 

I checked for this in the past when I gave the kids access to their Emby library and could swear they only saw backgrounds from images within their own libraries, so something must have changed somewhere.  I've also reviewed my settings and found nothing that could have triggered this.

Thanks

Edited by GothsterC
Link to comment
Share on other sites

GothsterC

After logging in, the inappropriate background images appear behind the icons in the Home and Movies screens.  

I've attached a screenshot and lightened it so you can see the image better.

post-31877-0-59740000-1470972594_thumb.jpg

Link to comment
Share on other sites

GothsterC

Yes.

Because I have children, I have movies on various drives.  I have a drive for kid movies.  I have a drive for more adult movies.  I have set up separate libraries that point to the correct locations.  The kids have access to only their own drives, not to the adult ones.  The backgrounds are downloaded by Emby from the various sources (themoviedb.org, etc.) automatically and serve as backgrounds when viewing a particular movie.  However when you are browsing, let's say the movies, you get a random background image from one of the movies behind the icons.  In the past, the random background image was only from content the user had access to, but now it is showing images from the other locations.

 

They should have access to these images

Drive K: Kids\Alvin and the Chipmunks [2007]\Alvin and the Chipmunks [2007]-fanart.jpg, *-fanart-1.jpg, , *-fanart-2.jpg and so on

Drive K: Kids\Alvin and the Chipmunks [2007]\extrafanart\fanart1.jpg, fanart-2.jpg and so on

 

They should not have access to these images, but they can randomly appear in the background

Drive R: Grownups\The Dreamers [2003]\The Dreamers [2003]-fanart.jpg, *-fanart-1.jpg, , *-fanart-2.jpg and so on

Drive R: Grownups\The Dreamers [2003]\extrafanart\fanart1.jpg, fanart-2.jpg and so on

 

They don't have access to any of the movies on drive R, but the randomly generated slideshow that appears in the background is drawing from that drive.

 

I hope this is clear.

 

Thanks

 

 

 

Link to comment
Share on other sites

thanks. what mechanism is being used to restrict that movie from the kids? just normal library access or one of the parental control features?

Link to comment
Share on other sites

GothsterC

I create the library using the Library settings by having a separate library for each drive.  So I have a library called Kids that points to the K drive and a library called Grownups that points to the R drive.

I then created a user called Kids using the Users settings.  In there, I used the Access tab and only selected access to the Kids library.  All others are disabled.  

I have nothing special setup in the Parental Controls tab.

Link to comment
Share on other sites

Ok, what i would suggest doing is going to the access tab for the kids user and just double checking that everything is the way you expect, and then also click save just to resave the settings. see if that makes a difference, thanks.

Link to comment
Share on other sites

GothsterC

I just did what you asked.  Everything looks correct and I saved again.  I went back in as Kids.  They still only show the movies they have access to, but the backdrop image when browsing the movie icons showed another, but different image, from the restricted library.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...