Jump to content

WMC Player - Audio format wrong and forward / rewind not working


maeffjus
 Share

Go to solution Solved by ebr,

Recommended Posts

maeffjus

Hi Everyone,

 

I'm using Emby for a longer while now, but I got one new and one older (longer existing) problem (bot in WMC with Windows 10):

 

Just a short overview of my config / systems:

I got a HTPC with an i5 6400 with 8GB of RAM running Windows 10 and the media center installed. This is connected via HDMI to a Pioneer VSX-830 surround receiver (with 5.1 speakers), which is connected to a 65" LED TV - also with HDMI.
My media is stored on a dedicated server - running Windows Server 2012 R2 with a i5 3550 and 32GB of RAM with all my media in a 5x3TB RAID6 volume. 
Emby is installed in newest version on both server and HTPC. Both are connected via Gbit network.
On both system I have installed Shark007's codecs in newest version and set the Audio setting to HDMI (the upper of the 3 options - these are: HDMI, SPDIF, Analog).
I do not use transcoding on the server to the HTPC.

1. (The new problem) The sound played from Emby is only played in stereo - no matter what the sound-track of the source is. I mostly got MKV files from which most of them are in 720p, some in 1080p - most with either DolbyDigital or DTS.
This is very anoying. 
When I watch TV from WMC, the output is equal with the input - so TV-shows with stereo will play in stereo and stuff in DD will be played with DD. 
Also when I open some movies in VLC on the HTPC, the output is exactly as it should be.
So what can I do to watch my movies with apropriate sound?

 

2. (The older problem) When I watch any movie with EMBY on the HTPC, the fast forward / rewind / skipping forward etc. is not usable. Any button-press just doesn't initate any action. I use a second display to show TV-station names etc, on this it only says "stream". In the past (with the old local version of the Media-Browser) all of this has not been a problem.

It doesn't change if I use the old or the new-style player.
How can I fix this? Resuming also doens't always work..

Thanks in advance and best regards,

Matthias
 

Link to comment
Share on other sites

epayson85

Have you setup your speaker configuration in Windows? Make sure you do that first and select stereo. Then under audio settings in shark007 where you selected HDMI... to the left of that set it as same as input and disable windows auto config. The reason your live TV is working is because you probably have Dolby bitstreaming enabled via windows sound settings and livetv uses Dolby. Most mkv files use DTS / ac3 or some other codec and need these settings setup correctly. Your issue will be if you are using audio other than Dolby / DTS / AC3 in your movies. For example aac audio. It cant be bitstreamed thus you have to send it analog. You can achieve this by disabling Microsoft audio codecs but that will break livetv. I process all my audio through ffdshow and I love it. Purists out there will disagree with me but I don't consider myself an audiophile. Can I hear everything / are the sounds processed through the correct speakers and are the voices loud enough to hear over the sounds effects / music? Yep so perfect to me haha.

Link to comment
Share on other sites

maeffjus

Thank you, I will try this later when I'm at home.
I agree with you - I really hear a bad MP3 (like the ones I encoded from audio CD's in the early 2000's when MP3 came out), but everything on a good bitrate with proper encoding...? I don't give a s....! 
I just want to have a nice quality, it doesn't have to be over the top or whatsoever, I have damaged my ears too much when I had my first car and installed a crazy 1500w amplifier with all the crazy stuff around it.

Any solution for #2?

Link to comment
Share on other sites

epayson85

Can you give us the media information of the file you are playing? Like the Audio and video codecs. Honestly if you have it setup like I said in shark007 it should work.

Link to comment
Share on other sites

  • Solution

Sounds like maybe the items are streaming instead of direct playing. Be sure it isn't an access problem to the media.

Link to comment
Share on other sites

maeffjus

The file is in DTS, 3F2R 48khz, 1536bit/s.

Video is H264 1280x738 pix.

I would like to do the sound configuration in WMC - but the option is gone - no idea why? Do you know?

Link to comment
Share on other sites

maeffjus

If I'd knew I'd try to get the option back - but however - I guessed it might be gone along with any other option I made - no Idea at all...

Link to comment
Share on other sites

maeffjus

I know - but in the options of WMC is no such option, I know that it has been there befor, but this option just disapeared.
No, the machine should be able to access the files on the server flawlessly. (Streaming issue)

Link to comment
Share on other sites

No, the machine should be able to access the files on the server flawlessly. (Streaming issue)

 

Should be or you have confirmed it?

 

Can you post an EMC log when you play one of these?

Link to comment
Share on other sites

maeffjus

Should be or you have confirmed it?

 

Can you post an EMC log when you play one of these?

Okay - forget about this point :-)

I have configured the network paths on the server in EBMY - BUT:

The substitution used the IP and the share on the HTPC uses the DNS-name. In general not a problem - but the HTPC simply hasn't had the credentials for the IP.

So it is now showing the time and as well can be forwarded etc.

 

For the a.m. video: acutally WMC claims it can not play it...?!? (I just gave it a shot - thought the network-share issue affected the sound-stream.)

Regards!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...