Jump to content

Emby server crashing on new update localhost 8096 error


jimlad

Recommended Posts

Hello,

 

When trying to connect to 

http://localhost:8096/web/library.html

 

This error from the browser (Chrome, running on 10.9.5);

 

This site can’t be reached localhost refused to connect.

ERR_CONNECTION_REFUSED

 

 

Prior to this I had attempted to restart the server and it hung showing a spinning progress wheel. 

I then updated to the latest update and restarted the machine. The server still isn't running.

I took a look at my system crash reports and it showed Emby was crashing, here's the first few lines;

 

/Applications/Emby.Server.Mac.app/Contents/MacOS/Emby.Server.Mac Identifier: com.emby.server Version: 3 (1) Code Type: X86 (Native) Parent Process: launchd [145] Date/Time: 2016-07-08 09:01:21.933 +0100 OS Version: Mac OS X 10.6.8 (10K549) Report Version: 6 Exception Type: EXC_BREAKPOINT (SIGTRAP) Exception Codes: 0x0000000000000002, 0x0000000000000000

 

Working previously, although buggy and I'll report those problems in a separate post.

 

Advice appreciated.

 

Thanks,

 

Jim

Link to post
Share on other sites

Try locationg

 

./users/config/mediabrowser-server/logs

 

or

 

./users/config/emby-server/logs

Link to post
Share on other sites

Try locationg

 

./users/config/mediabrowser-server/logs

 

or

 

./users/config/emby-server/logs

 

It's a mac so there isn't a config folder...? Wouldn't the crash report be logged in the console?

Link to post
Share on other sites

the folder should be there in 

 

/Users/{username}/.config/emby-server

 

or

 

/Users/{username}/.config/mediabrowser-server

Link to post
Share on other sites

server-63603562609.txt

the folder should be there in 

 

/Users/{username}/.config/emby-server

 

or

 

/Users/{username}/.config/mediabrowser-server

Ok, finally managed to find it, thanks. There are several of these files, some are as big as 10.7mb some as small as 70kb attached...

Link to post
Share on other sites

Ok, so you're still running 3.0.5972, which is a version behind. What I would start with is installing the latest release from the website, then we can re-evaluate from there. Thanks.

Link to post
Share on other sites

There's something not right here, I have re-installed the latest version multiple times previously and I've just done it again.

 

I've then tried to open the server app in the applications folder which presumably should run invisibly in the background. I've taken a look at activity monitor to check it was running but I couldn't see it. Trying to access the library in the web browser (Chrome) results in the same error. (This site can’t be reached localhost refused to connect. ERR_CONNECTION_REFUSED).

Link to post
Share on other sites

Ok, so you're still running 3.0.5972, which is a version behind. What I would start with is installing the latest release from the website, then we can re-evaluate from there. Thanks.

 

I've also tried restarting... Any thoughts?

Link to post
Share on other sites

I would try installing the new 3.0.5986 from the website. Thanks.

 

Just tried this again downloading the latest version for OSX and re-installing - same error. Tried restarting no difference.

 

Please advise, thanks.

Link to post
Share on other sites

I appreciate your suggestions so far but I'm struggling a bit with the lack of direct support after paying for the software on both my phone and mac. 

Link to post
Share on other sites

Hi,

Can you please try this version?

 

https://github.com/MediaBrowser/Emby.Releases/raw/master/Server/Emby.Server.Mac.pkg

 

Once installed the version will be 3.0.5990. Please let me know if you see a better result. Thanks!

 

 

I've ran the installer with this version. This makes no difference, I'm not convinced this is even installing properly. There's no sign of anything emby in activity monitor after I launch the emby app...?

Link to post
Share on other sites

Hi, we have a new version on the website, 3.0.6000. I would try that and report back. Thanks!

Link to post
Share on other sites

Hi, we have a new version on the website, 3.0.6000. I would try that and report back. Thanks!

 

Tried it, no difference.

 

How do I get a refund of these apps?

Link to post
Share on other sites

Hello,

 

When trying to connect to 

http://localhost:8096/web/library.html

 

This error from the browser (Chrome, running on 10.9.5);

 

This site can’t be reached localhost refused to connect.

ERR_CONNECTION_REFUSED

 

 

Prior to this I had attempted to restart the server and it hung showing a spinning progress wheel. 

I then updated to the latest update and restarted the machine. The server still isn't running.

I took a look at my system crash reports and it showed Emby was crashing, here's the first few lines;

 

/Applications/Emby.Server.Mac.app/Contents/MacOS/Emby.Server.Mac Identifier: com.emby.server Version: 3 (1) Code Type: X86 (Native) Parent Process: launchd [145] Date/Time: 2016-07-08 09:01:21.933 +0100 OS Version: Mac OS X 10.6.8 (10K549) Report Version: 6 Exception Type: EXC_BREAKPOINT (SIGTRAP) Exception Codes: 0x0000000000000002, 0x0000000000000000

 

Working previously, although buggy and I'll report those problems in a separate post.

 

Advice appreciated.

 

Thanks,

 

Jim

Hi!

If you have installed ESET antivirus, try dissable everything.

Yesterday I installed Emby and worked fine, but since I turned on my imac this morning I had the same problem with localhost.

I've dissabled eset and now works again.

 

I hope this works for you too!!

 

Regards

César

Link to post
Share on other sites

Hi!

If you have installed ESET antivirus, try dissable everything.

Yesterday I installed Emby and worked fine, but since I turned on my imac this morning I had the same problem with localhost.

I've dissabled eset and now works again.

 

I hope this works for you too!!

 

Regards

César

 

Thanks very much for the suggestion, I haven't got any antivirus stuff installed though.

Link to post
Share on other sites

Can you provide an emby server log of the latest version? thanks.

 

 

There is no log in the .config folder as emby is crashing before a log can be created. I've deleted everything and re-installed from the latest version, it didn't help. There's a log in the console which starts like this;

 

Process:         Emby.Server.Mac [71774]

Path:            /Applications/Emby.Server.Mac.app/Contents/MacOS/Emby.Server.Mac

Identifier:      com.emby.server

Version:         3 (1)

Code Type:       X86 (Native)

Parent Process:  launchd [138]

Date/Time:       2016-07-29 00:15:26.661 +0100

OS Version:      Mac OS X 10.6.8 (10K549)

Report Version:  6

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Dyld Error Message:

  Symbol not found: _objc_autoreleasePoolPush

  Referenced from: /Applications/Emby.Server.Mac.app/Contents/MacOS/Emby.Server.Mac

  Expected in: /usr/lib/libobjc.A.dylib

Link to post
Share on other sites

I'm sure emby doesn't want to establish a reputation as a company who takes customers money for software which doesn't work, offers no solutions or refunds and doesn't have a proper support structure in place. 

 

I'm not clear on whether the admin on the forums work for emby directly or indirectly and whether they're involved in the coding of the app.

 

Regardless of that, can you either offer me some sort of direct support to get this fixed asap, or, point me in the direction of a refund for both the phone and server versions. 

Link to post
Share on other sites
Anthony24

Still crashes on my end but not as often and preventing from clicking on the icon at all to keep it running is my only solution, a bug up its configuration I say.

 

And another reason I won't put money into this until it actually works and when i have money myself, bills more important than somthing that's not fully functional

Edited by Anthony24
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...