Jump to content

Multiple playback problems after upgrade


sque
 Share

Recommended Posts

i have been using emby since the begining of this year when I had deployed on a custom NAS that runs OpenMediaVault. In general it rusn wells and even choose to become a supporter. However today when I decided to update OMV and as a consequency Emby was also updated to version 3.0.5972.0 it failed hard. There is no way that I can play any of the stored content.

 

  • Playback through DLNA from my TV (Panasonic with Firefox OS) has become completely unpredictable, it may start playing a file and some point it will skip big portions of the file or jump to the next in queue.
  • Playback through DLNA from Kodi is not working at all. Although it enumerates all the available content, when you start playing a file it pops-up an error.
  • Playback throuhg Firefox 43 on my pc, does not work at all. It looks like someone pressed pause after it started but pushing playback nothing changes. Some other times it pops: "Video Error There was an error playing the video.
  • Using Chromium there is slightly different behaviour where it starts playing a bit and then pops the infamous "Video Error" message.

 

I searched on the logs and I see that transcoding seems to work with ~10x speed and the intermediate file is created. However when I downloaded the temp file at my pc and tried to open with VLC it played only the 6 first minutes with only sound and then stalled for ever. On the server logs I can only find things like:

 

2016-06-19 01:46:55.1926 Error App: Error streaming media. The client has most likely disconnected or transcoding has failed.

 

I am seeking for any kind of help as the downgrade is not an option for me.

 

server.txt

transcode-b2723a4d-c437-45c3-9467-a0e40093e63f.txt

Link to comment
Share on other sites

Hi, right now it looks like mono 4.4 is a bit unstable. I would recommend going back to mono 4.3.2.4.

Link to comment
Share on other sites

EruIluvatar

Let's try again. I seem to have the exact same problem (openmediavault, no playback after upgrade, "Video Error, There was an error playing the video").

For completeness' sake, my log is attached.

 

However I'm not sure how to downgrade mono, "apt-cache showpkg mono-complete" just shows the following.

Which package exactly needs to be downgraded and how?

 

Package: mono-complete

Versions:
4.4.0.182-0beta3 (/var/lib/apt/lists/download.mono-project.com_repo_debian_dists_wheezy_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/download.mono-project.com_repo_debian_dists_wheezy_main_binary-amd64_Packages
                  MD5: dacc30c6a4347277b44c68a99c998d5f
 
2.10.8.1-8+deb7u1 (/var/lib/apt/lists/ftp.ch.debian.org_debian_dists_wheezy_main_binary-amd64_Packages) (/var/lib/apt/lists/security.debian.org_dists_wheezy_updates_main_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/ftp.ch.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
                  MD5: c9e7122ddc88d3f39253c9b5ce49fc27
 Description Language: en
                 File: /var/lib/apt/lists/ftp.ch.debian.org_debian_dists_wheezy_main_i18n_Translation-en
                  MD5: c9e7122ddc88d3f39253c9b5ce49fc27
 
 
Reverse Depends:
Dependencies:
4.4.0.182-0beta3 - mono-runtime (5 4.4.0.182-0beta3) mono-runtime-sgen (5 4.4.0.182-0beta3) libmono-2.0-1 (5 4.4.0.182-0beta3) libmono-profiler (5 4.4.0.182-0beta3) mono-utils (5 4.4.0.182-0beta3) mono-jay (5 4.4.0.182-0beta3) mono-devel (5 4.4.0.182-0beta3) mono-mcs (5 4.4.0.182-0beta3) mono-csharp-shell (5 4.4.0.182-0beta3) mono-4.0-gac (5 4.4.0.182-0beta3) mono-4.0-service (5 4.4.0.182-0beta3) monodoc-base (5 4.4.0.182-0beta3) monodoc-manual (5 4.4.0.182-0beta3) libmono-cil-dev (5 4.4.0.182-0beta3) ca-certificates-mono (5 4.4.0.182-0beta3)
2.10.8.1-8+deb7u1 - mono-runtime (5 2.10.8.1-8+deb7u1) mono-runtime-sgen (5 2.10.8.1-8+deb7u1) libmono-2.0-1 (5 2.10.8.1-8+deb7u1) libmono-profiler (5 2.10.8.1-8+deb7u1) mono-utils (5 2.10.8.1-8+deb7u1) mono-jay (5 2.10.8.1-8+deb7u1) mono-devel (5 2.10.8.1-8+deb7u1) mono-mcs (5 2.10.8.1-8+deb7u1) mono-gmcs (5 2.10.8.1-8+deb7u1) mono-dmcs (5 2.10.8.1-8+deb7u1) mono-csharp-shell (5 2.10.8.1-8+deb7u1) mono-2.0-gac (5 2.10.8.1-8+deb7u1) mono-4.0-gac (5 2.10.8.1-8+deb7u1) mono-2.0-service (5 2.10.8.1-8+deb7u1) mono-4.0-service (5 2.10.8.1-8+deb7u1) monodoc-base (5 2.10.8.1-8+deb7u1) monodoc-manual (5 2.10.8.1-8+deb7u1) libmono-cil-dev (5 2.10.8.1-8+deb7u1)
Provides:
4.4.0.182-0beta3 -
2.10.8.1-8+deb7u1 -
Reverse Provides:
Link to comment
Share on other sites

I found a way to downgrade Mono to version 4.2.4 but still the problems persists. For the shake of completeness, I will write how I downgraded and then I will make a second post with the server logs of all tests.

 

Disable latest Mono version from OMV

Go to OMV Admin panel and follow the menu as "System" -> "OMV-Extras.org" and disable Mono and Mono Testing.

 

Add official Mono snapshot repo for version 4.2

First you need to get ssh access to the OMV instance.

 

Create a new file `/etc/apt/sources.list.d/custom-mono.list` with the following content:

deb http://download.mono-project.com/repo/debian wheezy-libjpeg62-compat main
deb http://download.mono-project.com/repo/debian wheezy-apache24-compat main
deb http://download.mono-project.com/repo/debian wheezy/snapshots/4.2 main

In order to force downgrade you need to Pin this version with higher priority than 1000. This can be done by creating a new file `/etc/apt/preferences.d/99mono-4.2.pref` with the following content

Package: *
Pin: release o=Xamarin, origin download.mono-project.com
Pin-Priority: 1001

Finally to perform downgrade you need to run:

sudo apt-get dist-upgrade
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...
Quasi2

I just upgraded a few days ago and have been looking everywhere for a fix.  My videos play for about twenty seconds and then the dreaded 'Video error.'

There was hope with this post, but alas, no joy.  I downgraded mono to 4.2.4.4 per the above instructions but am still having the problem.

Not sure that this matters but I notice there are two transcode logs for trying to play one video (no previews/trailers).

server log:

 

1st trans log:

 

2nd trans log:
 

Thanks

Link to comment
Share on other sites

I just upgraded a few days ago and have been looking everywhere for a fix.  My videos play for about twenty seconds and then the dreaded 'Video error.'

 

There was hope with this post, but alas, no joy.  I downgraded mono to 4.2.4.4 per the above instructions but am still having the problem.

 

Not sure that this matters but I notice there are two transcode logs for trying to play one video (no previews/trailers).

 

server log:

 

1st trans log:

 

2nd trans log:

 

Thanks

 

That server log still shows mono 4.4.1.

Link to comment
Share on other sites

Quasi2
root@omv:/# apt-cache showpkg mono-complete

Package: mono-complete

Versions:

4.2.4.4-0wheezy1 (/var/lib/apt/lists/download.mono-project.com_repo_debian_dists_wheezy_snapshots_4.2_main_binary-amd64_Packages)

 Description Language:

                 File: /var/lib/apt/lists/download.mono-project.com_repo_debian_dists_wheezy_snapshots_4.2_main_binary-amd64_Packages

                  MD5: dacc30c6a4347277b44c68a99c998d5f

 

2.10.8.1-8+deb7u1 (/var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_binary-amd64_Packages) (/var/lib/apt/lists/security.debian.org_dists_wheezy_updates_main_binary-amd64_Packages)

 Description Language:

                 File: /var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_binary-amd64_Packages

                  MD5: c9e7122ddc88d3f39253c9b5ce49fc27

 Description Language: en

                 File: /var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_i18n_Translation-en

                  MD5: c9e7122ddc88d3f39253c9b5ce49fc27

 

 

Reverse Depends:

Dependencies:

4.2.4.4-0wheezy1 - mono-runtime (5 4.2.4.4-0wheezy1) mono-runtime-sgen (5 4.2.4.4-0wheezy1) libmono-2.0-1 (5 4.2.4.4-0wheezy1) libmono-profiler (5 4.2.4.4-0wheezy1) mono-utils (5 4.2.4.4-0wheezy1) mono-jay (5 4.2.4.4-0wheezy1) mono-devel (5 4.2.4.4-0wheezy1) mono-mcs (5 4.2.4.4-0wheezy1) mono-csharp-shell (5 4.2.4.4-0wheezy1) mono-4.0-gac (5 4.2.4.4-0wheezy1) mono-4.0-service (5 4.2.4.4-0wheezy1) monodoc-base (5 4.2.4.4-0wheezy1) monodoc-manual (5 4.2.4.4-0wheezy1) libmono-cil-dev (5 4.2.4.4-0wheezy1) ca-certificates-mono (5 4.2.4.4-0wheezy1)

2.10.8.1-8+deb7u1 - mono-runtime (5 2.10.8.1-8+deb7u1) mono-runtime-sgen (5 2.10.8.1-8+deb7u1) libmono-2.0-1 (5 2.10.8.1-8+deb7u1) libmono-profiler (5 2.10.8.1-8+deb7u1) mono-utils (5 2.10.8.1-8+deb7u1) mono-jay (5 2.10.8.1-8+deb7u1) mono-devel (5 2.10.8.1-8+deb7u1) mono-mcs (5 2.10.8.1-8+deb7u1) mono-gmcs (5 2.10.8.1-8+deb7u1) mono-dmcs (5 2.10.8.1-8+deb7u1) mono-csharp-shell (5 2.10.8.1-8+deb7u1) mono-2.0-gac (5 2.10.8.1-8+deb7u1) mono-4.0-gac (5 2.10.8.1-8+deb7u1) mono-2.0-service (5 2.10.8.1-8+deb7u1) mono-4.0-service (5 2.10.8.1-8+deb7u1) monodoc-base (5 2.10.8.1-8+deb7u1) monodoc-manual (5 2.10.8.1-8+deb7u1) libmono-cil-dev (5 2.10.8.1-8+deb7u1)

Provides:

4.2.4.4-0wheezy1 -

2.10.8.1-8+deb7u1 -

Reverse Provides:
Link to comment
Share on other sites

Quasi2

**********************************
EDIT:

Boob move.  I didn't stop emby before apt-get dist-upgrade.

Hopefully that saves another noob a few hours of frustration.



I still have a few files that are giving trouble but seems like most are working (4 of 5 tested so far).


 

Edited by Quasi2
Link to comment
Share on other sites

  • 2 weeks later...
dadasaurus

I just wanted to reply that on Debian 8, I was also on mono-complete 4.4.1 and it was very unstable. Rolling back to 4.2.4 appears to have fixed it for me. 

 

Thanks to all who posted in this thread.

Link to comment
Share on other sites

I just wanted to reply that on Debian 8, I was also on mono-complete 4.4.1 and it was very unstable. Rolling back to 4.2.4 appears to have fixed it for me. 

 

Thanks to all who posted in this thread.

 

Awesome, thanks for reporting back. We have a new stable server release rolling out this weekend that we believe resolves all of the Mono 4.4.X issues. Thanks.

Link to comment
Share on other sites

dadasaurus

Awesome, thanks for reporting back. We have a new stable server release rolling out this weekend that we believe resolves all of the Mono 4.4.X issues. Thanks.

 

 

lol, well that was fast... installed build 6000, and upgraded mono back to 4.4.1

 

it appears to have fixed the 4.4.1 instability.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...