Jump to content


Photo

Question about people refresh

Refresh People metadata image task

  • Please log in to reply
33 replies to this topic

#1 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1129 posts
  • Local time: 10:51 AM

Posted 06 June 2016 - 05:15 AM

Version 3.1.10.0

 

this is from running the task, no image and no metadata got neither fetched nor saved to file

2016-06-06 10:35:29.6649 Debug App: Running PersonXmlProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:35:29.6649 Debug App: PersonXmlProvider returned no metadata for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:35:29.6649 Debug App: Running MovieDbPersonProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:35:29.6649 Debug App: MovieDbPersonProvider returned no metadata for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:35:29.6649 Debug App: Running MovieDbPersonImageProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:35:29.6649 Debug App: Running TvdbPersonImageProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:35:29.6649 Debug App: Saving C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh to database.

a manual refresh from the actors detail page got this with all metadata and image saved

2016-06-06 10:58:20.8904 Info HttpServer: HTTP POST http://localhost:8096/emby/Items/0daec7038d6e39ab484e93f3e47d2055/Refresh?Recursive=true&ImageRefreshMode=FullRefresh&MetadataRefreshMode=FullRefresh&ReplaceAllImages=false&ReplaceAllMetadata=true. UserAgent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
2016-06-06 10:58:21.0292 Debug App: Running MovieDbPersonProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:58:21.0292 Info HttpClient: HttpClientManager GET: https://api.themoviedb.org/3/search/person?api_key=***APIKEY***&query=Neve+McIntosh
2016-06-06 10:58:21.4019 Info HttpServer: HTTP Response 204 to ::1. Time: 512ms. http://localhost:8096/emby/Items/0daec7038d6e39ab484e93f3e47d2055/Refresh?Recursive=true&ImageRefreshMode=FullRefresh&MetadataRefreshMode=FullRefresh&ReplaceAllImages=false&ReplaceAllMetadata=true
2016-06-06 10:58:21.9625 Info HttpClient: HttpClientManager GET: https://api.themoviedb.org/3/person/120895?api_key=***APIKEY***&append_to_response=credits,images,external_ids
2016-06-06 10:58:22.1609 Debug App: Running PersonXmlProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:58:22.1609 Debug App: PersonXmlProvider returned no metadata for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:58:22.1609 Debug App: Running MovieDbPersonImageProvider for C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh
2016-06-06 10:58:22.2160 Debug ProviderManager: Saving C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh to Emby Xml.
2016-06-06 10:58:22.2290 Debug App: Saving C:\Users\***USER***\AppData\Roaming\Emby-Server\metadata\People\N\Neve McIntosh to database.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 06 June 2016 - 12:08 PM

There's no problem here - the task is only looking for changes since the last time it was run. We can't hit TheMovieDb for all of your people every single time it runs.



#3 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1129 posts
  • Local time: 10:51 AM

Posted 06 June 2016 - 12:43 PM

so when are people information fetched ? only on the first time they appear in a new file ?



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 06 June 2016 - 12:47 PM

The first time and then periodically after that.



#5 jscoys OFFLINE  

jscoys

    Advanced Member

  • Members
  • 1195 posts
  • Local time: 04:51 AM

Posted 06 June 2016 - 01:04 PM

I noticed a weird phenomena. I had an actor not appearing into ET... I thought in a first time that it was a movie data fetch problem... And then I saw it in the web view... I then remembered people without pictures are not displayed in ET (design concerns...)... So went on the actor page ask for a refresh and then image was downloaded! Well done... But I assure you that this guy was there since the last time I reinstalled my server (4 months ago if I remember well). So I suspect that all images are not downloaded correctly.

I know there is a bandwidth increase for information providers. Is it possible to at least make a little test to see if picture is available locally and if there is one on the server each time a people refresh command is launched, without downloading the picture of course? If the picture is not there it Will download it. At least, we'll be sure all pictures are present and if it is already there it Will not download it, so bandwidth limits are correctly respected?


Sent from my iPhone using Tapatalk

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 06 June 2016 - 01:11 PM

We do already check for local people images.



#7 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1129 posts
  • Local time: 10:51 AM

Posted 06 June 2016 - 01:21 PM

The first time and then periodically after that.

 

any further informations on "periodically" ?


  • NANO SHELL likes this

#8 NANO SHELL OFFLINE  

NANO SHELL

    Advanced Member

  • Members
  • 84 posts
  • Local time: 06:51 PM
  • LocationAUSTRALIA

Posted 07 June 2016 - 01:59 PM

I myself sought of have this issue. I have plenty of actors/actresses with only a name. No picture, bio or links to TheMovieDb/IMDB. Any idea on how often it pulls data from 'TheMovieDb/IMDB' and how to make it run as it does not do it for every person I have.

Attached Files


  • jscoys likes this

#9 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1129 posts
  • Local time: 10:51 AM

Posted 07 June 2016 - 06:21 PM

that's the exact reason why i started this


  • jscoys likes this

#10 daedalus OFFLINE  

daedalus

    Advanced Member

  • Members
  • 1129 posts
  • Local time: 10:51 AM

Posted 20 June 2016 - 02:20 AM

anything ?



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 20 June 2016 - 02:28 AM

for each person individually it's every 30 days



#12 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15617 posts
  • Local time: 01:51 AM
  • LocationWashington State

Posted 20 June 2016 - 04:47 AM

So would clearing the tmdb-people cache force a full refresh?



#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 20 June 2016 - 11:56 AM

No. Person metadata is fully downloaded the first time an actor is added to your library, and every 30 days after. For in between you can refresh a person manually.



#14 gnollo OFFLINE  

gnollo

    Advanced Member

  • Members
  • 181 posts
  • Local time: 09:51 AM

Posted 09 January 2017 - 12:43 PM

I have not seen pictures for actors since I did a clean install of the Emby server to fix issues with loading the hompage taking forever.

If it was periodically running I should have some pictures but I have none by default.

I noticed that if I click on an actor, it then downloads the picture, but I cannot find it in either

 

C:\Users\XYZ\AppData\Roaming\Emby-Server\ImagesByName\People

 

or 

 

C:\ProgramData\MediaBrowser\ImagesByName\People\

 

Which is where my MCM is downloading actor's pictures. 

Where are the actors picture I download by clicking on them actually going?

If I copy all of my actors picture in that folder, should the system understand that the pictures are there and show them in the UI? I use Theater by the way.

 

I am running Version 3.1.270.0 beta of the server.



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 09 January 2017 - 02:08 PM

Hi @gnollo, the front page of the Emby Server dashboard shows your metadata path. The People folder goes underneath that. Let us know if this helps. thanks !



#16 Abobader OFFLINE  

Abobader

    Super-Tester

  • Administrators
  • 9401 posts
  • Local time: 11:51 AM

Posted 09 January 2017 - 04:38 PM

Good day,

 

IBN (ImagesByName) folder not supported anymore, as Luke said, click on "path" at the emby server dashboard and will find.

 

Simply see the path and copy the alphabetic folders to People top folder and then run the task for it.

 

My best



#17 gnollo OFFLINE  

gnollo

    Advanced Member

  • Members
  • 181 posts
  • Local time: 09:51 AM

Posted 09 January 2017 - 08:14 PM

Thanks guys, found the path (I was looking for it in the metadata settings!), and low and behold it was neither of the folders.

It was a folder with images I set up years ago, which still has all of the actors in the root level.

I copied all of the actors beginning with T as a test, and I can immediately see the actor picture appear as soon as the picture is saved in the folder.

I will merge the three actor directories into the path one, so the situation should improve.

I tend to save all metadata using MCM first, I wonder if there is a way to scan the whole library with MCM but change nothing in the folders where movies and tv series are saved, only update the people folders. This would go around the refresh people process.



#18 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15617 posts
  • Local time: 01:51 AM
  • LocationWashington State

Posted 09 January 2017 - 08:25 PM

Thanks guys, found the path (I was looking for it in the metadata settings!), and low and behold it was neither of the folders.

It was a folder with images I set up years ago, which still has all of the actors in the root level.

I copied all of the actors beginning with T as a test, and I can immediately see the actor picture appear as soon as the picture is saved in the folder.

I will merge the three actor directories into the path one, so the situation should improve.

I tend to save all metadata using MCM first, I wonder if there is a way to scan the whole library with MCM but change nothing in the folders where movies and tv series are saved, only update the people folders. This would go around the refresh people process.

Sorry, but no.  You would have update the path in MCM and re-fetch your entire library.



#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 04:51 AM

Posted 09 January 2017 - 11:03 PM

@gnollo the question of where the images are was answered in post #15

#20 gnollo OFFLINE  

gnollo

    Advanced Member

  • Members
  • 181 posts
  • Local time: 09:51 AM

Posted 11 January 2017 - 02:48 AM

@gnollo the question of where the images are was answered in post #15

 

Got that, thank you I found the folder thanks to your post.

I just wonder how the actors get into the movie layout. For example I added recently a movie to my library, did the MCM scan and saved movie.xml.

The folder gets scanned in by emby, I can see the movie in the library with description and actors. I check one of the actors names in all my folders, and can't find it, but I can see it in the window.

If I click on it, the picture gets downloaded, and I can now see a folder in the path selected in the emby server configuration window.

Why was the actor folder not there before?


Edited by gnollo, 11 January 2017 - 02:49 AM.






Also tagged with one or more of these keywords: Refresh People, metadata, image, task

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users