Jump to content

DLNA and DLNA "Play To" device detection


Quiffster
 Share

Recommended Posts

DLNA too unreliable now....

 

I've been a user of Emby for a long long time since the old Windows Media Centre MB add-in days.  Back then i would use Serviio for DLNA, and MB3 for windows home theatre.  But once MB got DLNA to a pretty mature state, i turned Serviiio off, and settled for MB/Emby (even though it still doesn't handle playing music well to older devices).

 

On my Samsung TV's - i use the Samsung Emby app - its great, lovely interface, streams well, works pretty well most of the time.  However for all my other devices including our main LG TV, and the kids Sony Bravia's - We've always used the Emby Android app - and 'Play to' DLNA functionality.

 

Until recently anyway...  I cannot recall when - but somewhere around Feb/March this year - there was a release which changed the DLNA code  to such a degree that it now renders Emby useless for all my non-Samsung App devices.

 

1.  "Play To" hasn't worked for many months, and there is evidently some kind of issue which is not with my home setup.  For example, when using the android app, if i choose my LG TV as the Play To device, then select some media - the little green "Play" arrow doesn't even appear.  On other occasions, when it does appear - pressing it just does nothing - no error - no nothing.

 

2.  Normal DLNA use:  This has been intermittent between releases.  Most often the Emby server doest appear as a server on the TV's DLNA server list.  For a few releases - the server appears, and can sometimes make it all the way through a tv show without dropping off with a server error, and not appearing in the list again.....

 

Interestingly, i did find that after every server update - if i go into the DLNA devices list in the web admin, and delete every device listed - i can often get the Emby server to re-appear on the TV's.  (PS - a delete all button would be a great addition to that config tab).

 

So... as of 3.0.5980, and with a full delete of all the "Devices" from Emby - Play To predictably still doesn't work, but at least the server shows up on the LG again - and I'll set the family down to watch a movie..

 

I'm happy to supply log files etc, but it feels like a point solution or identification to what i suggest is a more fundamental problem with a code change way back earlier this year.

 

I'd also consider going back to an old release from say Dec 2015 (is that possible by the way), but i'm worried that a recent database change / upgrade would mean that that isn't possible??

 

Until then, I'll keep my fingers crossed and upgrade every time a release comes out, in the hope the issue gets sorted....

 

 

If anyone else is suffering the same problem - perhaps you could Like or follow the posts and we can see if this is more pervasive than just the odd system with a error..

Link to comment
Share on other sites

There latest version of the server should resolve the play to discovery issues

Link to comment
Share on other sites

  • 1 year later...

I am facing the same problem. Suddenly, starting in mid 2016, Emby got so unrelieable that it won't get detected by other devices for hours.

I have switched from Ubuntu Server to Fedora Sever recently. This did not improve anything. In fact, it took a while to get everything working at all since Emby doesn't ship with any firewalld rules.

The Panasonic DVR shows up all the time. So it is certainly no network issue. They are both in the same subnet (10.0.0.x).

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...