Jump to content


Photo

Relink people to movies

Refresh People Actors Link

  • Please log in to reply
6 replies to this topic

#1 Hedwig OFFLINE  

Hedwig

    Advanced Member

  • Members
  • 58 posts
  • Local time: 06:10 PM
  • LocationBelgium - Dutch

Posted 27 April 2016 - 10:55 AM

Relink people to movies...

I have a lot of movies where the link between the actors and their movies got broken.
I did many manual corrections but the problem keeps coming back, even on the ones that had a manual correction.

People do exist in the Metadata/People folder but their names do not appear in the People Section of the movie.
After a refresh of that particular movie the link comes back for that one movie.
Refreshing People via dashboard does not help either.

Is there a way to refresh the full database in one operation?



#2 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44785 posts
  • Local time: 12:10 PM

Posted 27 April 2016 - 10:58 AM

The association of people to movies is within the metadata for the movies.

 

First, I'd make sure you don't have an external program modifying your movie metadata and causing this problem.

 

Then, you can do a refresh from the library level and wait for them all to be updated.


  • jscoys likes this

#3 Hedwig OFFLINE  

Hedwig

    Advanced Member

  • Members
  • 58 posts
  • Local time: 06:10 PM
  • LocationBelgium - Dutch

Posted 28 April 2016 - 07:44 AM

I keep all metadata in the Emby folders and not in the moviefolders themselves.

 

Where do I find that Refresh button in the library section ? Is it possible to do a full refresh for a particular library?



#4 ebr ONLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 44785 posts
  • Local time: 12:10 PM

Posted 28 April 2016 - 09:08 AM

Go to home screen on web client and hover over the library in question.  Select '...' menu and select 'Edit'.  Then '...' menu again and 'Refresh'.  Go have a coffee...



#5 Hedwig OFFLINE  

Hedwig

    Advanced Member

  • Members
  • 58 posts
  • Local time: 06:10 PM
  • LocationBelgium - Dutch

Posted 28 April 2016 - 11:23 AM

Had not enough time for a coffee ... a full refresh only took a few seconds on a library of 2600 movies.

 

Nothing changed in the association of people...

 

I hope I hit the right spots (look at the screen below)

 

 

 

 

 

Attached File  Refresh.jpg   21.7KB   7 downloads



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 128939 posts
  • Local time: 12:10 PM

Posted 28 April 2016 - 12:00 PM

That's not true. A full refresh takes a long time. the issue is that there is currently no way to monitor the progress of it in the web interface, why is why you're thinking that. Unfortunately you can only really know that it's done once the refreshes stop getting added to the server log. best thing to do until we have in-app monitoring is just let it go overnight.



#7 Hedwig OFFLINE  

Hedwig

    Advanced Member

  • Members
  • 58 posts
  • Local time: 06:10 PM
  • LocationBelgium - Dutch

Posted 29 April 2016 - 06:37 AM

Ok, I see - thanks Luke.

 

That means that the server log should grow in bytes all the time it takes to accomplish the task.

 

I will give it a try and let you know.







Also tagged with one or more of these keywords: Refresh, People, Actors, Link

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users