Jump to content


Photo

Video Lenght Wrong (Huge Episode Duration)

runtime lenght huge metadata

  • Please log in to reply
6 replies to this topic

#1 joaodaher OFFLINE  

joaodaher

    Newbie

  • Members
  • 1 posts
  • Local time: 10:49 PM

Posted 05 April 2016 - 06:20 PM

I have just finished setting up my Emby server for the first time, and I'm loving it!

But I'm facing an issue: all my videos are showing a very very long duration (length).

The files are all in individual folders, with no metadata file in it. Emby accessed all the content and downloaded artworks fine.

As I've read, video length is extracted (and is ignored from <runtime> inside a .nfo file).

The major issue is that during playback I can't skip the video, since the bar is way too long.

Most of videos are .mkv, but the issue is present in other filetypes too.

 

What I've tried (and had no success):

- Refreshing library;

- Refreshing individual metadata in the Metadata Manager;

- Completely reinstalling Emby Server;

- Forcing a <runtime> tag in the video NFO file;

- Installing stable, beta and dev releases.

 

Anyone had the same problem or have any idea how can I solve this?

 

57043820203d9_lenght_worng.png



#2 Pais OFFLINE  

Pais

    Advanced Member

  • Members
  • 216 posts
  • Local time: 09:49 PM

Posted 05 April 2016 - 06:44 PM

Can you post the media info?



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135803 posts
  • Local time: 09:49 PM

Posted 05 April 2016 - 09:32 PM

Hi, welcome. Yes that does look wrong. We don't use media info from nfo files, instead we use ffprobe and extract the information on our own. I am also curious to see what media information we were able to extract so please provide that. If we really can't find an answer then I might need a sample file. thanks.



#4 werkas OFFLINE  

werkas

    Newbie

  • Members
  • 2 posts
  • Local time: 03:49 AM

Posted 29 June 2016 - 12:51 PM

Ran into the same problem today.

This seems to affect most of my video files, but interestingly not all of them.

 

From what I've gathered, there seems to be a discrepancy between the way the runtime is listed for the correct and incorrect length.

 

I'm guessing that the "wrong" video length/runtime is actually correct, but in the wrong format (possibly ticks instead of minutes).

If you simply "cut" the last 6 digits of the super-long runtime, you get the approximate length in minutes.

 

You can probably calculate it exactly, but it was easier comparing that approximate with the actual runtime when opening the file in an external player.

 

Hoping that this info sheds some light on the problem.

If there is anything else I can do to help, please let me know.

 

 

PS: I did try exchanging my ffprobe for a new version in addition to the things joaodaher tried, but that didn't change anything. New items would still get listed with runtimes in the millions.

PPS: Running Emby 3.1.44.0 on Win7 SP1


Edited by werkas, 29 June 2016 - 12:52 PM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135803 posts
  • Local time: 09:49 PM

Posted 29 June 2016 - 12:54 PM

can you provide a sample video? thanks.



#6 werkas OFFLINE  

werkas

    Newbie

  • Members
  • 2 posts
  • Local time: 03:49 AM

Posted 29 June 2016 - 02:20 PM

57740eb86548e_xfiles_runtime.png

 

Sample video/corresponding file to above screenshot attached to this post (in .7z archive format, as I wasn't able to upload the unpacked file, even after renaming the extension).

The video file plays for 48s in MPC-HC, and Win7 shows the length as 0m47s.

Media Info in MPC-HC says: Duration: 47s 744ms.

Multiplying .795733 with 60 gives 47,74398.

My final guess is that the last six digits are the remaining seconds of the runtime, expressed in ticks, with the actual runtime in minutes being prepended, or something along those lines...

Attached Files



#7 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15313 posts
  • Local time: 06:49 PM
  • LocationWashington State

Posted 29 June 2016 - 02:52 PM

Hmm, added attached file to beta v3.1.45.0

 

577418e9cb0ee_test.jpg


Edited by Happy2Play, 29 June 2016 - 02:54 PM.






Also tagged with one or more of these keywords: runtime, lenght, huge, metadata

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users