Jump to content

Bug fetching metadata for TV series


anderbytes
 Share

Go to solution Solved by Luke,

Recommended Posts

anderbytes

@@ebr and @@Luke,

Since latest stable a few days ago, I've been having problems downloading metadata for TV series.

 

Movie metadata is downloaded correctly from TMDB, but when an episode of anything is searched, it doesn`t find anything anywhere, and the easier way to see the result of that is that the episode title becomes exactly the media filename.

 

Here's the part of the log where it tries to search for episode metadata

2016-03-28 22:07:24.0516 Info HttpServer: HTTP POST https://server.mynas.com:8920/emby/Items/00465cf143c89d390a7aa97082201cae/Refresh?Recursive=true&ImageRefreshMode=FullRefresh&MetadataRefresh$
2016-03-28 22:07:24.1896 Debug App: Running FFProbeProvider for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.WEBDL-72$
2016-03-28 22:07:24.1955 Debug MediaEncoder: /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/emby/ffmpeg/20160215/ffprobe -i file:"/media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/$
2016-03-28 22:07:24.3499 Debug App: Running TvdbEpisodeProvider for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.WEBD$
2016-03-28 22:07:24.3513 Debug App: No series identity found for The.Walking.Dead.S06E15.East.WEBDL-720p.x264.AAC-DeeJayAhmed
2016-03-28 22:07:24.3513 Debug App: TvdbEpisodeProvider returned no metadata for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06$
2016-03-28 22:07:24.3513 Debug App: Running MovieDbEpisodeProvider for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.W$
2016-03-28 22:07:24.3539 Debug App: MovieDbEpisodeProvider returned no metadata for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.$
2016-03-28 22:07:24.3539 Debug App: Running EpisodeNfoProvider for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.WEBDL$
2016-03-28 22:07:24.3556 Debug App: EpisodeNfoProvider returned no metadata for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E$
2016-03-28 22:07:24.3556 Debug App: Running EpisodeXmlProvider for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.WEBDL$
2016-03-28 22:07:24.3566 Debug App: EpisodeXmlProvider returned no metadata for /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E$
2016-03-28 22:07:24.3934 Debug ProviderManager: Saving /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.WEBDL-720p.x264.A$
2016-03-28 22:07:24.4137 Debug App: Saving /media/f32939a5-f612-4c8d-aa32-3ae82b0f0742/DISK/REPOSITORY/SERIES/The Walking Dead/Season 6/The.Walking.Dead.S06E15.East.WEBDL-720p.x264.AAC-DeeJayAhm$

I need to remind you that:

1. Because I'm in OMV I couldn't participate in Beta, so this could have passed (only possible after Mono packages will be available for Betas)

2. My metadata configurations are set to download Portuguese (Brazil) info

 

Before latest 5910... if no metadata for my exact country is found, it would fall back to english.

 

Another detail is... before 5910, correct metadata translated for my country was being downloaded, or maybe it was pt-PT and I didn`t noticed the difference (I would have to dig deeper in providers to confirm that)

 

Expected when trying to download TV metadata:

1. Download my country's metadata from any provider, or else

2. Download pt metadata from any provider, or else

3. Download English metadata from any provider

Edited by anderbytes
Link to comment
Share on other sites

anderbytes

I'm in 5911 already... I always update to the latest stable available before reporting any bugs.

 

I mentioned 5910 in the post above but it was because I forgot the number 5911... for some reason 5910 was easier to remember.

Link to comment
Share on other sites

  • Solution

for those episodes, check the series metadata, make sure there is a tvdb id, or just refresh the whole series.

  • Like 1
Link to comment
Share on other sites

anderbytes

CONTENT REMOVED BY MYSELF

Edited by anderbytes
Link to comment
Share on other sites

anderbytes

for those episodes, check the series metadata, make sure there is a tvdb id, or just refresh the whole series.

 

Will try but.... Not even trying to "Identify" manually returns anything... is that a clue?

Link to comment
Share on other sites

anderbytes

The episode.

 

 

But I have a good update here: I did series refresh, episode refresh, series full refresh, episode full refresh, full series refresh from metadata manager.... and one of these did the trick.

 

The metadata is coming in English... but that may be a problem of incomplete metadata in provider, that I can manually fill.

 

Thanks for the "try-the-whole-series-refresh". Didn't know it could be that

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...