Jump to content

Direct Play setup


rcarteraz
 Share

Go to solution Solved by Angelblue05,

Recommended Posts

So, I know this has been posted before but I can't for the life of me get this to work. I'm hoping someone could help me out. I have all my media on V:\ (V:\Movies and V:\TV Shows) which is two drives pooled together. I can access everything just fine through Kodi from my Fire TV it just doesn't direct play. I want it to direct play and can't seem to get that to work. What would be the proper way to configure the server and add-on to allow for direct play?

Link to comment
Share on other sites

Make sure you libraries are set up on your server pointing to UNC paths (rather than direct drive paths) or use path substitutions.

  • Like 1
Link to comment
Share on other sites

Make sure you libraries are set up on your server pointing to UNC paths (rather than direct drive paths) or use path substitutions.

 

I'm sorry.. I'm not sure how to do that....  :wacko:

Link to comment
Share on other sites

Angelblue05

Looks formatted correctly. If you try to access the end path (\\192.168.0.8\Movies), does it work? 

 

Note, you could have also done From: V:\ To: \\192.168.0.8\

  • Like 1
Link to comment
Share on other sites

Looks formatted correctly. If you try to access the end path (\\192.168.0.8\Movies), does it work? 

 

Note, you could have also done From: V:\ To: \\192.168.0.8\

When I access it via the browser on my computer it doesn't show the file list....

 

 

Oh.. I'll do that then, seems easier.

 

Now for the add-on side what do I need to configure to ensure it see this correctly?

Link to comment
Share on other sites

Angelblue05

Ok, so give it a try in Kodi, make sure the emby add-on settings > playback > play from http instead of smb is disabled. Let me know :)

  • Like 1
Link to comment
Share on other sites

Ok, so give it a try in Kodi, make sure the emby add-on settings > playback > play from http instead of smb is disabled. Let me know :)

 

Okay, still says it's unable to direct play. 

 

My computer that I'm running the server from has a username and password. Does that need to be configured in the add-on at all?

Link to comment
Share on other sites

Angelblue05

Yes, add-on settings > playback > Network credentials

 

For server, you'd put the ip, so it matches your paths. Then username and password, restart Kodi. Make sure the setting play from http is still disabled. :)

  • Like 1
Link to comment
Share on other sites

Yes, add-on settings > playback > Network credentials

 

For server, you'd put the ip, so it matches your paths. Then username and password, restart Kodi. Make sure the setting play from http is still disabled. :)

 

Just to clarify the ip it should be \\192.168.0.8\ as it is under Path Substitution? Then same id and password for the computer?

  • Like 1
Link to comment
Share on other sites

  • Solution
Angelblue05

Correct (drop the slashes). This is so Kodi can access your shares over the network. You want to enter the windows credentials where your content is located.

Edited by Angelblue05
  • Like 1
Link to comment
Share on other sites

Correct (drop the slashes). This is so Kodi can access your shares over the network. You want to enter the windows credentials where your content is located.

Okay, I'm going crazy.. It still failed. I've done everything exactly as shown....

Link to comment
Share on other sites

Correct (drop the slashes). This is so Kodi can access your shares over the network. You want to enter the windows credentials where your content is located.

Wait... So instead of \\192.168.0.8\ just use 192.168.0.8?

 

 

 

Okay, dropped the slashes... And I'm pretty sure it's working now. Tried 3 different videos, no failed message and no message saying it's going to play via HTTP. THANK YOU!!!!

Edited by rcarteraz
  • Like 1
Link to comment
Share on other sites

Angelblue05

Sorry, I saw that you had slashes in there, I thought I edited my post quickly enough :(

 

Glad you got it working, to confirm, you can check your emby dashboard and mouseover the kodi device while you are playing something.

  • Like 1
Link to comment
Share on other sites

Sorry, I saw that you had slashes in there, I thought I edited my post quickly enough :(

 

Glad you got it working, to confirm, you can check your emby dashboard and mouseover the kodi device while you are playing something.

Yup, shows as direct playing. Appreciate it very much!

 

Also, I just added your extension to Chrome. It's pretty cool! I'll be sure to thank you for your time tomorrow when I get paid.

  • Like 2
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...