Jump to content

Emby Not playing full 5.1


Recommended Posts

I have always used chrome in the past to access my media and played content via the browser.  Just noticed today that I'm not getting surround sound.  I spent a lot of time updating drivers, messing with settings etc.  It works fine when watching movies from my cable provider.  Finally narrowed it down to chrome and firefox.  Using IE I can hear sound on my surround speakers.

 

I have an AMD Radeon HD 5500 video card with HDMI out to my AVR, so it handles audio.  Running Win 8.1.  If I go into my windows sounds configuration it is set to 5.1 and the test sounds each speaker.

 

Also if I play using an external player like MPC-HC, sounds work in all speakers.

 

So not sure what is going on now.

 

Any ideas?

 

Is there a better way/experience to view movies on my main media PC?  Several years ago I used to use media browser theater I think it was, but switched to a browser which was easier to use for navigating etc with a wireless KB/Mouse.  

 

Thanks

 

Link to post
Share on other sites

Hi there, welcome. In order to best help you, please see how to report a media playback issue. Thanks!

Anyway to share my logs with just admins or a support person?  I don't really want to just post my server logs out here for any and everyone to be able to grab.  The logs contain all kinds of info on my internal network, what is on it, what it sees, how my server is configured etc.  Pretty much a security no no.

 

Thanks

Link to post
Share on other sites

This is happening in chrome because we are transcoding the audio to mp3, and libmp3lame has a limitation of only supporting 2 channels. We used to encode to aac and that does support surround, but with recent ffmpeg updates we've noticed popping and distortions in the transcoded aac audio. That pretty much forced us to use mp3. With each new ffmpeg update we are retesting to see if it's still necessary. Note that other apps can handle additional audio formats and thus don't suffer from this limitation.

Link to post
Share on other sites

 

Is there a better way/experience to view movies on my main media PC?  

 

 

The new Emby Theatre is a great solution for a Media PC - it's mouse support is very good.

 

You could also try the MPC-HC remote app - which runs in the tray and causes MPC-HC to be launched when you click play in the WebUI.

 

Another option is to use EMC (the Emby Media Center plugin) assuming you already have Windows Media Center or you're willing to install the patched version onto Windows 10.

  • Like 1
Link to post
Share on other sites

This is happening in chrome because we are transcoding the audio to mp3, and libmp3lame has a limitation of only supporting 2 channels. We used to encode to aac and that does support surround, but with recent ffmpeg updates we've noticed popping and distortions in the transcoded aac audio. That pretty much forced us to use mp3. With each new ffmpeg update we are retesting to see if it's still necessary. Note that other apps can handle additional audio formats and thus don't suffer from this limitation.

Just want to mention that it is happening in Firefox too.  Bummer, pretty much don't ever use IE.

 

Thanks for looking at my logs though, hopefully a near update will get things back to working.

Link to post
Share on other sites

The new Emby Theatre is a great solution for a Media PC - it's mouse support is very good.

 

You could also try the MPC-HC remote app - which runs in the tray and causes MPC-HC to be launched when you click play in the WebUI.

 

Another option is to use EMC (the Emby Media Center plugin) assuming you already have Windows Media Center or you're willing to install the patched version onto Windows 10.

I may try Emby Theatre again, I used it a year or so ago when I first go Mediabrowser back then.  

 

I do use MPC-HC remote app sometimes.  The issue with that is that it never stays connected even though I leave my HTPC logged in and browser open.  I mean I can select MPC chromecast as the player and watch some shows, but if I don't use it for a few hours, over night etc I always have to select it again.

 

Not running WMC and not really an option for me.  Never like the one with Win 7, not sure if it ever improved with Win 8 or 10.  Using Chrome just worked best for my needs.

 

Thanks

Link to post
Share on other sites

 

Not running WMC and not really an option for me.  Never like the one with Win 7, not sure if it ever improved with Win 8 or 10.  Using Chrome just worked best for my needs.

 

 

WMC is basically identical as on Win 7 - but once you're in EMC you get the Emby experience. The default Chocolate theme is really nice

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...