Jump to content
Tanamur

ANSWERED Rush Theme: Extender Display Issues

Recommended Posts

Tanamur
MBServer: Version 3.0.5083.27698
MBClassic: Version 3.0.100.0 B12-4.1
MBTheater: Not installed
PC Server OS: Windows 7 Home Premium 64-bit SP1
Codecs: Nothing other than installed with Win7 out of the box and MBServer
Extender:  HP MediaSmart Connect x280n
Theme: Rush with Color Scheme: Extender_Black

 

Hi @@Soultaker - I quite like the Rush theme and really appreciate you have created a theme with extenders in mind.

 

I am having a few display problems which I have highlighted in the red boxes on the photos below and would be interested in any suggestions you may have to correct them.

 

Also regarding the multi-colored media info icons you are using here, is that a custom set and where would I obtain and I install them in the IBN folder.

 

52ae440175add_IMG_20131216_072223.jpg52ae441cb3611_IMG_20131216_072357.jpg52ae442f3fd46_IMG_20131216_072417.jpg52ae443b80998_IMG_20131216_072616.jpg

 

Thanks for the great work and support, Tanamur

Share this post


Link to post
Share on other sites
yardameus

Thought I knew it all, just figured it out a few months ago, no problem man.  The dark icons are awesome with Rush.  Wish I could help with the extender issues....

Share this post


Link to post
Share on other sites
Soultaker

Hi there,

 

I have done all my testing with my Xbox 360 as an extender. Unfortunately I don't have a HP MediaSmart Connect x280n extender to test on.

 

1. Does Rush appear fine if run from your PC?

 

2. Are you using any overscan settings (OverScanScaling, OverScanPadding) and if so what values?

 

 

I will investigate further...

Edited by Soultaker

Share this post


Link to post
Share on other sites
Tanamur

Hi there,

 

I have done all my testing with my Xbox 360 as an extender. Unfortunately I don't have a HP MediaSmart Connect x280n extender to test on.

 

1. Does Rush appear fine if run from your PC?

 

2. Are you using any overscan settings (OverScanScaling, OverScanPadding) and if so what values?

 

 

I will investigate further...

Hiya @@Soultaker - Thanks for the quick response and I know I am probably hanging on to this extender a bit past its time but it is a nicely built unit.

 

I did have to adjust the (OverScanScaling, OverScanPadding) for the x280n for all themes I was testing and tweaked it to:

<OverScanScaling>
    <X>1</X>
    <Y>1</Y>
    <Z>1</Z>
  </OverScanScaling>
  <OverScanPadding>
    <Bottom>-45</Bottom>
    <Left>-75</Left>
    <Right>-75</Right>
    <Top>-45</Top>
  </OverScanPadding>

For this follow-up, I returned the settings to their original state of 0 and took a couple of photos (top row) to show you the difference. It did not have any noticeable effect on the theme display issues. Rush looks great on the HTPC (bottom row). Thanks for having a look at the options:

 

52aec8f9c8bd7_IMG_20131216_171006.jpg52aec9089f256_IMG_20131216_171049.jpg

52aec91ebb36d_IMG_20131216_HTPC.jpg52aec92c3fb32_IMG_20131216_HTPC2.jpg

 
Cheers, Tanamur

Share this post


Link to post
Share on other sites
Soultaker

Hi

 

Thanks to your response I now know what the issues are. Unfortunately it's a hardware/software issue with the low-fidelity extenders and the optimizations that have been made so that these (under-powered) platforms remain usable. I'm currently at work but give me a day or two as I have some ideas on tricks (hacks) that may workaround the lack of rendering capability on low fidelity extenders.

 

-ST

Share this post


Link to post
Share on other sites
Soultaker

@@Tanamur Hey dude might want to checkout the new release of Rush

 

 

v0.12.16.0 (for MBC 3.100)

  • Added config override for low fidelity extenders. This reduces graphical intensity so that these platforms can handle the theme. Not recommended for XBox360 Extenders or HTPC users.
  • Moved chapter time to top right.

 

rush-low-fidelity.jpg

Edited by Soultaker
  • Like 1

Share this post


Link to post
Share on other sites
Tanamur

Hey @@Soultaker - Well that is just an impressive piece of work, not to mention fast, especially since you don't have an x280n to test it on yourself and are relying on "shaky-cam" photos from me for feedback. Mate this v0.12.16.0 (for MBC 3.100) looks so good on my extender with working (green arrow) 1) blue halo selection border, 2) rounded box list selection border, 3) count tab gap fixed, 4) clearart still utilized, and 5) multi-colored media info icons. I was going to ask you how to turn off the blue background on the synopses...now I don't have to. Check out the photos...

 

Could you please have a look at the time tab (red box in photos) in the upper right as there still seems to be a gap there like you already fixed on the count tab.  

 

Also, there is just one item possibly unrelated to themes I would appreciate your feedback on. It first appears on the MB3 flash screen when it is started from Media Center, then the splash screen seems to fail all together. This happens on all themes. The underscan/overscan border (pre-theme loading) seems to be unaffected by the extender specific MBCommonXml.config file. The reason I mention it is because it also affects the full screen weather panel in the Rush theme and the general configuration screens for all themes.

 

Previously, when I was first attempting to adjust the overscan/underscan issue by editing the registry, I know I managed to change something that caused this to stop and display properly. I don't think the animated dots worked but the splash screen display did not have a blue border. 

 

Many thanks again. My personal tastes go toward a simple, clean, presentation of my choices. I am not a big backdrop fan. I really like the small, bright green checkmark/text in the lower right for viewed & future status.

 

Cheers, Tanamur

 

52afa2695e998_20131217072759.jpg52afa27852825_20131217072947.jpg52afa28942c87_20131217073017.jpg52afa297bb7df_20131217073712.jpg52afa2b554cfb_20131217080627.jpg52afa2c544858_20131217080632.jpg52afa2d2db65d_20131217074232.jpg52afa2e129ddb_20131217073945.jpg

Share this post


Link to post
Share on other sites
Soultaker

Hey

 

First I'm glad most of the show stoppers were dealt with it was quite tricky writing fixes without actually testing them. I forgot about the clock panel so I'll sort that out in a later release.

 

The MBC Splash screen does not appear to support overscan settings, this is a core MBC issue probably need to talk to ebr about this. The general config area suffers from the same behaviour.

 

The rush weather page has the same problems, but that is one that I can tackle.

Share this post


Link to post
Share on other sites
Tanamur

Hey

 

First I'm glad most of the show stoppers were dealt with it was quite tricky writing fixes without actually testing them. I forgot about the clock panel so I'll sort that out in a later release.

 

The MBC Splash screen does not appear to support overscan settings, this is a core MBC issue probably need to talk to ebr about this. The general config area suffers from the same behaviour.

 

The rush weather page has the same problems, but that is one that I can tackle.

Hi @@Soultaker - Thanks for doing all of changes so quickly and I will appreciate the clock and weather tweaks when you have time. Mr. PayPal should have sent you a message already.

 

To tidy up everything I uninstalled the extender from Media Center, factory reset the extender (60 seconds, deletes, cookies, resets server lists, etc) and set everything up again. This takes about 15 minutes and does require recopying a backup of the MB-Classis extender MBCommonXml.config file back into its folder. Altogether about a 20 minute job. In the end, the MB splash screen no longer fails but it did not correct the overscan issue there or in the Configurator and weather windows..

 

Cheers, Tanamur

Share this post


Link to post
Share on other sites
Tanamur

Hi @@Soultaker - I discovered one more area needing a tweak for the next release: EHS > Collection > View Menu > Thumb Strip

 

The description/synopsis box is still trying to maintain the blue background in "low fidelity" mode and looks wonky on the extender. Thanks, @Tanamur

 

52c20e3f6f4b3_rushthemeerror.jpg

Share this post


Link to post
Share on other sites
Tanamur

@@Soultaker - I guess that was quite a server & plugin update yesterday. Both the clock/time and the EHS > Collection > View Menu > Thumb Strip are both fixed and looking good. I had accidently deleted Rush during my general cleanup and troubleshooting in configurator so I wasn't prompted to update it. When I re-installed I hadn't noticed the version went from v0.12.16.0 to v1.0.1.0. When I fired up the extender today it was all a pleasant surprise. Thanks, Tanamur

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...