Jump to content


Photo

Buffering on NowTV

dev server buffering nowtv

  • Please log in to reply
12 replies to this topic

#1 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:23 AM
  • LocationSwindon, UK

Posted 18 January 2016 - 05:34 AM

Over the last week I seem to be getting a lot of buffering, so bad that a show/movie may play for a minute before buffering.

Not sure if it is a setting somewhere, the video filetype, or my server setup.

 

My server setup:

readynas nv+2 wired to router

Emby software on laptop connected wireless (laptop running windows 10)

NowTV connected wireless

 

Running Server Version 3.0.5859.40353

 

Server log: https://www.dropbox....672000.txt?dl=0

 

Transcoding log: https://www.dropbox....f9f837.txt?dl=0

 

The log is for just one show, but it is happening on multiple shows. I have tried turning off 'enable throttling', but that has not helped

 

Also, would replacing my nowtv box with a roku 3 (has ethernet) improve things on my current setup?


Edited by gillmacca, 18 January 2016 - 06:00 AM.


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 49864 posts
  • Local time: 05:23 AM

Posted 18 January 2016 - 09:28 AM

The problem is on the server end.  It is not transcoding fast enough to produce smooth video.  So, you need to investigate what is going on on the server machine when this happens.



#3 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:23 AM
  • LocationSwindon, UK

Posted 18 January 2016 - 10:28 AM

I know it's not a very fast server (something I am gonna address this year), but it seems strange that it has been fine for a good few months, Although, I just managed to play a movie all the way through without any buffering



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 49864 posts
  • Local time: 05:23 AM

Posted 18 January 2016 - 11:02 AM

The next time it happens investigate what else is going on on the server machine.  Maybe it is also running a library scan or some really intensive operation like a chapter image extraction.  Or, perhaps more then one stream is going at once.



#5 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:23 AM
  • LocationSwindon, UK

Posted 19 January 2016 - 09:12 AM

Nothing else is happening on the server (I have even turned off dlna). Chapter extraction is done when the library scan is run at 4 in the morning.

Think I may have solved it. Looks like episodes I am trying to watch are in HD, which the nowtv box I believe has trouble playing



#6 CBers OFFLINE  

CBers

    Advanced Member

  • Moderators
  • 15538 posts
  • Local time: 10:23 AM
  • LocationKent, England.

Posted 19 January 2016 - 09:35 AM

Think I may have solved it. Looks like episodes I am trying to watch are in HD, which the nowtv box I believe has trouble playing


Which Now TV box do you have, the v1 or v2?

My v1 Now TV box has always played HD content, so I doubt it's the box.

As ebr said, check the server and the PC the server is running on for anything spurious, including a rogue ffmpeg process.

#7 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:23 AM
  • LocationSwindon, UK

Posted 19 January 2016 - 09:38 AM

Can confirm it is not the nowtv box, as it buffers in chrome as well.

I have restarted my router, laptop and server and still getting buffering. 

I think maybe my server isn't powerful enough to stream hd



#8 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 49864 posts
  • Local time: 05:23 AM

Posted 19 January 2016 - 10:03 AM

I think maybe my server isn't powerful enough to stream hd

 

At this point, that would be my conclusion as well.  Looks like just a dual-core processor...?



#9 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5891 posts
  • Local time: 02:23 AM

Posted 19 January 2016 - 12:30 PM

What is the transcoding level set to on the server?

You are getting 16fps. The ac3 is why its transcoding. Your roku shows that it has detected stereo only. Since this is h264, and keyframes arent aligned at 3s intervals it cant copy the video stream. Maybe you can change your roku system hdmi and audio settings to get dolby detected? If you could do this you file would direct play.

Sent from my Nexus 7 using Tapatalk

#10 gillmacca OFFLINE  

gillmacca

    Advanced Member

  • Members
  • 331 posts
  • Local time: 10:23 AM
  • LocationSwindon, UK

Posted 19 January 2016 - 12:42 PM

I have transcoding set at auto with throttling. I have a nowtv which as far as I am aware, does not have access to hdmi and audio settings. There is an audio mode, but only has stereo as an option



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148965 posts
  • Local time: 05:23 AM

Posted 19 January 2016 - 12:45 PM

yea given the transcoding performance you will want to either consider upgrading your server or preparing your media so that it will direct play. to learn how to do that for the Roku app, check out our wiki page for the app:

 

https://github.com/M.../Wiki/wiki/Roku



#12 speechles OFFLINE  

speechles

    Advanced Member

  • App Developer
  • 5891 posts
  • Local time: 02:23 AM

Posted 19 January 2016 - 01:07 PM

You can try to set transcoding threads to max, and disable throttling. This should push more bits. But your laptop fan may whirrr up and it might heat it up. Just do this for a bit and see if you can get framerate above 24/30 fps. Otherwise, you need a tim taylor from the show home improvement to tell you, "You need more power!! Ugh grunt gunt ugh"

:)

Sent from my Nexus 7 using Tapatalk

Edited by speechles, 19 January 2016 - 01:08 PM.


#13 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 148965 posts
  • Local time: 05:23 AM

Posted 19 January 2016 - 01:10 PM

ffmpeg will already go full blast and there is no throttling appearing in that log so it shouldn't matter







Also tagged with one or more of these keywords: dev server, buffering, nowtv

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users